summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/jempbox
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/jempbox')
-rw-r--r--dev-java/jempbox/Manifest2
-rw-r--r--dev-java/jempbox/files/jempbox-1.7.1_maven-build.xml247
-rw-r--r--dev-java/jempbox/jempbox-0.2.0.ebuild71
-rw-r--r--dev-java/jempbox/jempbox-1.7.1.ebuild46
-rw-r--r--dev-java/jempbox/metadata.xml5
5 files changed, 371 insertions, 0 deletions
diff --git a/dev-java/jempbox/Manifest b/dev-java/jempbox/Manifest
new file mode 100644
index 000000000000..2eac58363ba0
--- /dev/null
+++ b/dev-java/jempbox/Manifest
@@ -0,0 +1,2 @@
+DIST JempBox-0.2.0.zip 6131627 SHA256 a4c6def91c31aaae4b8ee4b3f9ecebef73fce2f608bf7fc906a89a9bef17978e SHA512 8468028cf04d78e4bcbd2108f21c26e70d23a39f9ee897c2edf0a982c8981cdcbf1f6474f222021ac68e65dc0e5f6063d2603658f694a99ccac6ee52715c3aad WHIRLPOOL bb8659ab900b8920ace7afb8787d30ed4a00c701f0962106dcb1891f7829c83a04a4f9de09c9b7b682340bed06fb58622ffd4ff60d0defd39c5485363161137f
+DIST pdfbox-1.7.1-src.zip 9167805 SHA256 805c6b893ff10216cc826aa44e7a2eaf35bb43ca8ed19896c43132d253d3145e SHA512 8b2af3d8f431626c106e4f6e9e1d59d14abcd58cfdc9553f20c5057eef9f9cfbd0287e14e58e4d34472ad81198eb3f4d0a2fd6e88bd1fa5cbcf01e4befbf77d0 WHIRLPOOL 438fcd6f2d0128b972dfd5be83b2bc455daf9f126ac5b7a6a5de8a41e29f482b462e8e48e07a21ac1e896de4daa5ffed2eee400ec96ac93fbbce25fef99b0ade
diff --git a/dev-java/jempbox/files/jempbox-1.7.1_maven-build.xml b/dev-java/jempbox/files/jempbox-1.7.1_maven-build.xml
new file mode 100644
index 000000000000..453f9f69f665
--- /dev/null
+++ b/dev-java/jempbox/files/jempbox-1.7.1_maven-build.xml
@@ -0,0 +1,247 @@
+<?xml version="1.0" encoding="UTF-8"?>
+
+<!-- ====================================================================== -->
+<!-- Ant build file (http://ant.apache.org/) for Ant 1.6.2 or above. -->
+<!-- ====================================================================== -->
+
+<!-- ====================================================================== -->
+<!-- ===================== - DO NOT EDIT THIS FILE! - ===================== -->
+<!-- ====================================================================== -->
+<!-- -->
+<!-- Any modifications will be overwritten. -->
+<!-- -->
+<!-- Generated by Maven Ant Plugin on 8/2/12 4:32 PM -->
+<!-- See: http://maven.apache.org/plugins/maven-ant-plugin/ -->
+<!-- -->
+<!-- ====================================================================== -->
+
+<project name="jempbox-from-maven" default="package" basedir=".">
+
+ <!-- ====================================================================== -->
+ <!-- Build environment properties -->
+ <!-- ====================================================================== -->
+
+ <property file="${user.home}/.m2/maven.properties"/>
+ <property file="maven-build.properties"/>
+
+ <property name="maven.build.finalName" value="jempbox-1.7.1"/>
+ <property name="maven.build.dir" value="target"/>
+ <property name="maven.build.outputDir" value="${maven.build.dir}/classes"/>
+ <property name="maven.build.srcDir.0" value="src/main/java"/>
+ <property name="maven.build.resourceDir.0" value="src/main/resources"/>
+ <property name="maven.build.testOutputDir" value="${maven.build.dir}/test-classes"/>
+ <property name="maven.build.testDir.0" value="src/test/java"/>
+ <property name="maven.build.testResourceDir.0" value="src/test/resources"/>
+ <property name="maven.test.reports" value="${maven.build.dir}/test-reports"/>
+ <property name="maven.reporting.outputDirectory" value="${maven.build.dir}/site"/>
+
+ <property name="maven.repo.local" value="${user.home}/.m2/repository"/>
+ <property name="maven.settings.offline" value="false"/>
+ <property name="maven.settings.interactiveMode" value="true"/>
+
+ <!-- ====================================================================== -->
+ <!-- Defining classpaths -->
+ <!-- ====================================================================== -->
+
+ <path id="build.classpath"/>
+ <path id="build.test.classpath">
+ <pathelement location="${maven.repo.local}/junit/junit/4.8.1/junit-4.8.1.jar"/>
+ </path>
+
+ <!-- ====================================================================== -->
+ <!-- Cleaning up target -->
+ <!-- ====================================================================== -->
+
+ <target name="clean" description="Clean the output directory">
+ <delete dir="${maven.build.dir}"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile" depends="get-deps" description="Compile the code">
+ <mkdir dir="${maven.build.outputDir}"/>
+ <javac destdir="${maven.build.outputDir}"
+ nowarn="false"
+ debug="true"
+ optimize="false"
+ deprecation="true"
+ target="1.5"
+ verbose="false"
+ fork="false"
+ source="1.5">
+ <src>
+ <pathelement location="${maven.build.srcDir.0}"/>
+ </src>
+ <classpath refid="build.classpath"/>
+ </javac>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Test-compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile-tests"
+ depends="compile"
+ description="Compile the test code"
+ unless="maven.test.skip">
+ <mkdir dir="${maven.build.testOutputDir}"/>
+ <javac destdir="${maven.build.testOutputDir}"
+ nowarn="false"
+ debug="true"
+ optimize="false"
+ deprecation="true"
+ target="1.5"
+ verbose="false"
+ fork="false"
+ source="1.5">
+ <src>
+ <pathelement location="${maven.build.testDir.0}"/>
+ </src>
+ <classpath>
+ <path refid="build.test.classpath"/>
+ <pathelement location="${maven.build.outputDir}"/>
+ </classpath>
+ </javac>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Run all tests -->
+ <!-- ====================================================================== -->
+
+ <target name="test"
+ depends="compile-tests, junit-missing"
+ unless="junit.skipped"
+ description="Run the test cases">
+ <mkdir dir="${maven.test.reports}"/>
+ <junit printSummary="yes" haltonerror="true" haltonfailure="true" fork="true" dir=".">
+ <sysproperty key="basedir" value="."/>
+ <formatter type="xml"/>
+ <formatter type="plain" usefile="false"/>
+ <classpath>
+ <path refid="build.test.classpath"/>
+ <pathelement location="${maven.build.outputDir}"/>
+ <pathelement location="${maven.build.testOutputDir}"/>
+ </classpath>
+ <batchtest todir="${maven.test.reports}" unless="test">
+ <fileset dir="${maven.build.testDir.0}">
+ <include name="**/Test*.java"/>
+ <include name="**/*Test.java"/>
+ <include name="**/*TestCase.java"/>
+ <exclude name="**/*Abstract*Test.java"/>
+ </fileset>
+ </batchtest>
+ <batchtest todir="${maven.test.reports}" if="test">
+ <fileset dir="${maven.build.testDir.0}">
+ <include name="**/${test}.java"/>
+ <exclude name="**/*Abstract*Test.java"/>
+ </fileset>
+ </batchtest>
+ </junit>
+ </target>
+
+ <target name="test-junit-present">
+ <available classname="junit.framework.Test" property="junit.present"/>
+ </target>
+
+ <target name="test-junit-status"
+ depends="test-junit-present">
+ <condition property="junit.missing">
+ <and>
+ <isfalse value="${junit.present}"/>
+ <isfalse value="${maven.test.skip}"/>
+ </and>
+ </condition>
+ <condition property="junit.skipped">
+ <or>
+ <isfalse value="${junit.present}"/>
+ <istrue value="${maven.test.skip}"/>
+ </or>
+ </condition>
+ </target>
+
+ <target name="junit-missing"
+ depends="test-junit-status"
+ if="junit.missing">
+ <echo>=================================== WARNING ===================================</echo>
+ <echo> JUnit is not present in your $ANT_HOME/lib directory. Tests not executed.</echo>
+ <echo>===============================================================================</echo>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Javadoc target -->
+ <!-- ====================================================================== -->
+
+ <target name="javadoc" description="Generates the Javadoc of the application">
+ <javadoc sourcepath="${maven.build.srcDir.0}"
+ packagenames="*"
+ destdir="${maven.reporting.outputDirectory}/apidocs"
+ access="protected"
+ old="false"
+ verbose="false"
+ version="true"
+ use="true"
+ author="true"
+ splitindex="false"
+ nodeprecated="false"
+ nodeprecatedlist="false"
+ notree="false"
+ noindex="false"
+ nohelp="false"
+ nonavbar="false"
+ serialwarn="false"
+ charset="ISO-8859-1"
+ source="1.5"
+ linksource="false"
+ breakiterator="false">
+ <link href="http://download.oracle.com/javase/1.5.0/docs/api/"/>
+ </javadoc>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Package target -->
+ <!-- ====================================================================== -->
+
+ <target name="package" depends="compile,test" description="Package the application">
+ <jar jarfile="${maven.build.dir}/${maven.build.finalName}.jar"
+ compress="true"
+ index="false"
+ basedir="${maven.build.outputDir}"
+ excludes="**/package.html">
+ </jar>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- A dummy target for the package named after the type it creates -->
+ <!-- ====================================================================== -->
+
+ <target name="jar" depends="package" description="Builds the jar for the application"/>
+
+ <!-- ====================================================================== -->
+ <!-- Download dependencies target -->
+ <!-- ====================================================================== -->
+
+ <target name="test-offline">
+ <condition property="maven.mode.offline">
+ <equals arg1="${maven.settings.offline}" arg2="true"/>
+ </condition>
+ </target>
+
+ <target name="get-deps"
+ depends="test-offline"
+ description="Download all dependencies"
+ unless="maven.mode.offline">
+ <mkdir dir="${maven.repo.local}"/>
+ <mkdir dir="${maven.repo.local}/junit/junit/4.8.1"/>
+ <get src="http://repository.apache.org/snapshots/junit/junit/4.8.1/junit-4.8.1.jar"
+ dest="${maven.repo.local}/junit/junit/4.8.1/junit-4.8.1.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <get src="http://repo.maven.apache.org/maven2/junit/junit/4.8.1/junit-4.8.1.jar"
+ dest="${maven.repo.local}/junit/junit/4.8.1/junit-4.8.1.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ </target>
+
+</project>
diff --git a/dev-java/jempbox/jempbox-0.2.0.ebuild b/dev-java/jempbox/jempbox-0.2.0.ebuild
new file mode 100644
index 000000000000..8fce8938680d
--- /dev/null
+++ b/dev-java/jempbox/jempbox-0.2.0.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+JAVA_PKG_IUSE="doc source test"
+WANT_ANT_TASKS="ant-nodeps"
+inherit java-pkg-2 java-ant-2
+
+MY_PN="JempBox"
+MY_P="${MY_PN}-${PV}"
+DESCRIPTION="Java library that implements Adobe's XMP specification"
+HOMEPAGE="http://www.jempbox.org"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.zip"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+RDEPEND=">=virtual/jre-1.4"
+DEPEND=">=virtual/jdk-1.4
+ app-arch/unzip
+ test? ( dev-java/ant-junit =dev-java/junit-3* )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ rm -v lib/*.jar
+ rm -rf docs/javadoc
+
+ if use test; then
+ java-ant_xml-rewrite -f build.xml --change -e junit \
+ -a haltonfailure -v true
+ cd lib
+ java-pkg_jar-from --build-only junit
+ else
+ # no way to separate building of tests in build.xml
+ # at least it doesn't include them in <jar>
+ rm -rf src/test
+ fi
+}
+
+src_compile() {
+ eant package $(use_doc)
+
+ #tests delete the jar and javadocs so newjar, dojavadoc will fail to
+ #install jar and javadoc.
+ mkdir gentoo-dist
+ cp "lib/${MY_P}.jar" "gentoo-dist/${MY_P}.jar" || die "Failed to copy jar."
+ if use doc; then
+ cp -R website/build/site/javadoc gentoo-dist || die \
+ "Unable to copy javadoc"
+ fi
+}
+
+src_test() {
+ ANT_TASKS="ant-junit" eant junit
+}
+
+src_install() {
+ java-pkg_newjar "gentoo-dist/${MY_P}".jar
+
+ if use doc; then
+ dohtml -r docs/*
+ java-pkg_dojavadoc gentoo-dist/javadoc
+ fi
+
+ use source && java-pkg_dosrc src/org
+}
diff --git a/dev-java/jempbox/jempbox-1.7.1.ebuild b/dev-java/jempbox/jempbox-1.7.1.ebuild
new file mode 100644
index 000000000000..06251c03ceb3
--- /dev/null
+++ b/dev-java/jempbox/jempbox-1.7.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+JAVA_PKG_IUSE="doc source test"
+
+inherit java-pkg-2 java-ant-2
+
+MY_PN=pdfbox
+
+DESCRIPTION="An open source Java library for parsing font files"
+HOMEPAGE="http://pdfbox.apache.org/"
+SRC_URI="mirror://apache/${MY_PN}/${PV}/${MY_PN}-${PV}-src.zip"
+
+LICENSE="BSD"
+SLOT="1.7"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+RDEPEND="
+ >=virtual/jre-1.5"
+DEPEND="
+ >=virtual/jdk-1.5
+ app-arch/unzip
+ test? ( dev-java/ant-junit:0 )"
+
+S="${WORKDIR}/${MY_PN}-${PV}/${PN}"
+
+java_prepare() {
+ cp -v "${FILESDIR}"/${P}_maven-build.xml build.xml || die
+}
+
+JAVA_ANT_REWRITE_CLASSPATH="yes"
+
+src_test() {
+ java-pkg-2_src_test
+}
+
+src_install() {
+ java-pkg_newjar target/${P}.jar ${PN}.jar
+
+ use doc && java-pkg_dojavadoc target/site/apidocs
+ use source && java-pkg_dosrc src/main/java/org
+}
diff --git a/dev-java/jempbox/metadata.xml b/dev-java/jempbox/metadata.xml
new file mode 100644
index 000000000000..838c00a4a448
--- /dev/null
+++ b/dev-java/jempbox/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>java</herd>
+</pkgmetadata>