summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/spring-core
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/spring-core')
-rw-r--r--dev-java/spring-core/Manifest2
-rw-r--r--dev-java/spring-core/metadata.xml16
-rw-r--r--dev-java/spring-core/spring-core-3.2.4.ebuild84
3 files changed, 102 insertions, 0 deletions
diff --git a/dev-java/spring-core/Manifest b/dev-java/spring-core/Manifest
new file mode 100644
index 000000000000..c5987bbdfda6
--- /dev/null
+++ b/dev-java/spring-core/Manifest
@@ -0,0 +1,2 @@
+DIST spring-framework-3.2.4-buildscripts.tar.bz2 2894 SHA256 5a18b76fd55ffca6fbd8957436641287eeead9765de8fe07443fc5d52f03e043 SHA512 003551ffd37501c8b8dceba7ca484709cdf05f96c893d35c33161288770d72f70c092917f79216aa71742e045cb71ddcb17e6b58a2221fe2c153a70e5e0346b9 WHIRLPOOL ae8edd73bf272c3e92e07e5c341110d824703bbb8393a7f4af3ea9b0f306516a025888b2c3433ac0b7a2c3eedaf4236c3e201710e3fd77620290f5c6e28891c7
+DIST spring-framework-3.2.4.tar.gz 8925304 SHA256 0e0ad9631ea17a90fd8bc2565a7fb5b29ad12c1bf9ec9582f77019b5b041d08d SHA512 6a8fe58213f105deaa982b188e7b49a5bd9e0cf32917c568423509fed6b7c708cb5ca42ee7b3818327d673e59e7af7c67c13707e8a635329540b2febddda0f1b WHIRLPOOL f3dba92202402a676d8ad37c0b80d3a7616eecd780477ff21865305e2e2e5048b525ad9d14d36c0c0def96da305e3067e02617e10b949600ba819612f9edf48b
diff --git a/dev-java/spring-core/metadata.xml b/dev-java/spring-core/metadata.xml
new file mode 100644
index 000000000000..e6f191495093
--- /dev/null
+++ b/dev-java/spring-core/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+ <longdescription>
+ The Spring Framework provides a comprehensive programming and configuration model for
+ modern Java-based enterprise applications - on any kind of deployment platform. A key
+ element of Spring is infrastructural support at the application level: Spring focuses
+ on the "plumbing" of enterprise applications so that teams can focus on application-level
+ business logic, without unnecessary ties to specific deployment environments.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">SpringSource/spring-framework</remote-id>
+ </upstream>
+</pkgmetadata>
+
diff --git a/dev-java/spring-core/spring-core-3.2.4.ebuild b/dev-java/spring-core/spring-core-3.2.4.ebuild
new file mode 100644
index 000000000000..5bdd74dce8a7
--- /dev/null
+++ b/dev-java/spring-core/spring-core-3.2.4.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc source test"
+WANT_ANT_TASKS="dev-java/jarjar:1 dev-java/ant-junit:0"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="A comprehensive programming and configuration model for modern enterprise applications"
+HOMEPAGE="http://www.springsource.org/spring-framework"
+SRC_URI="https://github.com/SpringSource/spring-framework/archive/v${PV}.RELEASE.tar.gz -> spring-framework-${PV}.tar.gz
+ http://dev.gentoo.org/~ercpe/distfiles/dev-java/spring-framework/spring-framework-${PV}-buildscripts.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="3.2"
+KEYWORDS="amd64 x86"
+
+IUSE=""
+
+CDEPEND="
+ dev-java/commons-logging:0
+ dev-java/log4j:0
+ dev-java/aspectj:0
+ dev-java/asm:4
+ dev-java/cglib:3
+ dev-java/jopt-simple:4.4
+"
+
+DEPEND=">=virtual/jdk-1.7
+ test? (
+ >=dev-java/junit-4.11:4
+ dev-java/hamcrest-core:1.3
+ dev-java/hamcrest-library:1.3
+ dev-java/mockito:0
+ dev-java/xmlunit:1
+ )
+ ${CDEPEND}"
+
+RDEPEND=">=virtual/jre-1.7
+ ${CDEPEND}"
+
+S="${WORKDIR}/spring-framework-${PV}.RELEASE/"
+
+EANT_BUILD_XML=${S}/${PN}/build.xml
+
+JAVA_ANT_REWRITE_CLASSPATH="true"
+EANT_GENTOO_CLASSPATH="
+ commons-logging
+ log4j
+ aspectj
+ jopt-simple-4.4
+ asm-4"
+
+EANT_TEST_GENTOO_CLASSPATH="${EANT_GENTOO_CLASSPATH}
+ hamcrest-library-1.3
+ hamcrest-core-1.3
+ junit-4
+ mockito
+ xmlunit-1
+ junit-4"
+
+java_prepare() {
+ # see build.xml
+ mkdir "${S}/${PN}/lib/" || die
+ java-pkg_jar-from --build-only --into "${S}/${PN}/lib/" asm-4
+ java-pkg_jar-from --build-only --into "${S}/${PN}/lib/" cglib-3 cglib.jar
+
+ # broken test.
+ rm -v ${PN}/src/test/java/org/springframework/core/annotation/AnnotationUtilsTests.java
+}
+
+src_install() {
+ java-pkg_dojar "${S}"/${PN}/dist/{${PN},asm-renamed,cglib-renamed}.jar
+
+ use source && java-pkg_dosrc "${S}"/${PN}/src/main/java/org/
+ use doc && java-pkg_dojavadoc "${S}"/${PN}/dist/apidocs/
+}
+
+src_test() {
+ java-pkg-2_src_test
+}