summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2016-02-12 21:24:53 +0000
committerJames Le Cuirot <chewi@gentoo.org>2016-02-13 13:09:34 +0000
commit572751ef5d7b5f7d75b1e5669c9fc87c46d0a5b6 (patch)
tree6351c2ef86fdf88945b540f0886c26da50539bd8 /dev-java/swingx-ws
parentdev-java/swingx-beaninfo: New package, required by swingx-ws (diff)
downloadgentoo-572751ef5d7b5f7d75b1e5669c9fc87c46d0a5b6.tar.gz
gentoo-572751ef5d7b5f7d75b1e5669c9fc87c46d0a5b6.tar.bz2
gentoo-572751ef5d7b5f7d75b1e5669c9fc87c46d0a5b6.zip
dev-java/swingx-ws: New package, required by bt747
BT747 actually maintains its own incompatible fork, which I have included here in the bt747 SLOT. I would have put this in a separate package but the original project is long dead so that variant will safely remain at 1.0 forever. Package-Manager: portage-2.2.27
Diffstat (limited to 'dev-java/swingx-ws')
-rw-r--r--dev-java/swingx-ws/Manifest2
-rw-r--r--dev-java/swingx-ws/metadata.xml9
-rw-r--r--dev-java/swingx-ws/swingx-ws-1.0.ebuild50
-rw-r--r--dev-java/swingx-ws/swingx-ws-1.0_p20110515.ebuild63
4 files changed, 124 insertions, 0 deletions
diff --git a/dev-java/swingx-ws/Manifest b/dev-java/swingx-ws/Manifest
new file mode 100644
index 000000000000..95955333fe57
--- /dev/null
+++ b/dev-java/swingx-ws/Manifest
@@ -0,0 +1,2 @@
+DIST swingx-ws-1.0-sources.jar 281598 SHA256 b90e5915f959e25ba5789fb8e48821b1f6c7e8a10d0eb28dac264465de37db13 SHA512 722f8642e3a7c7825dd44cf01eca624b1d8a6bbfa829dbd7be326b53bf9d5467f48293489bbac6466ba9e74d991caaa6c9d56f0b7a08d205133926413517ca28 WHIRLPOOL ca2b512f5ec376f774df46d7b67f9ef01bce93cb0e41057cefe374e35d2558c1a7d9ed6bc5d5de0b205e5b2732490f200d562cb59a30876659abf8579a671157
+DIST swingx-ws-2011_05_15-src.zip 7010679 SHA256 30783793463d43a2b8303324059b0783466bef5bd889a8af4797b8aa39e65cf2 SHA512 1929bcd5d615e336fbf77f5c0406a15f0b8aae1ea2167106b8efe2708bf365b39a2313d2a22b5f77ca9559b161db5c50dc18d0cc4cebfcf7a0e4e0c978d4d5da WHIRLPOOL 96551039365386a70137d35a252299479a38389c38d26fc9dbf1e57035d40b96bbaa59c14c7f23f4a9b56f828fe10eb48c76cb886f6ab35c4d0a2cf2d2287ee1
diff --git a/dev-java/swingx-ws/metadata.xml b/dev-java/swingx-ws/metadata.xml
new file mode 100644
index 000000000000..08559768ae92
--- /dev/null
+++ b/dev-java/swingx-ws/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>java@gentoo.org</email>
+ <name>Java</name>
+ </maintainer>
+ <longdescription>Set of utilities and widgets to simplify interaction of Swing based GUIs with the web applications of any kind.</longdescription>
+</pkgmetadata>
diff --git a/dev-java/swingx-ws/swingx-ws-1.0.ebuild b/dev-java/swingx-ws/swingx-ws-1.0.ebuild
new file mode 100644
index 000000000000..b9844676df07
--- /dev/null
+++ b/dev-java/swingx-ws/swingx-ws-1.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Utilities and widgets to integrate Swing GUIs with web applications"
+HOMEPAGE="https://java.net/projects/swingx-ws/"
+SRC_URI="http://central.maven.org/maven2/org/swinglabs/${PN}/${PV}/${P}-sources.jar"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+CDEPEND="dev-java/commons-httpclient:3
+ dev-java/jdom:1.0
+ dev-java/json:0
+ dev-java/jtidy:0
+ dev-java/rome:0
+ dev-java/swingx:1.6
+ dev-java/swingx-beaninfo:0
+ dev-java/xerces:2
+ dev-java/xml-commons-external:1.4"
+
+RDEPEND=">=virtual/jre-1.6
+ ${CDEPEND}"
+
+DEPEND=">=virtual/jdk-1.6
+ ${CDEPEND}
+ app-arch/unzip"
+
+JAVA_GENTOO_CLASSPATH="commons-httpclient-3,jdom-1.0,json,jtidy,rome,swingx-1.6,swingx-beaninfo,xerces-2,xml-commons-external-1.4"
+
+java_prepare() {
+ # Fixes for newer swingx-beaninfo.
+ sed -i "s:BeanInfoSupport:org.jdesktop.beans.\0:g" org/jdesktop/swingx/*.java || die
+ find -name "*.java" -exec sed -i -r "s:org\.jdesktop\.swingx\.(editors|BeanInfoSupport|EnumerationValue):org.jdesktop.beans.\1:g" {} + || die
+
+ # GraphicsUtilities moved in later SwingX versions.
+ sed -i "s:org\.jdesktop\.swingx\.graphics\.GraphicsUtilities:org.jdesktop.swingx.util.GraphicsUtilities:g" \
+ org/jdesktop/swingx/mapviewer/AbstractTileFactory.java || die
+}
+
+src_compile() {
+ java-pkg-simple_src_compile
+ java-pkg_addres ${PN}.jar .
+}
diff --git a/dev-java/swingx-ws/swingx-ws-1.0_p20110515.ebuild b/dev-java/swingx-ws/swingx-ws-1.0_p20110515.ebuild
new file mode 100644
index 000000000000..238b617ab71b
--- /dev/null
+++ b/dev-java/swingx-ws/swingx-ws-1.0_p20110515.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+MY_P="${PN}-2011_05_15-src"
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Utilities and widgets to integrate Swing GUIs with web applications"
+HOMEPAGE="https://java.net/projects/swingx-ws/"
+SRC_URI="mirror://sourceforge/${PN}/Development/${MY_P}.zip"
+LICENSE="LGPL-2.1"
+SLOT="bt747"
+KEYWORDS="~amd64 ~x86"
+
+CDEPEND="dev-java/commons-httpclient:3
+ dev-java/jdom:1.0
+ dev-java/json:0
+ dev-java/jtidy:0
+ dev-java/rome:0
+ dev-java/swing-layout:1
+ dev-java/swingx:1.6
+ dev-java/swingx-beaninfo:0
+ dev-java/xerces:2
+ dev-java/xml-commons-external:1.4"
+
+RDEPEND=">=virtual/jre-1.6
+ ${CDEPEND}"
+
+DEPEND=">=virtual/jdk-1.6
+ ${CDEPEND}
+ app-arch/unzip"
+
+S="${WORKDIR}/${MY_P}/src"
+JAVA_SRC_DIR="beaninfo java"
+JAVA_GENTOO_CLASSPATH="commons-httpclient-3,jdom-1.0,json,jtidy,rome,swing-layout-1,swingx-1.6,swingx-beaninfo,xerces-2,xml-commons-external-1.4"
+
+java_prepare() {
+ java-pkg_clean "${WORKDIR}"
+
+ # SwingWorker has been built-in since Java 6.
+ find java -name "*.java" -exec sed -i -r "s:org\.jdesktop\.swingworker\.:javax.swing.:g" {} + || die
+
+ # Fixes for newer swingx-beaninfo.
+ sed -i "s:BeanInfoSupport:org.jdesktop.beans.\0:g" beaninfo/org/jdesktop/swingx/*.java || die
+ find beaninfo -name "*.java" -exec sed -i -r "s:org\.jdesktop\.swingx\.(editors|BeanInfoSupport|EnumerationValue):org.jdesktop.beans.\1:g" {} + || die
+
+ # GraphicsUtilities moved in later SwingX versions.
+ sed -i "s:org\.jdesktop\.swingx\.graphics\.GraphicsUtilities:org.jdesktop.swingx.util.GraphicsUtilities:g" \
+ java/org/jdesktop/swingx/mapviewer/AbstractTileFactory.java || die
+}
+
+src_compile() {
+ java-pkg-simple_src_compile
+
+ local DIR
+ for DIR in ${JAVA_SRC_DIR}; do
+ java-pkg_addres ${PN}.jar ${DIR}
+ done
+}