summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2015-09-26 00:22:27 +0100
committerJames Le Cuirot <chewi@gentoo.org>2015-09-26 00:22:27 +0100
commit375b1578abc8fe67c08778d963356d9c496df015 (patch)
tree7be9b5faaf1ab9c3d060454431ea862e2d4355be /dev-java/xstream
parentmedia-tv/tvbrowser: Remove dependency on stax (diff)
downloadgentoo-375b1578abc8fe67c08778d963356d9c496df015.tar.gz
gentoo-375b1578abc8fe67c08778d963356d9c496df015.tar.bz2
gentoo-375b1578abc8fe67c08778d963356d9c496df015.zip
dev-java/xstream: Remove the tests so we can last-rite dev-java/stax
The tests were completely broken anyway. Also update the HOMEPAGE and SRC_URI as Codehaus is dead. Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-java/xstream')
-rw-r--r--dev-java/xstream/xstream-1.3.1-r4.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/dev-java/xstream/xstream-1.3.1-r4.ebuild b/dev-java/xstream/xstream-1.3.1-r4.ebuild
new file mode 100644
index 000000000000..bd8cd61917a1
--- /dev/null
+++ b/dev-java/xstream/xstream-1.3.1-r4.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="A text-processing Java classes that serialize objects to XML and back again"
+HOMEPAGE="http://x-stream.github.io"
+SRC_URI="http://repo.maven.apache.org/maven2/com/thoughtworks/${PN}/${PN}-distribution/${PV}/${PN}-distribution-${PV}-src.zip"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+
+# By default, these tests exit successfully on failure. Chewi has fixed
+# that below but it's probably because they blow up spectacularly on
+# every VM he has tried. They also depend on classes unique to the
+# Codehaus StAX implementation (dev-java/stax), which has now been
+# last-rited, so we no longer bother to support them at all.
+RESTRICT="test"
+
+CDEPEND="dev-java/cglib:3
+ dev-java/dom4j:1
+ dev-java/jdom:1.0
+ dev-java/joda-time:0
+ dev-java/xom:0
+ dev-java/xpp3:0
+ dev-java/xml-commons-external:1.3
+ dev-java/jettison:0"
+
+RDEPEND=">=virtual/jre-1.6
+ ${CDEPEND}"
+
+DEPEND=">=virtual/jdk-1.6
+ app-arch/unzip
+ ${CDEPEND}"
+
+S="${WORKDIR}/${P}/${PN}"
+
+JAVA_ANT_REWRITE_CLASSPATH="true"
+EANT_GENTOO_CLASSPATH="xpp3,jdom-1.0,xom,dom4j-1,joda-time,cglib-3,xml-commons-external-1.3,jettison"
+EANT_BUILD_TARGET="benchmark:compile jar"
+EANT_EXTRA_ARGS="-Dversion=${PV} -Djunit.haltonfailure=true"
+
+java_prepare() {
+ rm -v lib/*.jar || die
+ rm -rfv lib/jdk1.3 || die
+}
+
+src_install(){
+ java-pkg_newjar target/${P}.jar
+ java-pkg_newjar target/${PN}-benchmark-${PV}.jar ${PN}-benchmark.jar
+
+ use doc && java-pkg_dojavadoc target/javadoc
+ use source && java-pkg_dosrc src/java/com
+}