summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2020-01-04 10:21:56 +0100
committerMiroslav Šulc <fordfrog@gentoo.org>2020-01-04 10:22:24 +0100
commit137fc9015bcce61dfbc1ba28744f5226a05ffca7 (patch)
tree4fad2d0bd087493f299dffcdfd08e264aa76d34d /dev-java
parentdev-python/turbolift: remove last-rited pkg (diff)
downloadgentoo-137fc9015bcce61dfbc1ba28744f5226a05ffca7.tar.gz
gentoo-137fc9015bcce61dfbc1ba28744f5226a05ffca7.tar.bz2
gentoo-137fc9015bcce61dfbc1ba28744f5226a05ffca7.zip
dev-java/balloontip: removed last rited package
Closes: https://bugs.gentoo.org/680452 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/balloontip/Manifest1
-rw-r--r--dev-java/balloontip/balloontip-1.2.1.ebuild38
-rw-r--r--dev-java/balloontip/files/balloontip-1.2.1-build.xml194
-rw-r--r--dev-java/balloontip/metadata.xml8
4 files changed, 0 insertions, 241 deletions
diff --git a/dev-java/balloontip/Manifest b/dev-java/balloontip/Manifest
deleted file mode 100644
index e73fed23821c..000000000000
--- a/dev-java/balloontip/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST balloontip_1.2.1.zip 822609 BLAKE2B db5e0f5687b6f03e0a0b62ed73a401240ff06d2eaafadc14e9a1946e9842fadf63176e7dbe6ff97f13b8e3b0c413356cc27c13ebfbcbb2994554971213c08240 SHA512 566e38767627b73324415b329d4f3e06e37572431bb34a022cbc81daf6057f9ab20da673702b2084a0026b70e7135aa8ae83f074ecea0c5a785e5006136ac91b
diff --git a/dev-java/balloontip/balloontip-1.2.1.ebuild b/dev-java/balloontip/balloontip-1.2.1.ebuild
deleted file mode 100644
index 8f12b47cfdd6..000000000000
--- a/dev-java/balloontip/balloontip-1.2.1.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-JAVA_PKG_IUSE="doc examples source"
-
-inherit eutils java-pkg-2 java-ant-2
-
-DESCRIPTION="A balloon tip component to spice up your Java Swing applications"
-HOMEPAGE="https://balloontip.java.net/"
-SRC_URI="https://java.net/projects/${PN}/downloads/download/${PN}_${PV}.zip"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-
-RDEPEND=">=virtual/jre-1.6"
-DEPEND=">=virtual/jdk-1.6"
-
-S="${WORKDIR}/${PN}_${PV}/src/${PN}"
-
-java_prepare() {
- find . -name "*.jar" -delete || die
-
- cp "${FILESDIR}"/${P}-build.xml build.xml || die
-}
-
-src_install() {
- java-pkg_newjar target/${P}.jar
-
- dodoc "${WORKDIR}"/${PN}_${PV}/README.txt
-
- use doc && java-pkg_dojavadoc target/site/apidocs
- use examples && java-pkg_doexamples "${S}-examples"
- use source && java-pkg_dosrc src/main/java/*
-
-}
diff --git a/dev-java/balloontip/files/balloontip-1.2.1-build.xml b/dev-java/balloontip/files/balloontip-1.2.1-build.xml
deleted file mode 100644
index 01613ad720ec..000000000000
--- a/dev-java/balloontip/files/balloontip-1.2.1-build.xml
+++ /dev/null
@@ -1,194 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-
-<!-- ====================================================================== -->
-<!-- Ant build file (http://ant.apache.org/) for Ant 1.6.2 or above. -->
-<!-- ====================================================================== -->
-
-<!-- ====================================================================== -->
-<!-- ===================== - DO NOT EDIT THIS FILE! - ===================== -->
-<!-- ====================================================================== -->
-<!-- -->
-<!-- Any modifications will be overwritten. -->
-<!-- -->
-<!-- Generated by Maven Ant Plugin on 7/13/13 1:34 PM -->
-<!-- See: http://maven.apache.org/plugins/maven-ant-plugin/ -->
-<!-- -->
-<!-- ====================================================================== -->
-
-<project name="balloontip-from-maven" default="package" basedir=".">
-
- <!-- ====================================================================== -->
- <!-- Build environment properties -->
- <!-- ====================================================================== -->
-
- <property file="${user.home}/.m2/maven.properties"/>
- <property file="maven-build.properties"/>
-
- <property name="maven.build.finalName" value="balloontip-1.2.1"/>
- <property name="maven.build.dir" value="target"/>
- <property name="maven.build.outputDir" value="${maven.build.dir}/classes"/>
- <property name="maven.build.srcDir.0" value="src/main/java"/>
- <property name="maven.build.resourceDir.0" value="src/main/resources"/>
- <property name="maven.build.testOutputDir" value="${maven.build.dir}/test-classes"/>
- <property name="maven.build.testDir.0" value="src/test/java"/>
- <property name="maven.build.testResourceDir.0" value="src/test/resources"/>
- <property name="maven.test.reports" value="${maven.build.dir}/test-reports"/>
- <property name="maven.reporting.outputDirectory" value="${maven.build.dir}/site"/>
-
- <property name="maven.repo.local" value="${user.home}/.m2/repository"/>
- <property name="maven.settings.offline" value="false"/>
- <property name="maven.settings.interactiveMode" value="true"/>
-
- <!-- ====================================================================== -->
- <!-- Defining classpaths -->
- <!-- ====================================================================== -->
-
- <path id="build.classpath"/>
- <path id="build.test.classpath"/>
-
- <!-- ====================================================================== -->
- <!-- Cleaning up target -->
- <!-- ====================================================================== -->
-
- <target name="clean" description="Clean the output directory">
- <delete dir="${maven.build.dir}"/>
- </target>
-
- <!-- ====================================================================== -->
- <!-- Compilation target -->
- <!-- ====================================================================== -->
-
- <target name="compile" depends="get-deps" description="Compile the code">
- <mkdir dir="${maven.build.outputDir}"/>
- <javac destdir="${maven.build.outputDir}"
- nowarn="false"
- debug="true"
- optimize="false"
- deprecation="true"
- target="1.5"
- verbose="false"
- fork="false"
- source="1.5">
- <src>
- <pathelement location="${maven.build.srcDir.0}"/>
- </src>
- <classpath refid="build.classpath"/>
- </javac>
- <copy todir="${maven.build.outputDir}">
- <fileset dir="${maven.build.resourceDir.0}"/>
- </copy>
- </target>
-
- <!-- ====================================================================== -->
- <!-- Test-compilation target -->
- <!-- ====================================================================== -->
-
- <target name="compile-tests"
- depends="compile"
- description="Compile the test code"
- unless="maven.test.skip">
- <mkdir dir="${maven.build.testOutputDir}"/>
- </target>
-
- <!-- ====================================================================== -->
- <!-- Run all tests -->
- <!-- ====================================================================== -->
-
- <target name="test"
- depends="compile-tests, junit-missing"
- unless="junit.skipped"
- description="Run the test cases"/>
-
- <target name="test-junit-present">
- <available classname="junit.framework.Test" property="junit.present"/>
- </target>
-
- <target name="test-junit-status"
- depends="test-junit-present">
- <condition property="junit.missing">
- <and>
- <isfalse value="${junit.present}"/>
- <isfalse value="${maven.test.skip}"/>
- </and>
- </condition>
- <condition property="junit.skipped">
- <or>
- <isfalse value="${junit.present}"/>
- <istrue value="${maven.test.skip}"/>
- </or>
- </condition>
- </target>
-
- <target name="junit-missing"
- depends="test-junit-status"
- if="junit.missing">
- <echo>=================================== WARNING ===================================</echo>
- <echo> JUnit is not present in your $ANT_HOME/lib directory. Tests not executed.</echo>
- <echo>===============================================================================</echo>
- </target>
-
- <!-- ====================================================================== -->
- <!-- Javadoc target -->
- <!-- ====================================================================== -->
-
- <target name="javadoc" description="Generates the Javadoc of the application">
- <javadoc sourcepath="${maven.build.srcDir.0}"
- packagenames="*"
- destdir="${maven.reporting.outputDirectory}/apidocs"
- access="protected"
- old="false"
- verbose="false"
- version="true"
- use="true"
- author="true"
- splitindex="false"
- nodeprecated="false"
- nodeprecatedlist="false"
- notree="false"
- noindex="false"
- nohelp="false"
- nonavbar="false"
- serialwarn="false"
- charset="ISO-8859-1"
- linksource="false"
- breakiterator="false">
- <bottom>&lt;![CDATA[&lt;a href=&quot;http://balloontip.java.net/&quot;&gt;http://balloontip.java.net/&lt;/a&gt;]]&gt;</bottom>
- </javadoc>
- </target>
-
- <!-- ====================================================================== -->
- <!-- Package target -->
- <!-- ====================================================================== -->
-
- <target name="package" depends="compile,test" description="Package the application">
- <jar jarfile="${maven.build.dir}/${maven.build.finalName}.jar"
- compress="true"
- index="false"
- basedir="${maven.build.outputDir}"
- excludes="**/package.html"/>
- </target>
-
- <!-- ====================================================================== -->
- <!-- A dummy target for the package named after the type it creates -->
- <!-- ====================================================================== -->
-
- <target name="jar" depends="package" description="Builds the jar for the application"/>
-
- <!-- ====================================================================== -->
- <!-- Download dependencies target -->
- <!-- ====================================================================== -->
-
- <target name="test-offline">
- <condition property="maven.mode.offline">
- <equals arg1="${maven.settings.offline}" arg2="true"/>
- </condition>
- </target>
-
- <target name="get-deps"
- depends="test-offline"
- description="Download all dependencies"
- unless="maven.mode.offline">
- <mkdir dir="${maven.repo.local}"/>
- </target>
-
-</project>
diff --git a/dev-java/balloontip/metadata.xml b/dev-java/balloontip/metadata.xml
deleted file mode 100644
index 2444066aa02b..000000000000
--- a/dev-java/balloontip/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<maintainer type="project">
- <email>java@gentoo.org</email>
- <name>Java</name>
-</maintainer>
-</pkgmetadata>