summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2019-05-14 16:06:17 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2019-05-14 16:06:45 -0700
commita957a9f513206d060421c9b09bef7334e7ce08ab (patch)
treeb49d2d9b5a538f7658238676052c30efa0b721a9 /dev-java
parentdev-java/openjdk-jre-bin: drop old :11 (diff)
downloadgentoo-a957a9f513206d060421c9b09bef7334e7ce08ab.tar.gz
gentoo-a957a9f513206d060421c9b09bef7334e7ce08ab.tar.bz2
gentoo-a957a9f513206d060421c9b09bef7334e7ce08ab.zip
dev-java/openjdk-jre-bin: drop old :8
Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/openjdk-jre-bin/openjdk-jre-bin-8.212_p03.ebuild94
1 files changed, 0 insertions, 94 deletions
diff --git a/dev-java/openjdk-jre-bin/openjdk-jre-bin-8.212_p03.ebuild b/dev-java/openjdk-jre-bin/openjdk-jre-bin-8.212_p03.ebuild
deleted file mode 100644
index 2af8e9e8e29d..000000000000
--- a/dev-java/openjdk-jre-bin/openjdk-jre-bin-8.212_p03.ebuild
+++ /dev/null
@@ -1,94 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit eapi7-ver java-vm-2
-
-abi_uri() {
- echo "${2-$1}? (
- https://github.com/AdoptOpenJDK/openjdk${SLOT}-binaries/releases/download/jdk${MY_PV}/OpenJDK8U-jre_${1}_linux_hotspot_${MY_PV/-/}.tar.gz
- )"
-}
-
-MY_PV=$(ver_rs 1 'u' 2 '-' ${PV//p/b})
-SLOT="$(ver_cut 1)"
-
-DESCRIPTION="Prebuilt Java JRE binaries provided by AdoptOpenJDK"
-HOMEPAGE="https://adoptopenjdk.net"
-SRC_URI="
- $(abi_uri x64 amd64)
-"
-
-LICENSE="GPL-2-with-classpath-exception"
-KEYWORDS="~amd64"
-
-IUSE="alsa cups +gentoo-vm headless-awt nsplugin selinux +webstart"
-
-RDEPEND="
- media-libs/fontconfig:1.0
- media-libs/freetype:2
- >net-libs/libnet-1.1
- >=sys-libs/glibc-2.2.5:*
- sys-libs/zlib
- alsa? ( media-libs/alsa-lib )
- cups? ( net-print/cups )
- selinux? ( sec-policy/selinux-java )
- !headless-awt? (
- x11-libs/libX11
- x11-libs/libXext
- x11-libs/libXi
- x11-libs/libXrender
- x11-libs/libXtst
- )"
-
-PDEPEND="
- webstart? ( >=dev-java/icedtea-web-1.6.1:0 )
- nsplugin? ( >=dev-java/icedtea-web-1.6.1:0[nsplugin] )"
-
-RESTRICT="preserve-libs splitdebug"
-QA_PREBUILT="*"
-
-S="${WORKDIR}/jdk${MY_PV}-jre"
-
-src_install() {
- local dest="/opt/${P}"
- local ddest="${ED}${dest#/}"
-
- rm ASSEMBLY_EXCEPTION LICENSE THIRD_PARTY_README || die
-
- # this does not exist on arm64 hence -f
- rm -fv lib/*/libfreetype.so* || die
-
- if ! use alsa ; then
- rm -v lib/*/libjsoundalsa.so* || die
- fi
-
- if use headless-awt ; then
- rm -fvr lib/*/lib*{[jx]awt,splashscreen}* \
- bin/policytool || die
- fi
-
- dodir "${dest}"
- cp -pPR * "${ddest}" || die
-
- use gentoo-vm && java-vm_install-env "${FILESDIR}"/${PN}-${SLOT}.env.sh
- java-vm_set-pax-markings "${ddest}"
- java-vm_revdep-mask
- java-vm_sandbox-predict /dev/random /proc/self/coredump_filter
-}
-
-pkg_postinst() {
- java-vm-2_pkg_postinst
-
- if use gentoo-vm ; then
- ewarn "WARNING! You have enabled the gentoo-vm USE flag, making this JRE"
- ewarn "recognised by the system. This will almost certainly break things."
- else
- ewarn "The experimental gentoo-vm USE flag has not been enabled so this JRE"
- ewarn "will not be recognised by the system. For example, simply calling"
- ewarn "\"java\" will launch a different JVM. This is necessary until Gentoo"
- ewarn "fully supports OpenJDK 8. This JRE must therefore be invoked using its"
- ewarn "absolute location under ${EPREFIX}/opt/${P}."
- fi
-}