summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2016-11-06 23:23:58 +0000
committerJames Le Cuirot <chewi@gentoo.org>2016-11-21 22:53:39 +0000
commitec860f9c8470f66833c41fbcdabe2d0d674fe601 (patch)
treef0df277454993425d779d3bc511a01f2387eecf7 /dev-java
parentdev-util/oprofile: fix bug 600000 (diff)
downloadgentoo-ec860f9c8470f66833c41fbcdabe2d0d674fe601.tar.gz
gentoo-ec860f9c8470f66833c41fbcdabe2d0d674fe601.tar.bz2
gentoo-ec860f9c8470f66833c41fbcdabe2d0d674fe601.zip
dev-java/commons-cli: Bump to 1.3.1, EAPI bump to 6
Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/commons-cli/Manifest1
-rw-r--r--dev-java/commons-cli/commons-cli-1.3.1.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-java/commons-cli/Manifest b/dev-java/commons-cli/Manifest
index 3e0b5bcc93db..02a26584a324 100644
--- a/dev-java/commons-cli/Manifest
+++ b/dev-java/commons-cli/Manifest
@@ -1 +1,2 @@
DIST commons-cli-1.2-src.tar.gz 68594 SHA256 b589cd675866aec12a068e0717f2bd52ead6128c43ba1612a8815db1df7f6e67 SHA512 61759cf0c791c4308b4df6a6c163b4abbb5e07909ba4904ad6565f6453ecad2ecbdc2d2df3e113b469f0d621866dfd7de07b857949ca7607c02c8ec75740eb80 WHIRLPOOL f89a34ca0f66b83643f54a976793f08d8d77b90f886fdc991e091495186050fb6424d04da10affb072367bbffb96faaf763cebf782d7fd11366c84678e826019
+DIST commons-cli-1.3.1-src.tar.gz 145886 SHA256 d4f7eedf6def7cd574ff9b0050a5a7203a702ed13c88d9fbb85b84284ab172ba SHA512 b5c569bea3c213a1959ae698894f2234477a7a5ed246f8e81142041173f668802959be018011bce6aa2a5631081378e67d69eeba9136fa19c96193dbdf2a7d15 WHIRLPOOL 2e589f5644c5d7cead5bb88364cd982a717b7eab33c50c9ff0dc14d562d5eb92e6f76f7e80c2b356d08cf1e80b6943d81d7f98f554b4de54fc394916c9e4c56e
diff --git a/dev-java/commons-cli/commons-cli-1.3.1.ebuild b/dev-java/commons-cli/commons-cli-1.3.1.ebuild
new file mode 100644
index 000000000000..430008ac0472
--- /dev/null
+++ b/dev-java/commons-cli/commons-cli-1.3.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="A Java library for working with the command line arguments and options"
+HOMEPAGE="http://commons.apache.org/cli/"
+SRC_URI="mirror://apache/commons/cli/source/${P}-src.tar.gz"
+LICENSE="Apache-2.0"
+SLOT="1"
+KEYWORDS="~amd64 ~ppc64 ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="test"
+
+RDEPEND=">=virtual/jre-1.7"
+
+DEPEND=">=virtual/jdk-1.7
+ test? ( dev-java/junit:4 )"
+
+S="${WORKDIR}/${P}-src"
+JAVA_SRC_DIR="src/main/java"
+
+src_install() {
+ java-pkg-simple_src_install
+ dodoc CONTRIBUTING.md NOTICE.txt README.md RELEASE-NOTES.txt
+}
+
+src_test() {
+ cd src/test/java || die
+
+ local CP=".:${S}/${PN}.jar:$(java-pkg_getjars junit-4)"
+ local TESTS=$(find * -name "*Test.java")
+ TESTS="${TESTS//.java}"
+ TESTS="${TESTS//\//.}"
+
+ ejavac -cp "${CP}" -d . $(find * -name "*.java")
+ ejunit4 -classpath "${CP}" ${TESTS}
+}