summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2016-04-19 09:36:17 -0700
committerZac Medico <zmedico@gentoo.org>2016-04-19 09:37:10 -0700
commitbf6b2654d8d63ffb965881f58d49eb7f832c681c (patch)
tree7d6feaabd85e61f2948171ea190cbf7c53b409d3 /dev-lang/go
parentnet-fs/samba: arm stable, bug #578004 (diff)
downloadgentoo-bf6b2654d8d63ffb965881f58d49eb7f832c681c.tar.gz
gentoo-bf6b2654d8d63ffb965881f58d49eb7f832c681c.tar.bz2
gentoo-bf6b2654d8d63ffb965881f58d49eb7f832c681c.zip
dev-lang/go: fix gccgo support to use gcc-config --get-bin-path (bug 579958)
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-lang/go')
-rw-r--r--dev-lang/go/go-1.6.1.ebuild2
1 files changed, 1 insertions, 1 deletions
diff --git a/dev-lang/go/go-1.6.1.ebuild b/dev-lang/go/go-1.6.1.ebuild
index 0cf5b7c56094..c70fc26e5293 100644
--- a/dev-lang/go/go-1.6.1.ebuild
+++ b/dev-lang/go/go-1.6.1.ebuild
@@ -152,7 +152,7 @@ src_compile()
export GOROOT_BOOTSTRAP="${WORKDIR}"/go-$(go_os)-$(go_arch)-bootstrap
if use gccgo; then
mkdir -p "${GOROOT_BOOTSTRAP}/bin" || die
- local go_binary=$(type -P go-5 2>/dev/null)
+ local go_binary=$(gcc-config --get-bin-path)/go-5
[[ -x ${go_binary} ]] || go_binary=$(
find "${EPREFIX}"/usr/${CHOST}/gcc-bin/*/go-5 | sort -V | tail -n1)
[[ -x ${go_binary} ]] || die "go-5: command not found"