summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-01-22 20:00:56 +0100
committerJustin Lecher <jlec@gentoo.org>2016-01-22 22:03:03 +0100
commit0dbd28d2e94105b4faaea44fc578ecbc8874efb4 (patch)
treeae9af68d370ed5f86adbfe793c7df9f1802802fa /dev-lang/mercury
parentx11-terms/rxvt-unicode: Use ecvs_clean to clean workdir (diff)
downloadgentoo-0dbd28d2e94105b4faaea44fc578ecbc8874efb4.tar.gz
gentoo-0dbd28d2e94105b4faaea44fc578ecbc8874efb4.tar.bz2
gentoo-0dbd28d2e94105b4faaea44fc578ecbc8874efb4.zip
dev-lang/mercury: Use ecvs_clean to clean workdir
* add missing die Package-Manager: portage-2.2.27 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-lang/mercury')
-rw-r--r--dev-lang/mercury/mercury-11.01.ebuild11
-rw-r--r--dev-lang/mercury/mercury-11.07.1.ebuild11
-rw-r--r--dev-lang/mercury/mercury-11.07.2.ebuild11
-rw-r--r--dev-lang/mercury/mercury-11.07.ebuild11
-rw-r--r--dev-lang/mercury/mercury-13.05.1.ebuild11
-rw-r--r--dev-lang/mercury/mercury-13.05.2.ebuild11
-rw-r--r--dev-lang/mercury/mercury-13.05.ebuild11
-rw-r--r--dev-lang/mercury/metadata.xml14
8 files changed, 42 insertions, 49 deletions
diff --git a/dev-lang/mercury/mercury-11.01.ebuild b/dev-lang/mercury/mercury-11.01.ebuild
index bb7c875926c4..f8f9bc74e90d 100644
--- a/dev-lang/mercury/mercury-11.01.ebuild
+++ b/dev-lang/mercury/mercury-11.01.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -36,7 +36,7 @@ TESTDIR="${WORKDIR}"/${PN}-tests-${PV}
SITEFILE=50${PN}-gentoo.el
src_prepare() {
- cd "${WORKDIR}"
+ cd "${WORKDIR}" || die
EPATCH_FORCE=yes
EPATCH_SUFFIX=patch
epatch "${WORKDIR}"/${PV}
@@ -49,7 +49,7 @@ src_prepare() {
epatch "${WORKDIR}"/${PV}-tests
fi
- cd "${S}"
+ cd "${S}" || die
eautoconf
}
@@ -132,7 +132,7 @@ src_test() {
TWS="${S}"
fi
- cd "${TESTDIR}"
+ cd "${TESTDIR}" || die
sed -i -e "s:@WORKSPACE@:${TWS}:" WS_FLAGS.ws \
|| die "sed WORKSPACE failed"
@@ -202,8 +202,7 @@ src_install() {
doins -r samples/java_interface || die
fi
- rm -rf $(find "${D}"/usr/share/doc/${PF}/samples \
- -name CVS -o -name .cvsignore)
+ ecvs_clean "${D}"/usr/share/doc/${PF}/samples
fi
}
diff --git a/dev-lang/mercury/mercury-11.07.1.ebuild b/dev-lang/mercury/mercury-11.07.1.ebuild
index fbc3732e2913..f143a22674d5 100644
--- a/dev-lang/mercury/mercury-11.07.1.ebuild
+++ b/dev-lang/mercury/mercury-11.07.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -36,7 +36,7 @@ TESTDIR="${WORKDIR}"/${PN}-tests-${PV}
SITEFILE=50${PN}-gentoo.el
src_prepare() {
- cd "${WORKDIR}"
+ cd "${WORKDIR}" || die
EPATCH_FORCE=yes
EPATCH_SUFFIX=patch
epatch "${WORKDIR}"/${PV}
@@ -49,7 +49,7 @@ src_prepare() {
epatch "${WORKDIR}"/${PV}-tests
fi
- cd "${S}"
+ cd "${S}" || die
eautoconf
}
@@ -132,7 +132,7 @@ src_test() {
TWS="${S}"
fi
- cd "${TESTDIR}"
+ cd "${TESTDIR}" || die
sed -i -e "s:@WORKSPACE@:${TWS}:" WS_FLAGS.ws \
|| die "sed WORKSPACE failed"
@@ -202,8 +202,7 @@ src_install() {
doins -r samples/java_interface || die
fi
- rm -rf $(find "${D}"/usr/share/doc/${PF}/samples \
- -name CVS -o -name .cvsignore)
+ ecvs_clean "${D}"/usr/share/doc/${PF}/samples
fi
}
diff --git a/dev-lang/mercury/mercury-11.07.2.ebuild b/dev-lang/mercury/mercury-11.07.2.ebuild
index 9d8b6487a7e2..74cb440ab3c2 100644
--- a/dev-lang/mercury/mercury-11.07.2.ebuild
+++ b/dev-lang/mercury/mercury-11.07.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -36,7 +36,7 @@ TESTDIR="${WORKDIR}"/${PN}-tests-${PV}
SITEFILE=50${PN}-gentoo.el
src_prepare() {
- cd "${WORKDIR}"
+ cd "${WORKDIR}" || die
EPATCH_FORCE=yes
EPATCH_SUFFIX=patch
epatch "${WORKDIR}"/${PV}
@@ -49,7 +49,7 @@ src_prepare() {
epatch "${WORKDIR}"/${PV}-tests
fi
- cd "${S}"
+ cd "${S}" || die
eautoconf
}
@@ -132,7 +132,7 @@ src_test() {
TWS="${S}"
fi
- cd "${TESTDIR}"
+ cd "${TESTDIR}" || die
sed -i -e "s:@WORKSPACE@:${TWS}:" WS_FLAGS.ws \
|| die "sed WORKSPACE failed"
@@ -202,8 +202,7 @@ src_install() {
doins -r samples/java_interface || die
fi
- rm -rf $(find "${D}"/usr/share/doc/${PF}/samples \
- -name CVS -o -name .cvsignore)
+ ecvs_clean "${D}"/usr/share/doc/${PF}/samples
fi
}
diff --git a/dev-lang/mercury/mercury-11.07.ebuild b/dev-lang/mercury/mercury-11.07.ebuild
index 2792e67fc652..6883d4424fce 100644
--- a/dev-lang/mercury/mercury-11.07.ebuild
+++ b/dev-lang/mercury/mercury-11.07.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -36,7 +36,7 @@ TESTDIR="${WORKDIR}"/${PN}-tests-${PV}
SITEFILE=50${PN}-gentoo.el
src_prepare() {
- cd "${WORKDIR}"
+ cd "${WORKDIR}" || die
EPATCH_FORCE=yes
EPATCH_SUFFIX=patch
epatch "${WORKDIR}"/${PV}
@@ -49,7 +49,7 @@ src_prepare() {
epatch "${WORKDIR}"/${PV}-tests
fi
- cd "${S}"
+ cd "${S}" || die
eautoconf
}
@@ -132,7 +132,7 @@ src_test() {
TWS="${S}"
fi
- cd "${TESTDIR}"
+ cd "${TESTDIR}" || die
sed -i -e "s:@WORKSPACE@:${TWS}:" WS_FLAGS.ws \
|| die "sed WORKSPACE failed"
@@ -202,8 +202,7 @@ src_install() {
doins -r samples/java_interface || die
fi
- rm -rf $(find "${D}"/usr/share/doc/${PF}/samples \
- -name CVS -o -name .cvsignore)
+ ecvs_clean "${D}"/usr/share/doc/${PF}/samples
fi
}
diff --git a/dev-lang/mercury/mercury-13.05.1.ebuild b/dev-lang/mercury/mercury-13.05.1.ebuild
index c0fcf9dd7b20..44f38dcacd48 100644
--- a/dev-lang/mercury/mercury-13.05.1.ebuild
+++ b/dev-lang/mercury/mercury-13.05.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -34,7 +34,7 @@ S="${WORKDIR}"/${MY_P}
SITEFILE=50${PN}-gentoo.el
src_prepare() {
- cd "${WORKDIR}"
+ cd "${WORKDIR}" || die
EPATCH_FORCE=yes
EPATCH_SUFFIX=patch
epatch "${WORKDIR}"/${PV}
@@ -43,7 +43,7 @@ src_prepare() {
"${S}"/scripts/Mmake.vars.in \
|| die "sed libdir failed"
- cd "${S}"
+ cd "${S}" || die
eautoconf
}
@@ -117,7 +117,7 @@ src_test() {
TWS="${S}"
fi
- cd "${S}"/tests
+ cd "${S}"/tests || die
sed -e "s:@WORKSPACE@:${TWS}:" < WS_FLAGS.ws > WS_FLAGS \
|| die "sed WORKSPACE failed"
@@ -183,8 +183,7 @@ src_install() {
doins -r samples/java_interface || die
fi
- rm -rf $(find "${D}"/usr/share/doc/${PF}/samples \
- -name CVS -o -name .cvsignore)
+ ecvs_clean "${D}"/usr/share/doc/${PF}/samples
fi
}
diff --git a/dev-lang/mercury/mercury-13.05.2.ebuild b/dev-lang/mercury/mercury-13.05.2.ebuild
index c82ce14cb01c..44f38dcacd48 100644
--- a/dev-lang/mercury/mercury-13.05.2.ebuild
+++ b/dev-lang/mercury/mercury-13.05.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -34,7 +34,7 @@ S="${WORKDIR}"/${MY_P}
SITEFILE=50${PN}-gentoo.el
src_prepare() {
- cd "${WORKDIR}"
+ cd "${WORKDIR}" || die
EPATCH_FORCE=yes
EPATCH_SUFFIX=patch
epatch "${WORKDIR}"/${PV}
@@ -43,7 +43,7 @@ src_prepare() {
"${S}"/scripts/Mmake.vars.in \
|| die "sed libdir failed"
- cd "${S}"
+ cd "${S}" || die
eautoconf
}
@@ -117,7 +117,7 @@ src_test() {
TWS="${S}"
fi
- cd "${S}"/tests
+ cd "${S}"/tests || die
sed -e "s:@WORKSPACE@:${TWS}:" < WS_FLAGS.ws > WS_FLAGS \
|| die "sed WORKSPACE failed"
@@ -183,8 +183,7 @@ src_install() {
doins -r samples/java_interface || die
fi
- rm -rf $(find "${D}"/usr/share/doc/${PF}/samples \
- -name CVS -o -name .cvsignore)
+ ecvs_clean "${D}"/usr/share/doc/${PF}/samples
fi
}
diff --git a/dev-lang/mercury/mercury-13.05.ebuild b/dev-lang/mercury/mercury-13.05.ebuild
index 3092ceb62089..7cefb73dd54b 100644
--- a/dev-lang/mercury/mercury-13.05.ebuild
+++ b/dev-lang/mercury/mercury-13.05.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -34,7 +34,7 @@ S="${WORKDIR}"/${MY_P}
SITEFILE=50${PN}-gentoo.el
src_prepare() {
- cd "${WORKDIR}"
+ cd "${WORKDIR}" || die
EPATCH_FORCE=yes
EPATCH_SUFFIX=patch
epatch "${WORKDIR}"/${PV}
@@ -43,7 +43,7 @@ src_prepare() {
"${S}"/scripts/Mmake.vars.in \
|| die "sed libdir failed"
- cd "${S}"
+ cd "${S}" || die
eautoconf
}
@@ -116,7 +116,7 @@ src_test() {
TWS="${S}"
fi
- cd "${S}"/tests
+ cd "${S}"/tests || die
sed -e "s:@WORKSPACE@:${TWS}:" < WS_FLAGS.ws > WS_FLAGS \
|| die "sed WORKSPACE failed"
@@ -182,8 +182,7 @@ src_install() {
doins -r samples/java_interface || die
fi
- rm -rf $(find "${D}"/usr/share/doc/${PF}/samples \
- -name CVS -o -name .cvsignore)
+ ecvs_clean "${D}"/usr/share/doc/${PF}/samples
fi
}
diff --git a/dev-lang/mercury/metadata.xml b/dev-lang/mercury/metadata.xml
index 1af61abf4524..7e9ce0ae4c47 100644
--- a/dev-lang/mercury/metadata.xml
+++ b/dev-lang/mercury/metadata.xml
@@ -1,11 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<maintainer>
- <email>keri@gentoo.org</email>
- <name>Keri Harris</name>
-</maintainer>
-<use>
- <flag name='erlang'>Support Mercury Erlang grade</flag>
-</use>
+ <maintainer>
+ <email>keri@gentoo.org</email>
+ <name>Keri Harris</name>
+ </maintainer>
+ <use>
+ <flag name="erlang">Support Mercury Erlang grade</flag>
+ </use>
</pkgmetadata>