summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2015-10-22 15:24:50 -0500
committerWilliam Hubbs <williamh@gentoo.org>2015-10-22 15:24:50 -0500
commit15e4adef9f7ba22fc33515f28954a704c7c79dc7 (patch)
treee164551671ff24fc79bf9a237b5aac485bcd0c8e /dev-lang
parentsys-apps/dbus: Fix machine-id symlink when ROOT != / (diff)
downloadgentoo-15e4adef9f7ba22fc33515f28954a704c7c79dc7.tar.gz
gentoo-15e4adef9f7ba22fc33515f28954a704c7c79dc7.tar.bz2
gentoo-15e4adef9f7ba22fc33515f28954a704c7c79dc7.zip
dev-lang/go: Do Not include testdata as part of the dependencies
This is for bug #563744
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/go/go-1.4.2.ebuild2
-rw-r--r--dev-lang/go/go-1.5.1.ebuild2
-rw-r--r--dev-lang/go/go-1.5.ebuild2
-rw-r--r--dev-lang/go/go-9999.ebuild2
4 files changed, 8 insertions, 0 deletions
diff --git a/dev-lang/go/go-1.4.2.ebuild b/dev-lang/go/go-1.4.2.ebuild
index 4de9d439bf4d..8384e081cd1b 100644
--- a/dev-lang/go/go-1.4.2.ebuild
+++ b/dev-lang/go/go-1.4.2.ebuild
@@ -32,6 +32,8 @@ QA_EXECSTACK="
usr/lib/go/src/debug/elf/testdata/go-relocation-test-gcc482-aarch64.obj
usr/lib/go/src/debug/elf/testdata/gcc-amd64-openbsd-debug-with-rela.obj"
+ REQUIRES_EXCLUDE="/usr/lib/go/src/debug/elf/testdata/*"
+
# The tools in /usr/lib/go should not cause the multilib-strict check to fail.
QA_MULTILIB_PATHS="usr/lib/go/pkg/tool/.*/.*"
diff --git a/dev-lang/go/go-1.5.1.ebuild b/dev-lang/go/go-1.5.1.ebuild
index b34ebb3aaf85..8d4c7158d828 100644
--- a/dev-lang/go/go-1.5.1.ebuild
+++ b/dev-lang/go/go-1.5.1.ebuild
@@ -32,6 +32,8 @@ RDEPEND="!<dev-go/go-tools-0_pre20150902"
# These test data objects have writable/executable stacks.
QA_EXECSTACK="usr/lib/go/src/debug/elf/testdata/*.obj"
+REQUIRES_EXCLUDE="/usr/lib/go/src/debug/elf/testdata/*"
+
# The tools in /usr/lib/go should not cause the multilib-strict check to fail.
QA_MULTILIB_PATHS="usr/lib/go/pkg/tool/.*/.*"
diff --git a/dev-lang/go/go-1.5.ebuild b/dev-lang/go/go-1.5.ebuild
index 6fc180ca12dc..c04ba93e317e 100644
--- a/dev-lang/go/go-1.5.ebuild
+++ b/dev-lang/go/go-1.5.ebuild
@@ -32,6 +32,8 @@ RDEPEND=""
# These test data objects have writable/executable stacks.
QA_EXECSTACK="usr/lib/go/src/debug/elf/testdata/*.obj"
+REQUIRES_EXCLUDE="/usr/lib/go/src/debug/elf/testdata/*"
+
# The tools in /usr/lib/go should not cause the multilib-strict check to fail.
QA_MULTILIB_PATHS="usr/lib/go/pkg/tool/.*/.*"
diff --git a/dev-lang/go/go-9999.ebuild b/dev-lang/go/go-9999.ebuild
index b34ebb3aaf85..8d4c7158d828 100644
--- a/dev-lang/go/go-9999.ebuild
+++ b/dev-lang/go/go-9999.ebuild
@@ -32,6 +32,8 @@ RDEPEND="!<dev-go/go-tools-0_pre20150902"
# These test data objects have writable/executable stacks.
QA_EXECSTACK="usr/lib/go/src/debug/elf/testdata/*.obj"
+REQUIRES_EXCLUDE="/usr/lib/go/src/debug/elf/testdata/*"
+
# The tools in /usr/lib/go should not cause the multilib-strict check to fail.
QA_MULTILIB_PATHS="usr/lib/go/pkg/tool/.*/.*"