summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2017-07-18 10:26:53 -0400
committerBrian Evans <grknight@gentoo.org>2017-07-18 10:26:53 -0400
commit9d968e14aeb899589d696343170a32045f79c76a (patch)
tree5bd2493d9730fa2913abcb87adbe7f8d683d1890 /dev-lang
parentmedia-video/mpv: revbump to update patchset (diff)
downloadgentoo-9d968e14aeb899589d696343170a32045f79c76a.tar.gz
gentoo-9d968e14aeb899589d696343170a32045f79c76a.tar.bz2
gentoo-9d968e14aeb899589d696343170a32045f79c76a.zip
dev-lang/php: Final REQUIRED_USE tweaks for usability
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/php/php-5.6.30.ebuild7
-rw-r--r--dev-lang/php/php-5.6.31.ebuild2
-rw-r--r--dev-lang/php/php-7.0.15.ebuild5
-rw-r--r--dev-lang/php/php-7.0.19.ebuild5
-rw-r--r--dev-lang/php/php-7.0.21.ebuild2
5 files changed, 11 insertions, 10 deletions
diff --git a/dev-lang/php/php-5.6.30.ebuild b/dev-lang/php/php-5.6.30.ebuild
index 802119c18f71..0dd5527d5e9e 100644
--- a/dev-lang/php/php-5.6.30.ebuild
+++ b/dev-lang/php/php-5.6.30.ebuild
@@ -145,12 +145,12 @@ DEPEND="${COMMON_DEPEND}
# Without USE=readline or libedit, the interactive "php -a" CLI will hang.
REQUIRED_USE="
+ || ( cli cgi fpm apache2 embed )
cli? ( ^^ ( readline libedit ) )
truetype? ( gd )
vpx? ( gd )
cjk? ( gd )
exif? ( gd )
-
xpm? ( gd )
gd? ( zlib )
simplexml? ( xml )
@@ -162,6 +162,7 @@ REQUIRED_USE="
ldap-sasl? ( ldap )
mhash? ( hash )
phar? ( hash )
+ recode? ( !imap !mysql !mysqli !libmysqlclient )
libmysqlclient? ( || (
mysql
mysqli
@@ -170,10 +171,8 @@ REQUIRED_USE="
qdbm? ( !gdbm )
readline? ( !libedit )
- recode? ( !imap !mysql !mysqli )
sharedmem? ( !threads )
-
- !cli? ( !cgi? ( !fpm? ( !apache2? ( !embed? ( cli ) ) ) ) )"
+"
PHP_MV="$(get_major_version)"
diff --git a/dev-lang/php/php-5.6.31.ebuild b/dev-lang/php/php-5.6.31.ebuild
index 7310a78821e8..0548b46abbe2 100644
--- a/dev-lang/php/php-5.6.31.ebuild
+++ b/dev-lang/php/php-5.6.31.ebuild
@@ -147,12 +147,12 @@ DEPEND="${COMMON_DEPEND}
REQUIRED_USE="
|| ( cli cgi fpm apache2 embed )
cli? ( ^^ ( readline libedit ) )
- gd? ( zlib )
truetype? ( gd )
vpx? ( gd )
cjk? ( gd )
exif? ( gd )
xpm? ( gd )
+ gd? ( zlib )
simplexml? ( xml )
soap? ( xml )
wddx? ( xml )
diff --git a/dev-lang/php/php-7.0.15.ebuild b/dev-lang/php/php-7.0.15.ebuild
index 0d130a0e2920..9d14cd817c28 100644
--- a/dev-lang/php/php-7.0.15.ebuild
+++ b/dev-lang/php/php-7.0.15.ebuild
@@ -139,6 +139,7 @@ DEPEND="${COMMON_DEPEND}
# Without USE=readline or libedit, the interactive "php -a" CLI will hang.
REQUIRED_USE="
+ || ( cli cgi fpm apache2 embed phpdbg )
cli? ( ^^ ( readline libedit ) )
truetype? ( gd )
webp? ( gd )
@@ -157,10 +158,10 @@ REQUIRED_USE="
phar? ( hash )
qdbm? ( !gdbm )
readline? ( !libedit )
- recode? ( !imap !mysqli )
+ recode? ( !imap !mysqli !mysql )
sharedmem? ( !threads )
mysql? ( || ( mysqli pdo ) )
- || ( cli cgi fpm apache2 embed phpdbg )"
+"
PHP_MV="$(get_major_version)"
diff --git a/dev-lang/php/php-7.0.19.ebuild b/dev-lang/php/php-7.0.19.ebuild
index c0316ea85092..6d0d49263b18 100644
--- a/dev-lang/php/php-7.0.19.ebuild
+++ b/dev-lang/php/php-7.0.19.ebuild
@@ -139,6 +139,7 @@ DEPEND="${COMMON_DEPEND}
# Without USE=readline or libedit, the interactive "php -a" CLI will hang.
REQUIRED_USE="
+ || ( cli cgi fpm apache2 embed phpdbg )
cli? ( ^^ ( readline libedit ) )
truetype? ( gd )
webp? ( gd )
@@ -157,10 +158,10 @@ REQUIRED_USE="
phar? ( hash )
qdbm? ( !gdbm )
readline? ( !libedit )
- recode? ( !imap !mysqli )
+ recode? ( !imap !mysqli !mysql )
sharedmem? ( !threads )
mysql? ( || ( mysqli pdo ) )
- || ( cli cgi fpm apache2 embed phpdbg )"
+"
PHP_MV="$(get_major_version)"
diff --git a/dev-lang/php/php-7.0.21.ebuild b/dev-lang/php/php-7.0.21.ebuild
index 90e9c59f5dfe..04e4ebd73e42 100644
--- a/dev-lang/php/php-7.0.21.ebuild
+++ b/dev-lang/php/php-7.0.21.ebuild
@@ -141,12 +141,12 @@ DEPEND="${COMMON_DEPEND}
REQUIRED_USE="
|| ( cli cgi fpm apache2 embed phpdbg )
cli? ( ^^ ( readline libedit ) )
- gd? ( zlib )
truetype? ( gd )
webp? ( gd )
cjk? ( gd )
exif? ( gd )
xpm? ( gd )
+ gd? ( zlib )
simplexml? ( xml )
soap? ( xml )
wddx? ( xml )