summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-10-02 09:56:16 -0400
committerMike Frysinger <vapier@gentoo.org>2015-10-02 09:56:33 -0400
commitbd3586765e47208668f27f707ec7f6d06b5d92a8 (patch)
tree771feb94a820a139df354d51632338403dfe3305 /dev-lang
parentsys-kernel/gentoo-sources: Add patch to fix potential deadlock in reqsk_queue... (diff)
downloadgentoo-bd3586765e47208668f27f707ec7f6d06b5d92a8.tar.gz
gentoo-bd3586765e47208668f27f707ec7f6d06b5d92a8.tar.bz2
gentoo-bd3586765e47208668f27f707ec7f6d06b5d92a8.zip
dev-lang/python: add upstream fix for testing w/gcc-5 #547626
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/python/files/python-3.4-gcc-5.patch37
-rw-r--r--dev-lang/python/python-3.3.5-r2.ebuild1
-rw-r--r--dev-lang/python/python-3.4.3-r2.ebuild1
3 files changed, 39 insertions, 0 deletions
diff --git a/dev-lang/python/files/python-3.4-gcc-5.patch b/dev-lang/python/files/python-3.4-gcc-5.patch
new file mode 100644
index 000000000000..80afbd1c47bb
--- /dev/null
+++ b/dev-lang/python/files/python-3.4-gcc-5.patch
@@ -0,0 +1,37 @@
+changeset: 94583:689092296ad3
+branch: 3.4
+parent: 94579:645f3d750be1
+user: Victor Stinner <victor.stinner@gmail.com>
+date: Wed Feb 11 14:23:35 2015 +0100
+summary: Issue #23433: Fix faulthandler._stack_overflow()
+
+diff -r 645f3d750be1 -r 689092296ad3 Modules/faulthandler.c
+--- a/Modules/faulthandler.c Tue Feb 10 14:49:32 2015 +0100
++++ b/Modules/faulthandler.c Wed Feb 11 14:23:35 2015 +0100
+@@ -911,12 +911,12 @@
+ }
+
+ #if defined(HAVE_SIGALTSTACK) && defined(HAVE_SIGACTION)
+-static void*
+-stack_overflow(void *min_sp, void *max_sp, size_t *depth)
++static Py_uintptr_t
++stack_overflow(Py_uintptr_t min_sp, Py_uintptr_t max_sp, size_t *depth)
+ {
+ /* allocate 4096 bytes on the stack at each call */
+ unsigned char buffer[4096];
+- void *sp = &buffer;
++ Py_uintptr_t sp = (Py_uintptr_t)&buffer;
+ *depth += 1;
+ if (sp < min_sp || max_sp < sp)
+ return sp;
+@@ -929,7 +929,8 @@
+ faulthandler_stack_overflow(PyObject *self)
+ {
+ size_t depth, size;
+- char *sp = (char *)&depth, *stop;
++ Py_uintptr_t sp = (Py_uintptr_t)&depth;
++ Py_uintptr_t stop;
+
+ depth = 0;
+ stop = stack_overflow(sp - STACK_OVERFLOW_MAX_SIZE,
+
diff --git a/dev-lang/python/python-3.3.5-r2.ebuild b/dev-lang/python/python-3.3.5-r2.ebuild
index 59fc5b7947d0..f14b1216b49d 100644
--- a/dev-lang/python/python-3.3.5-r2.ebuild
+++ b/dev-lang/python/python-3.3.5-r2.ebuild
@@ -75,6 +75,7 @@ src_prepare() {
EPATCH_SUFFIX="patch" epatch "${WORKDIR}/patches"
epatch "${FILESDIR}/${PN}-3.3.5-ncurses-pkg-config.patch"
+ epatch "${FILESDIR}/${PN}-3.4-gcc-5.patch" #547626
sed -i -e "s:@@GENTOO_LIBDIR@@:$(get_libdir):g" \
Lib/distutils/command/install.py \
diff --git a/dev-lang/python/python-3.4.3-r2.ebuild b/dev-lang/python/python-3.4.3-r2.ebuild
index 888e7a716e9d..80d86b644b84 100644
--- a/dev-lang/python/python-3.4.3-r2.ebuild
+++ b/dev-lang/python/python-3.4.3-r2.ebuild
@@ -70,6 +70,7 @@ src_prepare() {
EPATCH_SUFFIX="patch" epatch "${WORKDIR}/patches"
epatch "${FILESDIR}/${PN}-3.4.3-ncurses-pkg-config.patch"
+ epatch "${FILESDIR}/${PN}-3.4-gcc-5.patch" #547626
sed -i -e "s:@@GENTOO_LIBDIR@@:$(get_libdir):g" \
Lib/distutils/command/install.py \