summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/DFB++
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/DFB++')
-rw-r--r--dev-libs/DFB++/DFB++-1.2.0.ebuild29
-rw-r--r--dev-libs/DFB++/Manifest1
-rw-r--r--dev-libs/DFB++/files/DFB++-1.2.0-directfb-api.patch28
-rw-r--r--dev-libs/DFB++/metadata.xml5
4 files changed, 63 insertions, 0 deletions
diff --git a/dev-libs/DFB++/DFB++-1.2.0.ebuild b/dev-libs/DFB++/DFB++-1.2.0.ebuild
new file mode 100644
index 000000000000..d2d0781aa762
--- /dev/null
+++ b/dev-libs/DFB++/DFB++-1.2.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+DESCRIPTION="C++ bindings for DirectFB"
+HOMEPAGE="http://www.directfb.org/dfb++.xml"
+SRC_URI="http://www.directfb.org/downloads/Extras/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~ppc64 x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/DirectFB-${PV}"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-directfb-api.patch #235041
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ dodoc AUTHORS ChangeLog NEWS README
+}
diff --git a/dev-libs/DFB++/Manifest b/dev-libs/DFB++/Manifest
new file mode 100644
index 000000000000..1f0b555300ad
--- /dev/null
+++ b/dev-libs/DFB++/Manifest
@@ -0,0 +1 @@
+DIST DFB++-1.2.0.tar.gz 369240 SHA256 d9281587e02ef288275d639a16abbe72ec0bc4e83f10b3308570f14f9126606a SHA512 8689e1037f5cd19fb7f8e9ebe3eee971e6e51338116fad11a1618df4646daabeab79fec90670f3dc4e227be9ede9821abe927ffbbd0e57511220d3a28a75d1da WHIRLPOOL 950218b861b524ab412429b8af7ea00a8568528e2577b86ff33877998b3474d6dddc678cfc4155e051261aeeef77183b3cf10f6106ea69e59526d3939908b890
diff --git a/dev-libs/DFB++/files/DFB++-1.2.0-directfb-api.patch b/dev-libs/DFB++/files/DFB++-1.2.0-directfb-api.patch
new file mode 100644
index 000000000000..6b6dfc5ba8cb
--- /dev/null
+++ b/dev-libs/DFB++/files/DFB++-1.2.0-directfb-api.patch
@@ -0,0 +1,28 @@
+fix building with DirectFB-1.2.3
+
+http://bugs.gentoo.org/235041
+
+patch by Philippe Weibel
+
+--- dfb++/idirectfbvideoprovider.cpp
++++ dfb++/idirectfbvideoprovider.cpp
+@@ -165,7 +165,7 @@
+ return level;
+ }
+
+-void IDirectFBVideoProvider::SetStreamAttributes (DFBStreamDescription attr)
++void IDirectFBVideoProvider::SetStreamAttributes (DFBStreamAttributes attr)
+ {
+ DFBCHECK( iface->SetStreamAttributes (iface, attr) );
+ }
+--- include/idirectfbvideoprovider.h
++++ include/idirectfbvideoprovider.h
+@@ -68,7 +68,7 @@
+ float GetVolume ();
+
+
+- void SetStreamAttributes (DFBStreamDescription attr);
++ void SetStreamAttributes (DFBStreamAttributes attr);
+
+ void SetAudioOutputs (DFBVideoProviderAudioUnits *audioUnits);
+ DFBVideoProviderAudioUnits GetAudioOutputs ();
diff --git a/dev-libs/DFB++/metadata.xml b/dev-libs/DFB++/metadata.xml
new file mode 100644
index 000000000000..e770d1bc9a96
--- /dev/null
+++ b/dev-libs/DFB++/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>graphics</herd>
+</pkgmetadata>