summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/apr-util
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/apr-util')
-rw-r--r--dev-libs/apr-util/Manifest3
-rw-r--r--dev-libs/apr-util/apr-util-1.5.2.ebuild103
-rw-r--r--dev-libs/apr-util/apr-util-1.5.3-r2.ebuild114
-rw-r--r--dev-libs/apr-util/apr-util-1.5.4.ebuild113
-rw-r--r--dev-libs/apr-util/files/apr-util-1.3.12-bdb-5.2.patch139
-rw-r--r--dev-libs/apr-util/files/apr-util-1.5.3-berkdb6.patch69
-rw-r--r--dev-libs/apr-util/files/apr-util-1.5.3-sysroot.patch36
-rw-r--r--dev-libs/apr-util/metadata.xml12
8 files changed, 589 insertions, 0 deletions
diff --git a/dev-libs/apr-util/Manifest b/dev-libs/apr-util/Manifest
new file mode 100644
index 00000000000..10dcdfeddf1
--- /dev/null
+++ b/dev-libs/apr-util/Manifest
@@ -0,0 +1,3 @@
+DIST apr-util-1.5.2.tar.bz2 693258 SHA256 9ace3d2e3129d5c244ef695a88b3b47897695e8e6ca2b96e92e4a635d9ed12a7 SHA512 14e890aa1a34369ddf0d041d397231e21994c0a51d3a07dd126985699184ee59c2df32dd752339dd90278988a9461c714f0a157126229be57450259646a1d6df WHIRLPOOL 94972bf43b21527015a489e640d81087021a7818fb4435b60a0b753d214e53b05630976894c81a70a069bb6918150c22df7621c63a539082a8b90ca442adce0e
+DIST apr-util-1.5.3.tar.bz2 695303 SHA256 78edb174f13e25ee15ded2b849b741a248b879a93a77a2d31c20f7e225be3968 SHA512 b03588fd10c8705ea72cb35e821a99ba160c5a480d91d766969672c72a4db5bc2ec01b13cbe0eccc1cd1eadd96e8198994296bc2f0232b3fce4e82271a382db6 WHIRLPOOL 4e3d131c2fcb5818db76c2d663caf7ab193a020011d21a1b03238075ba1ddb9778aa3df1e165cb13833efc446c81d13893a126d91e8da6cc55a5431e50f3b797
+DIST apr-util-1.5.4.tar.bz2 694427 SHA256 a6cf327189ca0df2fb9d5633d7326c460fe2b61684745fd7963e79a6dd0dc82e SHA512 ca877d8e444218c4ba0f28063ee075ddcd6c0a487b692dc80ef442fe775ec4eeb337c6957853772e8082e27edcb450d7e909c2c6c3ab4a95bbf0a5ee5ea4a2d1 WHIRLPOOL bc4ce82785513f4bf2207bb26758abc79e6bfef62a57d3e2ead570abc618b321c302390b9dcd8eab1ec44a9e5d398c2cc4d35af2549636e20d7c20678725ac2e
diff --git a/dev-libs/apr-util/apr-util-1.5.2.ebuild b/dev-libs/apr-util/apr-util-1.5.2.ebuild
new file mode 100644
index 00000000000..c394781a270
--- /dev/null
+++ b/dev-libs/apr-util/apr-util-1.5.2.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+# Usually apr-util has the same PV as apr, but in case of security fixes, this may change.
+# APR_PV="${PV}"
+APR_PV="1.4.6"
+
+inherit autotools db-use eutils libtool multilib toolchain-funcs
+
+DESCRIPTION="Apache Portable Runtime Utility Library"
+HOMEPAGE="http://apr.apache.org/"
+SRC_URI="mirror://apache/apr/${P}.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="1"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="berkdb doc freetds gdbm ldap mysql nss odbc openssl postgres sqlite static-libs"
+RESTRICT="test"
+
+RDEPEND="dev-libs/expat
+ >=dev-libs/apr-${APR_PV}:1
+ berkdb? ( >=sys-libs/db-4 )
+ freetds? ( dev-db/freetds )
+ gdbm? ( sys-libs/gdbm )
+ ldap? ( =net-nds/openldap-2* )
+ mysql? ( =virtual/mysql-5* )
+ nss? ( dev-libs/nss )
+ odbc? ( dev-db/unixODBC )
+ openssl? ( dev-libs/openssl )
+ postgres? ( dev-db/postgresql )
+ sqlite? ( dev-db/sqlite:3 )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+DOCS=(CHANGES NOTICE README)
+
+src_prepare() {
+ eautoreconf
+
+ elibtoolize
+}
+
+src_configure() {
+ local myconf
+
+ tc-is-static-only && myconf+=" --disable-util-dso"
+
+ if use berkdb; then
+ local db_version
+ db_version="$(db_findver sys-libs/db)" || die "Unable to find Berkeley DB version"
+ db_version="$(db_ver_to_slot "${db_version}")"
+ db_version="${db_version/\./}"
+ myconf+=" --with-dbm=db${db_version} --with-berkeley-db=$(db_includedir 2> /dev/null):${EPREFIX}/usr/$(get_libdir)"
+ else
+ myconf+=" --without-berkeley-db"
+ fi
+
+ econf \
+ --datadir="${EPREFIX}"/usr/share/apr-util-1 \
+ --with-apr="${EPREFIX}"/usr \
+ --with-expat="${EPREFIX}"/usr \
+ --without-sqlite2 \
+ $(use_with freetds) \
+ $(use_with gdbm) \
+ $(use_with ldap) \
+ $(use_with mysql) \
+ $(use_with nss) \
+ $(use_with odbc) \
+ $(use_with openssl) \
+ $(use_with postgres pgsql) \
+ $(use_with sqlite sqlite3) \
+ ${myconf}
+}
+
+src_compile() {
+ emake CPPFLAGS="${CPPFLAGS}" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+
+ if use doc; then
+ emake dox
+ fi
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name "*.la" -exec rm -f {} +
+ find "${ED}usr/$(get_libdir)/apr-util-${SLOT}" -name "*.a" -exec rm -f {} +
+
+ if use doc; then
+ dohtml -r docs/dox/html/*
+ fi
+
+ if ! use static-libs; then
+ find "${ED}" -name "*.a" -exec rm -f {} +
+ fi
+
+ # This file is only used on AIX systems, which Gentoo is not,
+ # and causes collisions between the SLOTs, so remove it.
+ rm -f "${ED}usr/$(get_libdir)/aprutil.exp"
+}
diff --git a/dev-libs/apr-util/apr-util-1.5.3-r2.ebuild b/dev-libs/apr-util/apr-util-1.5.3-r2.ebuild
new file mode 100644
index 00000000000..807719ed49d
--- /dev/null
+++ b/dev-libs/apr-util/apr-util-1.5.3-r2.ebuild
@@ -0,0 +1,114 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+# Usually apr-util has the same PV as apr, but in case of security fixes, this may change.
+# APR_PV="${PV}"
+APR_PV="1.4.6"
+
+inherit autotools db-use eutils libtool multilib toolchain-funcs
+
+DESCRIPTION="Apache Portable Runtime Utility Library"
+HOMEPAGE="http://apr.apache.org/"
+SRC_URI="mirror://apache/apr/${P}.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="1"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="berkdb doc freetds gdbm ldap mysql nss odbc openssl postgres sqlite static-libs"
+RESTRICT="test"
+
+RDEPEND="dev-libs/expat
+ >=dev-libs/apr-${APR_PV}:1
+ berkdb? ( >=sys-libs/db-4 )
+ freetds? ( dev-db/freetds )
+ gdbm? ( sys-libs/gdbm )
+ ldap? ( =net-nds/openldap-2* )
+ mysql? ( =virtual/mysql-5* )
+ nss? ( dev-libs/nss )
+ odbc? ( dev-db/unixODBC )
+ openssl? ( dev-libs/openssl )
+ postgres? ( dev-db/postgresql )
+ sqlite? ( dev-db/sqlite:3 )"
+DEPEND="${RDEPEND}
+ >=sys-devel/libtool-2.4.2
+ doc? ( app-doc/doxygen )"
+
+DOCS=(CHANGES NOTICE README)
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-berkdb6.patch #476374
+ epatch "${FILESDIR}"/${PN}-1.5.3-sysroot.patch #385775
+ eautoreconf
+ elibtoolize
+}
+
+src_configure() {
+ local myconf=()
+
+ tc-is-static-only && myconf+=( --disable-util-dso )
+
+ if use berkdb; then
+ local db_version
+ db_version="$(db_findver sys-libs/db)" || die "Unable to find Berkeley DB version"
+ db_version="$(db_ver_to_slot "${db_version}")"
+ db_version="${db_version/\./}"
+ myconf+=(
+ --with-dbm=db${db_version}
+ # We use $T for the libdir because otherwise it'd simply be the normal
+ # system libdir. That's pointless as the compiler will search it for
+ # us already. This makes cross-compiling and such easier.
+ --with-berkeley-db="${SYSROOT}$(db_includedir 2>/dev/null):${T}"
+ )
+ else
+ myconf+=( --without-berkeley-db )
+ fi
+
+ if use nss || use openssl ; then
+ myconf+=( --with-crypto ) # 518708
+ fi
+
+ econf \
+ --datadir="${EPREFIX}"/usr/share/apr-util-1 \
+ --with-apr="${SYSROOT}${EPREFIX}"/usr \
+ --with-expat="${EPREFIX}"/usr \
+ --without-sqlite2 \
+ $(use_with freetds) \
+ $(use_with gdbm) \
+ $(use_with ldap) \
+ $(use_with mysql) \
+ $(use_with nss) \
+ $(use_with odbc) \
+ $(use_with openssl) \
+ $(use_with postgres pgsql) \
+ $(use_with sqlite sqlite3) \
+ "${myconf[@]}"
+ # Use the current env build settings rather than whatever apr was built with.
+ sed -i -r \
+ -e "/^(apr_builddir|apr_builders|top_builddir)=/s:=:=${SYSROOT}:" \
+ -e "/^CC=/s:=.*:=$(tc-getCC):" \
+ -e '/^(C|CPP|CXX|LD)FLAGS=/d' \
+ -e '/^LTFLAGS/s:--silent::' \
+ build/rules.mk || die
+}
+
+src_compile() {
+ emake
+ use doc && emake dox
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name "*.la" -delete
+ find "${ED}usr/$(get_libdir)/apr-util-${SLOT}" -name "*.a" -delete
+ use static-libs || find "${ED}" -name "*.a" -delete
+
+ use doc && dohtml -r docs/dox/html/*
+
+ # This file is only used on AIX systems, which Gentoo is not,
+ # and causes collisions between the SLOTs, so remove it.
+ rm -f "${ED}usr/$(get_libdir)/aprutil.exp"
+}
diff --git a/dev-libs/apr-util/apr-util-1.5.4.ebuild b/dev-libs/apr-util/apr-util-1.5.4.ebuild
new file mode 100644
index 00000000000..22a1e1945ef
--- /dev/null
+++ b/dev-libs/apr-util/apr-util-1.5.4.ebuild
@@ -0,0 +1,113 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+# Usually apr-util has the same PV as apr, but in case of security fixes, this may change.
+# APR_PV="${PV}"
+APR_PV="1.4.6"
+
+inherit autotools db-use eutils libtool multilib toolchain-funcs
+
+DESCRIPTION="Apache Portable Runtime Utility Library"
+HOMEPAGE="http://apr.apache.org/"
+SRC_URI="mirror://apache/apr/${P}.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="1"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="berkdb doc freetds gdbm ldap mysql nss odbc openssl postgres sqlite static-libs"
+#RESTRICT="test"
+
+RDEPEND="dev-libs/expat
+ >=dev-libs/apr-${APR_PV}:1
+ berkdb? ( >=sys-libs/db-4 )
+ freetds? ( dev-db/freetds )
+ gdbm? ( sys-libs/gdbm )
+ ldap? ( =net-nds/openldap-2* )
+ mysql? ( =virtual/mysql-5* )
+ nss? ( dev-libs/nss )
+ odbc? ( dev-db/unixODBC )
+ openssl? ( dev-libs/openssl )
+ postgres? ( dev-db/postgresql )
+ sqlite? ( dev-db/sqlite:3 )"
+DEPEND="${RDEPEND}
+ >=sys-devel/libtool-2.4.2
+ doc? ( app-doc/doxygen )"
+
+DOCS=(CHANGES NOTICE README)
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.5.3-sysroot.patch #385775
+ eautoreconf
+ elibtoolize
+}
+
+src_configure() {
+ local myconf=()
+
+ tc-is-static-only && myconf+=( --disable-util-dso )
+
+ if use berkdb; then
+ local db_version
+ db_version="$(db_findver sys-libs/db)" || die "Unable to find Berkeley DB version"
+ db_version="$(db_ver_to_slot "${db_version}")"
+ db_version="${db_version/\./}"
+ myconf+=(
+ --with-dbm=db${db_version}
+ # We use $T for the libdir because otherwise it'd simply be the normal
+ # system libdir. That's pointless as the compiler will search it for
+ # us already. This makes cross-compiling and such easier.
+ --with-berkeley-db="${SYSROOT}$(db_includedir 2>/dev/null):${T}"
+ )
+ else
+ myconf+=( --without-berkeley-db )
+ fi
+
+ if use nss || use openssl ; then
+ myconf+=( --with-crypto ) # 518708
+ fi
+
+ econf \
+ --datadir="${EPREFIX}"/usr/share/apr-util-1 \
+ --with-apr="${SYSROOT}${EPREFIX}"/usr \
+ --with-expat="${EPREFIX}"/usr \
+ --without-sqlite2 \
+ $(use_with freetds) \
+ $(use_with gdbm) \
+ $(use_with ldap) \
+ $(use_with mysql) \
+ $(use_with nss) \
+ $(use_with odbc) \
+ $(use_with openssl) \
+ $(use_with postgres pgsql) \
+ $(use_with sqlite sqlite3) \
+ "${myconf[@]}"
+ # Use the current env build settings rather than whatever apr was built with.
+ sed -i -r \
+ -e "/^(apr_builddir|apr_builders|top_builddir)=/s:=:=${SYSROOT}:" \
+ -e "/^CC=/s:=.*:=$(tc-getCC):" \
+ -e '/^(C|CPP|CXX|LD)FLAGS=/d' \
+ -e '/^LTFLAGS/s:--silent::' \
+ build/rules.mk || die
+}
+
+src_compile() {
+ emake
+ use doc && emake dox
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name "*.la" -delete
+ find "${ED}usr/$(get_libdir)/apr-util-${SLOT}" -name "*.a" -delete
+ use static-libs || find "${ED}" -name "*.a" -delete
+
+ use doc && dohtml -r docs/dox/html/*
+
+ # This file is only used on AIX systems, which Gentoo is not,
+ # and causes collisions between the SLOTs, so remove it.
+ rm -f "${ED}usr/$(get_libdir)/aprutil.exp"
+}
diff --git a/dev-libs/apr-util/files/apr-util-1.3.12-bdb-5.2.patch b/dev-libs/apr-util/files/apr-util-1.3.12-bdb-5.2.patch
new file mode 100644
index 00000000000..5687a8e730f
--- /dev/null
+++ b/dev-libs/apr-util/files/apr-util-1.3.12-bdb-5.2.patch
@@ -0,0 +1,139 @@
+--- build/dbm.m4
++++ build/dbm.m4
+@@ -579,6 +579,25 @@
+ apu_db_version=5
+ fi
+ ])
++dnl
++dnl APU_CHECK_DB52: is DB5.2 present?
++dnl
++dnl if present: sets apu_db_header, apu_db_lib, and apu_db_version
++dnl
++AC_DEFUN([APU_CHECK_DB52], [
++ places=$1
++ if test -z "$places"; then
++ places="std /usr/local/BerkeleyDB.5.2 /boot/home/config"
++ fi
++ APU_CHECK_BERKELEY_DB("5", "2", "-1",
++ "$places",
++ "db52/db.h db5/db.h db.h",
++ "db-5.2 db5-5.2 db52 db5 db"
++ )
++ if test "$apu_have_db" = "1"; then
++ apu_db_version=5
++ fi
++])
+
+ AC_DEFUN([APU_CHECK_DB], [
+ requested=$1
+@@ -681,6 +700,12 @@
+ AC_MSG_ERROR(Berkeley db5 not found)
+ fi
+ ;;
++ db52)
++ APU_CHECK_DB52("$check_places")
++ if test "$apu_db_version" != "5"; then
++ AC_MSG_ERROR(Berkeley db5 not found)
++ fi
++ ;;
+ default)
+ APU_CHECK_DB_ALL("$check_places")
+ ;;
+@@ -688,40 +713,43 @@
+ ])
+
+ dnl
+-dnl APU_CHECK_DB_ALL: Try all Berkeley DB versions, from 5.1 to 1.
++dnl APU_CHECK_DB_ALL: Try all Berkeley DB versions, from 5.2 to 1.
+ dnl
+ AC_DEFUN([APU_CHECK_DB_ALL], [
+ all_places=$1
+
+- APU_CHECK_DB51("$all_places")
++ APU_CHECK_DB52("$all_places")
+ if test "$apu_db_version" != "5"; then
+- APU_CHECK_DB50("$all_places")
++ APU_CHECK_DB51("$all_places")
+ if test "$apu_db_version" != "5"; then
+- APU_CHECK_DB48("$all_places")
+- if test "$apu_db_version" != "4"; then
+- APU_CHECK_DB47("$all_places")
++ APU_CHECK_DB50("$all_places")
++ if test "$apu_db_version" != "5"; then
++ APU_CHECK_DB48("$all_places")
+ if test "$apu_db_version" != "4"; then
+- APU_CHECK_DB46("$all_places")
++ APU_CHECK_DB47("$all_places")
+ if test "$apu_db_version" != "4"; then
+- APU_CHECK_DB45("$all_places")
++ APU_CHECK_DB46("$all_places")
+ if test "$apu_db_version" != "4"; then
+- APU_CHECK_DB44("$all_places")
++ APU_CHECK_DB45("$all_places")
+ if test "$apu_db_version" != "4"; then
+- APU_CHECK_DB43("$all_places")
++ APU_CHECK_DB44("$all_places")
+ if test "$apu_db_version" != "4"; then
+- APU_CHECK_DB42("$all_places")
++ APU_CHECK_DB43("$all_places")
+ if test "$apu_db_version" != "4"; then
+- APU_CHECK_DB41("$all_places")
++ APU_CHECK_DB42("$all_places")
+ if test "$apu_db_version" != "4"; then
+- APU_CHECK_DB4("$all_places")
++ APU_CHECK_DB41("$all_places")
+ if test "$apu_db_version" != "4"; then
+- APU_CHECK_DB3("$all_places")
+- if test "$apu_db_version" != "3"; then
+- APU_CHECK_DB2("$all_places")
+- if test "$apu_db_version" != "2"; then
+- APU_CHECK_DB1("$all_places")
+- if test "$apu_db_version" != "1"; then
+- APU_CHECK_DB185("$all_places")
++ APU_CHECK_DB4("$all_places")
++ if test "$apu_db_version" != "4"; then
++ APU_CHECK_DB3("$all_places")
++ if test "$apu_db_version" != "3"; then
++ APU_CHECK_DB2("$all_places")
++ if test "$apu_db_version" != "2"; then
++ APU_CHECK_DB1("$all_places")
++ if test "$apu_db_version" != "1"; then
++ APU_CHECK_DB185("$all_places")
++ fi
+ fi
+ fi
+ fi
+@@ -763,11 +791,11 @@
+ apu_db_version=0
+
+ AC_ARG_WITH(dbm, [APR_HELP_STRING([--with-dbm=DBM], [choose the DBM type to use.
+- DBM={sdbm,gdbm,ndbm,db,db1,db185,db2,db3,db4,db41,db42,db43,db44,db45,db46,db47,db48,db50,db51}])],
++ DBM={sdbm,gdbm,ndbm,db,db1,db185,db2,db3,db4,db41,db42,db43,db44,db45,db46,db47,db48,db50,db51,db52}])],
+ [
+ if test "$withval" = "yes"; then
+ AC_MSG_ERROR([--with-dbm needs to specify a DBM type to use.
+- One of: sdbm, gdbm, ndbm, db, db1, db185, db2, db3, db4, db41, db42, db43, db44, db45, db46, db47, db48, db50, db51])
++ One of: sdbm, gdbm, ndbm, db, db1, db185, db2, db3, db4, db41, db42, db43, db44, db45, db46, db47, db48, db50, db51, db52])
+ fi
+ requested="$withval"
+ ], [
+@@ -978,6 +1006,10 @@
+ apu_use_db=1
+ apu_default_dbm=db5
+ ;;
++ db52)
++ apu_use_db=1
++ apu_default_dbm=db5
++ ;;
+ default)
+ dnl ### use more sophisticated DBMs for the default?
+ apu_default_dbm="sdbm (default)"
+@@ -985,7 +1017,7 @@
+ ;;
+ *)
+ AC_MSG_ERROR([--with-dbm=$look_for is an unknown DBM type.
+- Use one of: sdbm, gdbm, ndbm, db, db1, db185, db2, db3, db4, db41, db42, db43, db44, db45, db46, db47, db48, db50, db51])
++ Use one of: sdbm, gdbm, ndbm, db, db1, db185, db2, db3, db4, db41, db42, db43, db44, db45, db46, db47, db48, db50, db51, db52])
+ ;;
+ esac
+
diff --git a/dev-libs/apr-util/files/apr-util-1.5.3-berkdb6.patch b/dev-libs/apr-util/files/apr-util-1.5.3-berkdb6.patch
new file mode 100644
index 00000000000..a3f4a3c9b19
--- /dev/null
+++ b/dev-libs/apr-util/files/apr-util-1.5.3-berkdb6.patch
@@ -0,0 +1,69 @@
+http://svn.apache.org/viewvc/apr/apr/trunk/build/dbm.m4?r1=1495889&r2=1544846&diff_format=h
+
+--- apr/apr/trunk/build/dbm.m4 2013/06/23 20:27:54 1495889
++++ apr/apr/trunk/build/dbm.m4 2013/11/23 17:57:39 1544846
+@@ -112,7 +112,7 @@
+ changequote([,])
+ unset $cache_id
+ AC_CHECK_HEADER([$bdb_header], [
+- if test "$1" = "3" -o "$1" = "4" -o "$1" = "5"; then
++ if test "$1" = "3" -o "$1" = "4" -o "$1" = "5" -o "$1" = "6"; then
+ # We generate a separate cache variable for each prefix and libname
+ # we search under. That way, we avoid caching information that
+ # changes if the user runs `configure' with a different set of
+@@ -455,13 +455,13 @@
+ ])
+
+ dnl
+-dnl APU_CHECK_DB_ALL: Try all Berkeley DB versions, from 5.X to 1.
++dnl APU_CHECK_DB_ALL: Try all Berkeley DB versions, from 6.X to 1.
+ dnl
+ AC_DEFUN([APU_CHECK_DB_ALL], [
+ all_places=$1
+
+- # Start version search at version 5.9
+- db_version=59
++ # Start version search at version 6.9
++ db_version=69
+ while [[ $db_version -ge 40 ]]
+ do
+ db_major=`echo $db_version | sed -e 's/.$//'`
+@@ -511,19 +511,34 @@
+ apu_db_version=0
+
+ # Maximum supported version announced in help string.
+- # Although we search for all versions up to 5.9,
++ # Although we search for all versions up to 6.9,
+ # we should only include existing versions in our
+ # help string.
+- db_max_version=53
+- db_min_version=41
+ dbm_list="sdbm, gdbm, ndbm, db, db1, db185, db2, db3, db4"
++ db_max_version=48
++ db_min_version=41
++ db_version="$db_min_version"
++ while [[ $db_version -le $db_max_version ]]
++ do
++ dbm_list="$dbm_list, db$db_version"
++ db_version=`expr $db_version + 1`
++ done
++ db_max_version=53
++ db_min_version=50
++ db_version="$db_min_version"
++ while [[ $db_version -le $db_max_version ]]
++ do
++ dbm_list="$dbm_list, db$db_version"
++ db_version=`expr $db_version + 1`
++ done
++ db_max_version=60
++ db_min_version=60
+ db_version="$db_min_version"
+ while [[ $db_version -le $db_max_version ]]
+ do
+ dbm_list="$dbm_list, db$db_version"
+ db_version=`expr $db_version + 1`
+ done
+- dbm_list="$dbm_list, db60"
+
+ AC_ARG_WITH(dbm, [APR_HELP_STRING([--with-dbm=DBM], [choose the DBM type to use.
+ DBM={sdbm,gdbm,ndbm,db,db1,db185,db2,db3,db4,db4X,db5X,db6X} for some X=0,...,9])],
diff --git a/dev-libs/apr-util/files/apr-util-1.5.3-sysroot.patch b/dev-libs/apr-util/files/apr-util-1.5.3-sysroot.patch
new file mode 100644
index 00000000000..ce07b147052
--- /dev/null
+++ b/dev-libs/apr-util/files/apr-util-1.5.3-sysroot.patch
@@ -0,0 +1,36 @@
+https://bugs.gentoo.org/385775
+
+utilize $SYSROOT to find the right includedir tree
+
+drop the -L/-R paths since we know our libdir is the standard path which
+the compiler already knows how to locate
+
+--- a/apu-config.in
++++ b/apu-config.in
+@@ -25,7 +25,7 @@ prefix="@prefix@"
+ exec_prefix="@exec_prefix@"
+ bindir="@bindir@"
+ libdir="@libdir@"
+-includedir="@includedir@"
++includedir="${SYSROOT}@includedir@"
+
+ LIBS="@APRUTIL_EXPORT_LIBS@"
+ INCLUDES="@APRUTIL_INCLUDES@"
+@@ -166,7 +166,7 @@ while test $# -gt 0; do
+ --link-ld)
+ if test "$location" = "installed"; then
+ ### avoid using -L if libdir is a "standard" location like /usr/lib
+- flags="$flags -L$libdir -l$APRUTIL_LIBNAME"
++ flags="$flags -l$APRUTIL_LIBNAME"
+ else
+ flags="$flags -L$APU_BUILD_DIR -l$APRUTIL_LIBNAME"
+ fi
+@@ -182,7 +182,7 @@ while test $# -gt 0; do
+ ### avoid using -L if libdir is a "standard" location like /usr/lib
+ # Since the user is specifying they are linking with libtool, we
+ # *know* that -R will be recognized by libtool.
+- flags="$flags -L$libdir -R$libdir -l$APRUTIL_LIBNAME"
++ flags="$flags -l$APRUTIL_LIBNAME"
+ else
+ flags="$flags $LA_FILE"
+ fi
diff --git a/dev-libs/apr-util/metadata.xml b/dev-libs/apr-util/metadata.xml
new file mode 100644
index 00000000000..5847a73b54f
--- /dev/null
+++ b/dev-libs/apr-util/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>polynomial-c@gentoo.org</email>
+ <name>Lars Wendler</name>
+ </maintainer>
+ <use>
+ <flag name="nss">Install apr_crypto_nss module</flag>
+ <flag name="openssl">Install apr_crypto_openssl module</flag>
+ </use>
+</pkgmetadata>