summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2017-12-06 10:36:49 +0100
committerFabian Groffen <grobian@gentoo.org>2017-12-10 11:58:39 +0100
commit3811c76a7d0f30d16ba808a03bbccee6479ce9c7 (patch)
treeb1e97e7966bb2245548b66ab973c1f98e7445138 /dev-libs/atf
parentdev-lua/lutok: add *-macos *-solaris keywords, bug #617758 (diff)
downloadgentoo-3811c76a7d0f30d16ba808a03bbccee6479ce9c7.tar.gz
gentoo-3811c76a7d0f30d16ba808a03bbccee6479ce9c7.tar.bz2
gentoo-3811c76a7d0f30d16ba808a03bbccee6479ce9c7.zip
dev-libs/atf: marked *-macos, fixed for *-solaris, bug #617758
Bug: https://bugs.gentoo.org/617758 Package-Manager: Portage-2.3.13-prefix, Repoman-2.3.4
Diffstat (limited to 'dev-libs/atf')
-rw-r--r--dev-libs/atf/atf-0.21-r1.ebuild24
-rw-r--r--dev-libs/atf/files/atf-0.21-getopt-solaris.patch12
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-libs/atf/atf-0.21-r1.ebuild b/dev-libs/atf/atf-0.21-r1.ebuild
new file mode 100644
index 000000000000..8f0c520fae81
--- /dev/null
+++ b/dev-libs/atf/atf-0.21-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit ltprune
+
+DESCRIPTION="Libraries to write tests in C, C++ and shell"
+HOMEPAGE="https://github.com/jmmv/atf"
+SRC_URI="https://github.com/jmmv/atf/releases/download/${P}/${P}.tar.gz"
+
+LICENSE="BSD BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND="virtual/pkgconfig"
+
+PATCHES=( ${FILESDIR}/${P}-getopt-solaris.patch )
+
+src_install() {
+ default
+ prune_libtool_files
+}
diff --git a/dev-libs/atf/files/atf-0.21-getopt-solaris.patch b/dev-libs/atf/files/atf-0.21-getopt-solaris.patch
new file mode 100644
index 000000000000..d70af36ce40e
--- /dev/null
+++ b/dev-libs/atf/files/atf-0.21-getopt-solaris.patch
@@ -0,0 +1,12 @@
+On Solaris, getopt(3) is in stdio.h.
+
+--- a/atf-c/tp_test.c
++++ b/atf-c/tp_test.c
+@@ -25,6 +25,7 @@
+
+ #include "atf-c/tp.h"
+
++#include <stdio.h>
+ #include <string.h>
+ #include <unistd.h>
+