summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/bglibs
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/bglibs')
-rw-r--r--dev-libs/bglibs/Manifest3
-rw-r--r--dev-libs/bglibs/bglibs-1.041.ebuild50
-rw-r--r--dev-libs/bglibs/bglibs-1.104.ebuild64
-rw-r--r--dev-libs/bglibs/bglibs-1.106-r1.ebuild77
-rw-r--r--dev-libs/bglibs/bglibs-1.106.ebuild76
-rw-r--r--dev-libs/bglibs/files/bglibs-1.104-parallel-fix.patch87
-rw-r--r--dev-libs/bglibs/files/bglibs-1.106-parallel-fix.patch61
-rw-r--r--dev-libs/bglibs/metadata.xml8
8 files changed, 426 insertions, 0 deletions
diff --git a/dev-libs/bglibs/Manifest b/dev-libs/bglibs/Manifest
new file mode 100644
index 000000000000..38a50f6ae49d
--- /dev/null
+++ b/dev-libs/bglibs/Manifest
@@ -0,0 +1,3 @@
+DIST bglibs-1.041.tar.gz 317199 SHA256 da09ff048d37ecdb691c495007580b99e8a2c1b3fcd8dede61bd0299846ec70b SHA512 63f1cbef024f528d13a23f84f11b014be2ee9a9c8c40f49f8a114a6b4407c1279860a049f3dd67cfa7306a5326bbb93bb57b134af05031ec3c00f5f49784f6bc WHIRLPOOL 0623af99baf8ab8cf99b7c0fb57a97a09223a5a0baa5d8f6e29381778289f1447b8a468a1b11cbd0cdc907b069192dc1c6e16c4ecec263f76de1bf2cfc28d7c0
+DIST bglibs-1.104.tar.gz 442643 SHA256 5593213ee3aedf297eff5fabddf535e4d2a85ad8c8f2a2b1d4dce210991022af SHA512 2ee24eb696126de2aa40451f3ce395220ea57cac9376ded6b7d7e195ecd7a1740f07339c4934a5aafdadb639a0d3421bfe6e674857d9663827a2c3714abe6a03 WHIRLPOOL 880002680aa1b19a81bf7f87e00be4897d7b1c928ea926831f3c6dcb681ea944305aa59057c2ee59ed07bad6018897760be9ff71f9e93b2d0687ac145caea302
+DIST bglibs-1.106.tar.gz 481564 SHA256 5c8ae51c2d88e58ff2fccc32d3000e88054d87fd69b6bfa6d0f70528e8538df0 SHA512 c1ae4bb9978b09ffe01231738d1f249c2040a51c2a0bbc4b04389a7085a3885cca6483f1bfe65deca213d991273bb3b7b925ebde8b6e2cd9182d8a57cb9a49d8 WHIRLPOOL be49bd8d802008296853ac91fd4bfb8f849aa7fb59cbc07d523fbccf8a60f4cbb5b79e8539a56eb2eb22edc7fc3b11838d6a0997566e5e5a415fbd532e237e18
diff --git a/dev-libs/bglibs/bglibs-1.041.ebuild b/dev-libs/bglibs/bglibs-1.041.ebuild
new file mode 100644
index 000000000000..996690f99b8d
--- /dev/null
+++ b/dev-libs/bglibs/bglibs-1.041.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit fixheadtails toolchain-funcs multilib
+
+DESCRIPTION="Bruce Guenters Libraries Collection"
+HOMEPAGE="http://untroubled.org/bglibs/"
+SRC_URI="http://untroubled.org/bglibs/archive/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm hppa ~mips ppc sparc x86 ~ppc64"
+IUSE=""
+DEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ # disable tests as we want them manually
+ sed -e '/^all:/s|selftests||' -i.orig "${S}"/Makefile
+ sed -e '/selftests/d' -i.orig "${S}"/TARGETS
+}
+
+src_compile() {
+ echo "${D}/usr/bin" > conf-bin
+ echo "${D}/usr/$(get_libdir)/bglibs" > conf-lib
+ echo "${D}/usr/include/bglibs" > conf-include
+ echo "${D}/usr/share/man" > conf-man
+ echo "$(tc-getCC) ${CFLAGS}" > conf-cc
+ echo "$(tc-getCC) ${LDFLAGS}" > conf-ld
+ emake || die
+}
+
+src_test() {
+ einfo "Running selftests"
+ emake selftests
+}
+
+src_install () {
+ einstall || die "install failed"
+
+ #make backwards compatible symlinks
+ dosym /usr/lib/bglibs /usr/lib/bglibs/lib
+ dosym /usr/include/bglibs /usr/lib/bglibs/include
+
+ dodoc ANNOUNCEMENT NEWS README ChangeLog TODO VERSION
+ dohtml doc/html/*
+ docinto latex
+ dodoc doc/latex/*
+}
diff --git a/dev-libs/bglibs/bglibs-1.104.ebuild b/dev-libs/bglibs/bglibs-1.104.ebuild
new file mode 100644
index 000000000000..d5ac29ae496f
--- /dev/null
+++ b/dev-libs/bglibs/bglibs-1.104.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit toolchain-funcs eutils multilib
+
+DESCRIPTION="Bruce Guenters Libraries Collection"
+HOMEPAGE="http://untroubled.org/bglibs/"
+SRC_URI="http://untroubled.org/bglibs/archive/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+DEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ epatch "${FILESDIR}"/bglibs-1.104-parallel-fix.patch
+ # disable tests as we want them manually
+ sed -i \
+ -e '/^all:/s|selftests||' \
+ "${S}"/Makefile
+ sed -i \
+ -e '/selftests/d' \
+ "${S}"/TARGETS
+ #sed -i \
+ # -e 's,^libraries:,LIBS = ,g' \
+ # -e '/^LIBS =/alibs-static: $(filter %.a,$(LIBS))' \
+ # -e '/^LIBS =/alibs-shared: $(filter %.la,$(LIBS))' \
+ # -e '/^LIBS =/alibraries: libs-static libs-shared' \
+ # "${S}"/Makefile
+}
+
+src_compile() {
+ echo "${D}/usr/bin" > conf-bin
+ echo "${D}/usr/$(get_libdir)/bglibs" > conf-lib
+ echo "${D}/usr/include/bglibs" > conf-include
+ echo "${D}/usr/share/man" > conf-man
+ echo "$(tc-getCC) ${CFLAGS}" > conf-cc
+ echo "$(tc-getCC) ${LDFLAGS}" > conf-ld
+ # Fails if we do parallel build of shared+static at the same time
+ emake libs-shared || die
+ emake libs-static || die
+ emake || die
+}
+
+src_test() {
+ einfo "Running selftests"
+ emake selftests
+}
+
+src_install () {
+ einstall || die "install failed"
+
+ #make backwards compatible symlinks
+ dosym /usr/lib/bglibs /usr/lib/bglibs/lib
+ dosym /usr/include/bglibs /usr/lib/bglibs/include
+
+ dodoc ANNOUNCEMENT NEWS README ChangeLog TODO VERSION
+ dohtml doc/html/*
+ docinto latex
+ dodoc doc/latex/*
+}
diff --git a/dev-libs/bglibs/bglibs-1.106-r1.ebuild b/dev-libs/bglibs/bglibs-1.106-r1.ebuild
new file mode 100644
index 000000000000..6e981f3d326f
--- /dev/null
+++ b/dev-libs/bglibs/bglibs-1.106-r1.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit toolchain-funcs eutils multilib
+
+DESCRIPTION="Bruce Guenters Libraries Collection"
+HOMEPAGE="http://untroubled.org/bglibs/"
+SRC_URI="http://untroubled.org/bglibs/archive/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+DEPEND=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.106-parallel-fix.patch
+ # disable tests as we want them manually
+ sed -i \
+ -e '/^all:/s|selftests||' \
+ "${S}"/Makefile
+ sed -i \
+ -e '/selftests/d' \
+ "${S}"/TARGETS
+ #sed -i \
+ # -e 's,^libraries:,LIBS = ,g' \
+ # -e '/^LIBS =/alibs-static: $(filter %.a,$(LIBS))' \
+ # -e '/^LIBS =/alibs-shared: $(filter %.la,$(LIBS))' \
+ # -e '/^LIBS =/alibraries: libs-static libs-shared' \
+ # "${S}"/Makefile
+}
+
+src_compile() {
+ echo "${D}/usr/bin" > conf-bin
+ echo "${D}/usr/$(get_libdir)/bglibs" > conf-lib
+ echo "${D}/usr/include/bglibs" > conf-include
+ echo "${D}/usr/share/man" > conf-man
+ echo "$(tc-getCC) ${CFLAGS}" > conf-cc
+ echo "$(tc-getCC) ${LDFLAGS}" > conf-ld
+ emake || die
+}
+
+src_test() {
+ einfo "Running selftests"
+ emake selftests
+}
+
+src_install () {
+ einstall || die "install failed"
+
+ #make backwards compatible symlinks
+ dosym /usr/$(get_libdir)/bglibs /usr/$(get_libdir)/bglibs/lib
+ [ "$(get_libdir)" != "lib" ] && dosym /usr/$(get_libdir)/bglibs /usr/$(get_libdir)/bglibs/$(get_libdir)
+ dosym /usr/include/bglibs /usr/$(get_libdir)/bglibs/include
+
+ #install .so in LDPATH
+ mv "${D}"/usr/$(get_libdir)/bglibs/libbg.so.1.1.1 "${D}"/usr/$(get_libdir)/
+ mv "${D}"/usr/$(get_libdir)/bglibs/libbg-sysdeps.so.1.1.1 "${D}"/usr/$(get_libdir)/
+ dosym libbg.so.1.1.1 /usr/$(get_libdir)/libbg.so.1
+ dosym libbg.so.1.1.1 /usr/$(get_libdir)/libbg.so
+ dosym libbg-sysdeps.so.1.1.1 /usr/$(get_libdir)/libbg-sysdeps.so.1
+ dosym libbg-sysdeps.so.1.1.1 /usr/$(get_libdir)/libbg-sysdeps.so
+
+ dosym ../libbg.so.1.1.1 /usr/$(get_libdir)/bglibs/libbg.so.1.1.1
+ dosym ../libbg-sysdeps.so.1.1.1 /usr/$(get_libdir)/bglibs/libbg-sysdeps.so.1.1.1
+
+ rm "${D}"/usr/$(get_libdir)/bglibs/libbg.la
+ rm "${D}"/usr/$(get_libdir)/bglibs/libbg-sysdeps.la
+
+ dodoc ANNOUNCEMENT NEWS README ChangeLog TODO VERSION
+ dohtml doc/html/*
+ docinto latex
+ dodoc doc/latex/*
+}
diff --git a/dev-libs/bglibs/bglibs-1.106.ebuild b/dev-libs/bglibs/bglibs-1.106.ebuild
new file mode 100644
index 000000000000..963fdadf0ebd
--- /dev/null
+++ b/dev-libs/bglibs/bglibs-1.106.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit toolchain-funcs eutils multilib
+
+DESCRIPTION="Bruce Guenters Libraries Collection"
+HOMEPAGE="http://untroubled.org/bglibs/"
+SRC_URI="http://untroubled.org/bglibs/archive/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+DEPEND=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.106-parallel-fix.patch
+ # disable tests as we want them manually
+ sed -i \
+ -e '/^all:/s|selftests||' \
+ "${S}"/Makefile
+ sed -i \
+ -e '/selftests/d' \
+ "${S}"/TARGETS
+ #sed -i \
+ # -e 's,^libraries:,LIBS = ,g' \
+ # -e '/^LIBS =/alibs-static: $(filter %.a,$(LIBS))' \
+ # -e '/^LIBS =/alibs-shared: $(filter %.la,$(LIBS))' \
+ # -e '/^LIBS =/alibraries: libs-static libs-shared' \
+ # "${S}"/Makefile
+}
+
+src_compile() {
+ echo "${D}/usr/bin" > conf-bin
+ echo "${D}/usr/$(get_libdir)/bglibs" > conf-lib
+ echo "${D}/usr/include/bglibs" > conf-include
+ echo "${D}/usr/share/man" > conf-man
+ echo "$(tc-getCC) ${CFLAGS}" > conf-cc
+ echo "$(tc-getCC) ${LDFLAGS}" > conf-ld
+ emake || die
+}
+
+src_test() {
+ einfo "Running selftests"
+ emake selftests
+}
+
+src_install () {
+ einstall || die "install failed"
+
+ #make backwards compatible symlinks
+ dosym /usr/lib/bglibs /usr/lib/bglibs/lib
+ dosym /usr/include/bglibs /usr/lib/bglibs/include
+
+ #install .so in LDPATH
+ mv "${D}"/usr/$(get_libdir)/bglibs/libbg.so.1.1.1 "${D}"/usr/$(get_libdir)/
+ mv "${D}"/usr/$(get_libdir)/bglibs/libbg-sysdeps.so.1.1.1 "${D}"/usr/$(get_libdir)/
+ dosym libbg.so.1.1.1 /usr/$(get_libdir)/libbg.so.1
+ dosym libbg.so.1.1.1 /usr/$(get_libdir)/libbg.so
+ dosym libbg-sysdeps.so.1.1.1 /usr/$(get_libdir)/libbg-sysdeps.so.1
+ dosym libbg-sysdeps.so.1.1.1 /usr/$(get_libdir)/libbg-sysdeps.so
+
+ dosym ../libbg.so.1.1.1 /usr/$(get_libdir)/bglibs/libbg.so.1.1.1
+ dosym ../libbg-sysdeps.so.1.1.1 /usr/$(get_libdir)/bglibs/libbg-sysdeps.so.1.1.1
+
+ rm "${D}"/usr/$(get_libdir)/bglibs/libbg.la
+ rm "${D}"/usr/$(get_libdir)/bglibs/libbg-sysdeps.la
+
+ dodoc ANNOUNCEMENT NEWS README ChangeLog TODO VERSION
+ dohtml doc/html/*
+ docinto latex
+ dodoc doc/latex/*
+}
diff --git a/dev-libs/bglibs/files/bglibs-1.104-parallel-fix.patch b/dev-libs/bglibs/files/bglibs-1.104-parallel-fix.patch
new file mode 100644
index 000000000000..d0717c2dd0f3
--- /dev/null
+++ b/dev-libs/bglibs/files/bglibs-1.104-parallel-fix.patch
@@ -0,0 +1,87 @@
+Fixes for parallel compile.
+
+- Redirection straight to an output target that is later used for dependancies
+ is not safe. The output file must be come into existence atomically.
+- libtool-2.x writes to .o AND .lo, regardless of the -o parameter. Because of
+ this, if you get a run order of compile then libcompile and makelib
+ simultaneously, there is a chance that the .o file from the original compile
+ can vanish and cause the makelib to fail. To deal with this, we split the
+ libraries target into shared and non-shared, and deliberately call the build
+ process as 3 phases: libs-shared, libs-static, all
+
+Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
+
+--- bglibs-1.104/Makefile.orig 2008-04-09 08:24:31.000000000 -0700
++++ bglibs-1.104/Makefile 2008-11-05 19:05:16.304710791 -0800
+@@ -254,7 +254,8 @@
+ ./compile crc-gentab.c
+
+ crc/crc16_arc_table.c: crc-gentab
+- ./crc-gentab crc16_arc 16 0x8005 reflected >$@
++ ./crc-gentab crc16_arc 16 0x8005 reflected >$@.tmp
++ mv $@.tmp $@
+
+ crc/crc16_arc_table.lo: libcompile crc/crc16_arc_table.c
+ ./libcompile crc/crc16_arc_table.c
+@@ -263,7 +264,8 @@
+ ./compile crc/crc16_arc_table.c
+
+ crc/crc16_ccitt_table.c: crc-gentab
+- ./crc-gentab crc16_ccitt 16 0x1021 normal >$@
++ ./crc-gentab crc16_ccitt 16 0x1021 normal >$@.tmp
++ mv $@.tmp $@
+
+ crc/crc16_ccitt_table.lo: libcompile crc/crc16_ccitt_table.c
+ ./libcompile crc/crc16_ccitt_table.c
+@@ -272,7 +274,8 @@
+ ./compile crc/crc16_ccitt_table.c
+
+ crc/crc16_xmodem_table.c: crc-gentab
+- ./crc-gentab crc16_xmodem 16 0x8408 reflected >$@
++ ./crc-gentab crc16_xmodem 16 0x8408 reflected >$@.tmp
++ mv $@.tmp $@
+
+ crc/crc16_xmodem_table.lo: libcompile crc/crc16_xmodem_table.c
+ ./libcompile crc/crc16_xmodem_table.c
+@@ -281,7 +284,8 @@
+ ./compile crc/crc16_xmodem_table.c
+
+ crc/crc32_table.c: crc-gentab
+- ./crc-gentab crc32 32 0x04C11DB7 reflected >$@
++ ./crc-gentab crc32 32 0x04C11DB7 reflected >$@.tmp
++ mv $@.tmp $@
+
+ crc/crc32_table.lo: libcompile crc/crc32_table.c
+ ./libcompile crc/crc32_table.c
+@@ -290,7 +294,8 @@
+ ./compile crc/crc32_table.c
+
+ crc/crc32c_table.c: crc-gentab
+- ./crc-gentab crc32c 32 0x1EDC6F41 reflected >$@
++ ./crc-gentab crc32c 32 0x1EDC6F41 reflected >$@.tmp
++ mv $@.tmp $@
+
+ crc/crc32c_table.lo: libcompile crc/crc32c_table.c
+ ./libcompile crc/crc32c_table.c
+@@ -299,7 +304,8 @@
+ ./compile crc/crc32c_table.c
+
+ crc/crc64_table.c: crc-gentab
+- ./crc-gentab crc64 64 0x42F0E1EBA9EA3693 normal >$@
++ ./crc-gentab crc64 64 0x42F0E1EBA9EA3693 normal >$@.tmp
++ mv $@.tmp $@
+
+ crc/crc64_table.lo: libcompile crc/crc64_table.c
+ ./libcompile crc/crc64_table.c
+@@ -1025,7 +1025,10 @@
+ libpwcmp.a: makelib pwcmp/client.o pwcmp/hex_encode.o
+ ./makelib libpwcmp.a pwcmp/client.o pwcmp/hex_encode.o
+
+-libraries: libbg.la libbg-sysdeps.la libbg-crc.a libpwcmp.a libbg-path.a libbg-instcheck.a libbg-base64.a libbg-adt.a libbg-installer.a libvmailmgr.a libbg-sysdeps.a libbg-str.a libbg-fmt.a libpwcmp-module.a libbg-misc.a libbg-instshow.a libbg-dict.a libbg-crypto.a libbg-cli.a libbg-cdb.a libbg-msg.a libbg-iobuf.a libbg-net.a libbg-unix.a
++LIBS = libbg.la libbg-sysdeps.la libbg-crc.a libpwcmp.a libbg-path.a libbg-instcheck.a libbg-base64.a libbg-adt.a libbg-installer.a libvmailmgr.a libbg-sysdeps.a libbg-str.a libbg-fmt.a libpwcmp-module.a libbg-misc.a libbg-instshow.a libbg-dict.a libbg-crypto.a libbg-cli.a libbg-cdb.a libbg-msg.a libbg-iobuf.a libbg-net.a libbg-unix.a
++libs-shared: $(filter %.la,$(LIBS))
++libs-static: $(filter %.a,$(LIBS))
++libraries: libs-shared libs-static
+
+ libvmailmgr.a: makelib vmailmgr/req_arg.o vmailmgr/req_init.o vmailmgr/req_write.o vmailmgr/resp_read.o vmailmgr/vpwentry_export.o vmailmgr/vpwentry_free.o vmailmgr/vpwentry_import.o
+ ./makelib libvmailmgr.a vmailmgr/req_arg.o vmailmgr/req_init.o vmailmgr/req_write.o vmailmgr/resp_read.o vmailmgr/vpwentry_export.o vmailmgr/vpwentry_free.o vmailmgr/vpwentry_import.o
diff --git a/dev-libs/bglibs/files/bglibs-1.106-parallel-fix.patch b/dev-libs/bglibs/files/bglibs-1.106-parallel-fix.patch
new file mode 100644
index 000000000000..30c13e8c75fa
--- /dev/null
+++ b/dev-libs/bglibs/files/bglibs-1.106-parallel-fix.patch
@@ -0,0 +1,61 @@
+Forward port to 1.106 by Thilo Bangert <bangert@gentoo.org>
+Fixes for parallel compile.
+
+- Redirection straight to an output target that is later used for dependancies
+ is not safe. The output file must be come into existence atomically.
+
+Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
+
+diff -Naur bglibs-1.106.orig/Makefile bglibs-1.106/Makefile
+--- bglibs-1.106.orig/Makefile 2009-11-20 11:52:29.000000000 +0100
++++ bglibs-1.106/Makefile 2009-11-20 11:56:01.000000000 +0100
+@@ -152,37 +152,43 @@
+ ./compile crc-gentab.c
+
+ crc/crc16_arc_table.c: crc-gentab
+- ./crc-gentab crc16_arc 16 0x8005 reflected >$@
++ ./crc-gentab crc16_arc 16 0x8005 reflected >$@.tmp
++ mv $@.tmp $@
+
+ crc/crc16_arc_table.lo crc/crc16_arc_table.o: ltcompile crc/crc16_arc_table.c
+ ./ltcompile crc/crc16_arc_table.c
+
+ crc/crc16_ccitt_table.c: crc-gentab
+- ./crc-gentab crc16_ccitt 16 0x1021 normal >$@
++ ./crc-gentab crc16_ccitt 16 0x1021 normal >$@.tmp
++ mv $@.tmp $@
+
+ crc/crc16_ccitt_table.lo crc/crc16_ccitt_table.o: ltcompile crc/crc16_ccitt_table.c
+ ./ltcompile crc/crc16_ccitt_table.c
+
+ crc/crc16_xmodem_table.c: crc-gentab
+- ./crc-gentab crc16_xmodem 16 0x8408 reflected >$@
++ ./crc-gentab crc16_xmodem 16 0x8408 reflected >$@.tmp
++ mv $@.tmp $@
+
+ crc/crc16_xmodem_table.lo crc/crc16_xmodem_table.o: ltcompile crc/crc16_xmodem_table.c
+ ./ltcompile crc/crc16_xmodem_table.c
+
+ crc/crc32_table.c: crc-gentab
+- ./crc-gentab crc32 32 0x04C11DB7 reflected >$@
++ ./crc-gentab crc32 32 0x04C11DB7 reflected >$@.tmp
++ mv $@.tmp $@
+
+ crc/crc32_table.lo crc/crc32_table.o: ltcompile crc/crc32_table.c
+ ./ltcompile crc/crc32_table.c
+
+ crc/crc32c_table.c: crc-gentab
+- ./crc-gentab crc32c 32 0x1EDC6F41 reflected >$@
++ ./crc-gentab crc32c 32 0x1EDC6F41 reflected >$@.tmp
++ mv $@.tmp $@
+
+ crc/crc32c_table.lo crc/crc32c_table.o: ltcompile crc/crc32c_table.c
+ ./ltcompile crc/crc32c_table.c
+
+ crc/crc64_table.c: crc-gentab
+- ./crc-gentab crc64 64 0x42F0E1EBA9EA3693 normal >$@
++ ./crc-gentab crc64 64 0x42F0E1EBA9EA3693 normal >$@.tmp
++ mv $@.tmp $@
+
+ crc/crc64_table.lo crc/crc64_table.o: ltcompile crc/crc64_table.c
+ ./ltcompile crc/crc64_table.c
diff --git a/dev-libs/bglibs/metadata.xml b/dev-libs/bglibs/metadata.xml
new file mode 100644
index 000000000000..a732fd8b2f03
--- /dev/null
+++ b/dev-libs/bglibs/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>robbat2@gentoo.org</email>
+ <name>Robin H. Johnson</name>
+ </maintainer>
+</pkgmetadata>