summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2018-04-03 09:27:40 +0300
committerAlon Bar-Lev <alonbl@gentoo.org>2018-04-03 09:28:09 +0300
commit581cab67637a9f8e159491f0d0bde735af207532 (patch)
tree5f3903249656ea4bd3c18f4ba3683befa6145654 /dev-libs/botan
parentapp-admin/webalizer: stable 2.23.08 for ppc64, bug #648092 (diff)
downloadgentoo-581cab67637a9f8e159491f0d0bde735af207532.tar.gz
gentoo-581cab67637a9f8e159491f0d0bde735af207532.tar.bz2
gentoo-581cab67637a9f8e159491f0d0bde735af207532.zip
dev-libs/botan: version bump
Bug: https://bugs.gentoo.org/show_bug.cgi?id=652254 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-libs/botan')
-rw-r--r--dev-libs/botan/Manifest1
-rw-r--r--dev-libs/botan/botan-2.5.0.ebuild (renamed from dev-libs/botan/botan-9999.ebuild)16
2 files changed, 8 insertions, 9 deletions
diff --git a/dev-libs/botan/Manifest b/dev-libs/botan/Manifest
index 87a901fd1f88..05d44f20dad6 100644
--- a/dev-libs/botan/Manifest
+++ b/dev-libs/botan/Manifest
@@ -1,2 +1,3 @@
DIST Botan-1.10.17.tgz 2706678 BLAKE2B bce65493c702381aaa747c2b935c545f85704b93bb6be4bf225048cc14812999291bbbe86786c2b00865489ec47d63128b12ef1020be8651be57fa1c84006a7c SHA512 a47cab3af113652247c8efc8b0f043eb62175eaa8554833d5fc3016ea94dbdd8aa722ab9b5226cc5f133afbcc088d54362111630eaa4594812c39925cc3c8649
DIST Botan-2.3.0.tgz 5947072 BLAKE2B b8eaf4228c01200f839031b423901f93c1b6863d10424ad52afeac85131e95bc1bad024478c8e4c8e4c12210e85aa62d30fb83b3ece8facdb57763f95c45687c SHA512 a8575bdb2eaa01fb45d8565bea0b54ddf47a21d2fb761fc0a286373b09d51e5a00e84d5cefc51040c5720db66f5625c6bc73ab09cffa9cd42472545610f9892a
+DIST Botan-2.5.0.tgz 6596225 BLAKE2B ffb5647e5734a8bef14b6c52ad12a211844e9c73f843427cb2972813523091cef99a21cea3d6a8bf69367f0d937ea0a422d2ed8aaf839ee1c7a2d95a1bd702a8 SHA512 51d91bcf6ba41247fbb649697e33e3a0c8ba9f35ba7865be9120c0f0efb7fa8c51fb3d922f0d5576ae1ef637188821ff4352ed45de52e0798910ee354787cdda
diff --git a/dev-libs/botan/botan-9999.ebuild b/dev-libs/botan/botan-2.5.0.ebuild
index 64cfdba155d9..d23a7ef344f7 100644
--- a/dev-libs/botan/botan-9999.ebuild
+++ b/dev-libs/botan/botan-2.5.0.ebuild
@@ -1,21 +1,24 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
inherit multilib python-r1 toolchain-funcs
-inherit git-r3
+MY_PN="Botan"
+MY_P="${MY_PN}-${PV}"
DESCRIPTION="A C++ crypto library"
HOMEPAGE="http://botan.randombit.net/"
-EGIT_REPO_URI="https://github.com/randombit/botan"
+SRC_URI="http://botan.randombit.net/releases/${MY_P}.tgz"
-KEYWORDS=""
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~ppc-macos"
SLOT="2/3" # soname version
LICENSE="BSD"
IUSE="bindist doc boost python bzip2 libressl lzma sqlite ssl static-libs zlib"
+S="${WORKDIR}/${MY_P}"
+
RDEPEND="bzip2? ( >=app-arch/bzip2-1.0.5 )
zlib? ( >=sys-libs/zlib-1.2.3 )
boost? ( >=dev-libs/boost-1.48 )
@@ -29,11 +32,6 @@ DEPEND="${RDEPEND}
dev-lang/python:*
doc? ( dev-python/sphinx )"
-src_prepare() {
- default
- use python && python_copy_sources
-}
-
src_configure() {
local disable_modules=()
use boost || disable_modules+=( "boost" )