summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-10-25 01:38:39 +0200
committerDavid Seifert <soap@gentoo.org>2016-10-25 02:08:35 +0200
commita183cd2a914e830b91c97445f32ffd7d9a073536 (patch)
treeb3c51c272db1663a02c6fe21f5ec7309609a50ac /dev-libs/c-blosc
parentdev-lang/rust: PDEPEND on dev-util/cargo (diff)
downloadgentoo-a183cd2a914e830b91c97445f32ffd7d9a073536.tar.gz
gentoo-a183cd2a914e830b91c97445f32ffd7d9a073536.tar.bz2
gentoo-a183cd2a914e830b91c97445f32ffd7d9a073536.zip
dev-libs/c-blosc: Version bump to 1.11.1
* EAPI=6 Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-libs/c-blosc')
-rw-r--r--dev-libs/c-blosc/Manifest1
-rw-r--r--dev-libs/c-blosc/c-blosc-1.11.1.ebuild55
-rw-r--r--dev-libs/c-blosc/files/c-blosc-1.11.1-fix-build-system.patch30
-rw-r--r--dev-libs/c-blosc/metadata.xml37
4 files changed, 105 insertions, 18 deletions
diff --git a/dev-libs/c-blosc/Manifest b/dev-libs/c-blosc/Manifest
index 8d8c47535d87..2e4943a6d405 100644
--- a/dev-libs/c-blosc/Manifest
+++ b/dev-libs/c-blosc/Manifest
@@ -1,3 +1,4 @@
+DIST c-blosc-1.11.1.tar.gz 622500 SHA256 d15937961d37b0780b8fb0641483eb9f6d4c379f88ac7ee84ff5dd06c2b72360 SHA512 75100cd8447c78c97b02ed8242d966c37c4050f216805d927b3d41367cb7899adfa13a9b61bc3bf3306be976f99f1a668c95f5a83f61929ccdf48f4edf630cb7 WHIRLPOOL db9226096078519002cfd3c93db92fa9ed71f2d6c3a9bca3cf267e63ea6c7d2f34ace6947af652a208e1b715e1aed53674733e67428381c04ff6c31f3a455b11
DIST c-blosc-1.3.2.tar.gz 229790 SHA256 7c21c4484c1ad7d6beddd73f35379e0d980530466cd6d87402e035c931983697 SHA512 0488042628b8b3d02e8e7b58d3d942751a43567e99e1e89f452765ad1aeba395248322df6a37daf828571b3c262ebaa54d3ca49cfed78ab499994454faf6bbdb WHIRLPOOL 195232123fbbd4f76f3a209069e7895c3ba900e98c49ca8334e1975634770463d993ae36f99fefb680d7c78a28ca979c27cd4af4412e83c804315f6cf52420fe
DIST c-blosc-1.3.5.tar.gz 231653 SHA256 60efbbd2ef613480d135dbb245260e7cd904cfd785cc2504458615d7b397675a SHA512 4c11309a3f5dd0e2ecb35f62480cf86a9ad8d8d84b0d744c0597a51d8f51010a2ed0ad868cc3aef1f674efc1c35ee3312ad727cb308b348026f08db0ac9ab04a WHIRLPOOL 58742b85bf1d9637492871cab0f0c0b87c96162b2dfbf196e91f62569f6a06077b901a202fab43f39472ccf728550340a85bd60f3fee1d6e0e76d655659db3f0
DIST c-blosc-1.5.3.tar.gz 240821 SHA256 d6d7c72d8e49311618f5f1609df1a9b2ca070655b563b9f7b80d5dc92fceaf4f SHA512 92f0a47ff6af2b776795315fce52e49c12e947e9007f97d05182a8369831e0ba80ff7b2b116fdedc4ef2b984106b014c90f82e233d5aed85cd91e3256f4a7313 WHIRLPOOL 9178c1a4e8e476b2a0556106ecbf58eb10bd076e3c731048d988f1e3dcaefa593cea176c6f5ec391c54a651421cce40858f1eae4ba9fc91d60a0fc158fe9fbc7
diff --git a/dev-libs/c-blosc/c-blosc-1.11.1.ebuild b/dev-libs/c-blosc/c-blosc-1.11.1.ebuild
new file mode 100644
index 000000000000..4c6ff57c497a
--- /dev/null
+++ b/dev-libs/c-blosc/c-blosc-1.11.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="Blocking, shuffling and lossless compression library"
+HOMEPAGE="http://www.blosc.org/"
+SRC_URI="https://github.com/Blosc/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+
+SLOT="0/1"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+IUSE="cpu_flags_x86_avx2 +lz4 +snappy static-libs test zlib zstd"
+
+RDEPEND="
+ lz4? ( >=app-arch/lz4-0_p120:= )
+ snappy? ( app-arch/snappy )
+ zlib? ( sys-libs/zlib )
+ zstd? ( app-arch/zstd )"
+DEPEND="${RDEPEND}"
+
+DOCS=( README.rst RELEASE_NOTES.rst THOUGHTS_FOR_2.0.txt ANNOUNCE.rst )
+PATCHES=( "${FILESDIR}/${PN}-1.11.1-fix-build-system.patch" )
+
+src_prepare() {
+ cmake-utils_src_prepare
+
+ # remove bundled libs
+ rm -rf internal-complibs || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_STATIC=$(usex static-libs)
+ -DBUILD_TESTS=$(usex test)
+ -DBUILD_BENCHMARKS=OFF
+
+ -DDEACTIVATE_AVX2=$(usex !cpu_flags_x86_avx2)
+ -DDEACTIVATE_LZ4=$(usex !lz4)
+ -DDEACTIVATE_SNAPPY=$(usex !snappy)
+ -DDEACTIVATE_ZLIB=$(usex !zlib)
+ -DDEACTIVATE_ZSTD=$(usex !zstd)
+
+ -DPREFER_EXTERNAL_LZ4=ON
+ -DPREFER_EXTERNAL_SNAPPY=ON
+ -DPREFER_EXTERNAL_ZLIB=ON
+ -DPREFER_EXTERNAL_ZSTD=ON
+ )
+ cmake-utils_src_configure
+}
diff --git a/dev-libs/c-blosc/files/c-blosc-1.11.1-fix-build-system.patch b/dev-libs/c-blosc/files/c-blosc-1.11.1-fix-build-system.patch
new file mode 100644
index 000000000000..02c5fc2d8ab3
--- /dev/null
+++ b/dev-libs/c-blosc/files/c-blosc-1.11.1-fix-build-system.patch
@@ -0,0 +1,30 @@
+Make the build system respect CFLAGS
+
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -195,7 +195,7 @@
+ CMAKE_SYSTEM_PROCESSOR STREQUAL AMD64)
+ if(CMAKE_C_COMPILER_ID STREQUAL GNU)
+ # We need C99 (GNU99 more exactly)
+- SET(CMAKE_C_FLAGS "-std=gnu99")
++ SET(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -std=gnu99")
+ set(COMPILER_SUPPORT_SSE2 TRUE)
+ if(CMAKE_C_COMPILER_VERSION VERSION_GREATER 4.7 OR CMAKE_C_COMPILER_VERSION VERSION_EQUAL 4.7)
+ set(COMPILER_SUPPORT_AVX2 TRUE)
+@@ -244,16 +244,6 @@
+ endif()
+
+ # flags
+-# @TODO: set -Wall
+-# @NOTE: -O3 is enabled in Release mode (CMAKE_BUILD_TYPE="Release")
+-
+-# Set the "-msse2" build flag only if the CMAKE_C_FLAGS is not already set.
+-# Probably "-msse2" should be appended to CMAKE_C_FLAGS_RELEASE.
+-if(CMAKE_C_COMPILER_ID STREQUAL GNU OR CMAKE_C_COMPILER_ID STREQUAL Clang OR CMAKE_C_COMPILER_ID STREQUAL Intel)
+- if(NOT CMAKE_C_FLAGS AND COMPILER_SUPPORT_SSE2)
+- set(CMAKE_C_FLAGS -msse2 CACHE STRING "C flags." FORCE)
+- endif(NOT CMAKE_C_FLAGS AND COMPILER_SUPPORT_SSE2)
+-endif(CMAKE_C_COMPILER_ID STREQUAL GNU OR CMAKE_C_COMPILER_ID STREQUAL Clang OR CMAKE_C_COMPILER_ID STREQUAL Intel)
+
+ if(MSVC)
+ if(NOT CMAKE_C_FLAGS)
diff --git a/dev-libs/c-blosc/metadata.xml b/dev-libs/c-blosc/metadata.xml
index 2838e037e669..646211224e11 100644
--- a/dev-libs/c-blosc/metadata.xml
+++ b/dev-libs/c-blosc/metadata.xml
@@ -1,22 +1,23 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="project">
- <email>sci@gentoo.org</email>
- <name>Gentoo Science Project</name>
- </maintainer>
- <longdescription lang="en">
- Blosc is a compression library designed to transmit data to the
- processor cache faster than the traditional non-compressed memory fetch.
- Compression ratios are not very high, but the decompression is very
- fast. Blosc is meant not only to reduce the size of large datasets on-disk
- or in-memory, but also to accelerate memory-bound computations.
-</longdescription>
- <use>
- <flag name="lz4">Enable lz4 compression</flag>
- <flag name="snappy">Enable snappy compression</flag>
- </use>
- <upstream>
- <remote-id type="github">Blosc/c-blosc</remote-id>
- </upstream>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ Blosc is a compression library designed to transmit data to the
+ processor cache faster than the traditional non-compressed memory fetch.
+ Compression ratios are not very high, but the decompression is very
+ fast. Blosc is meant not only to reduce the size of large datasets on-disk
+ or in-memory, but also to accelerate memory-bound computations.
+ </longdescription>
+ <use>
+ <flag name="lz4">Enable lz4 compression</flag>
+ <flag name="snappy">Enable snappy compression</flag>
+ <flag name="zstd">Enable zstd compression</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">Blosc/c-blosc</remote-id>
+ </upstream>
</pkgmetadata>