summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/e_dbus
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/e_dbus')
-rw-r--r--dev-libs/e_dbus/Manifest1
-rw-r--r--dev-libs/e_dbus/e_dbus-1.7.10.ebuild59
-rw-r--r--dev-libs/e_dbus/e_dbus-9999.ebuild66
-rw-r--r--dev-libs/e_dbus/metadata.xml10
4 files changed, 136 insertions, 0 deletions
diff --git a/dev-libs/e_dbus/Manifest b/dev-libs/e_dbus/Manifest
new file mode 100644
index 000000000000..624a29c76a05
--- /dev/null
+++ b/dev-libs/e_dbus/Manifest
@@ -0,0 +1 @@
+DIST e_dbus-1.7.10.tar.bz2 439191 SHA256 b93f778a4bf50ce044b4798e08a03f62e9b890c47305f9d5839989481f38ddd4 SHA512 db3e3106cd3f66699dd59433beb8592115a8970982c7dc49f04458bc162acbbece5c6ec08bea994cc7eca04fe786ad45961bb555d2dfd364d07d3673d144b3c4 WHIRLPOOL 2f351946be4e47722fb6c027641d0054aed5fcd1523a02d20758763423100086e4c5bcf129f448c764a39ce8b4748c62b58c5e8dc9d3e676077866879b219f04
diff --git a/dev-libs/e_dbus/e_dbus-1.7.10.ebuild b/dev-libs/e_dbus/e_dbus-1.7.10.ebuild
new file mode 100644
index 000000000000..91402e20abdd
--- /dev/null
+++ b/dev-libs/e_dbus/e_dbus-1.7.10.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit enlightenment
+
+DESCRIPTION="Enlightenment's (Ecore) integration to DBus"
+SRC_URI="http://download.enlightenment.org/releases/${P}.tar.bz2"
+
+LICENSE="BSD-2"
+KEYWORDS="amd64 ~arm x86"
+IUSE="bluetooth +connman +libnotify ofono static-libs test-binaries +udev"
+
+RDEPEND=">=dev-libs/efl-1.8.4
+ sys-apps/dbus
+ connman? ( >=net-misc/connman-0.75 )
+ udev? ( || ( sys-power/upower sys-power/upower-pm-utils ) sys-fs/udisks:0 )
+"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${PN}-${PV%%_*}
+
+src_configure() {
+ E_ECONF+=(
+ $(use_enable bluetooth ebluez)
+ $(use_enable connman econnman0_7x)
+ $(use_enable doc)
+ --disable-ehal
+ $(use_enable libnotify enotify)
+ $(use_enable ofono eofono)
+ $(use_enable test-binaries edbus-test)
+ $(use_enable test-binaries edbus-test-client)
+ $(use_enable udev eukit)
+ )
+ if use test-binaries ; then
+ E_ECONF+=(
+ $(use_enable bluetooth edbus-bluez-test)
+ $(use_enable connman edbus-connman0_7x-test)
+ $(use_enable libnotify edbus-notification-daemon-test)
+ $(use_enable libnotify edbus-notify-test)
+ $(use_enable ofono edbus-ofono-test)
+ $(use_enable udev edbus-ukit-test)
+ )
+ else
+ E_ECONF+=(
+ --disable-edbus-bluez-test
+ --disable-edbus-connman0_7x-test
+ --disable-edbus-notification-daemon-test
+ --disable-edbus-notify-test
+ --disable-edbus-ofono-test
+ --disable-edbus-ukit-test
+ --disable-edbus-async-test
+ --disable-edbus-performance-test
+ )
+ fi
+ enlightenment_src_configure
+}
diff --git a/dev-libs/e_dbus/e_dbus-9999.ebuild b/dev-libs/e_dbus/e_dbus-9999.ebuild
new file mode 100644
index 000000000000..a8f1961b40d3
--- /dev/null
+++ b/dev-libs/e_dbus/e_dbus-9999.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_SUB_PROJECT="legacy"
+ EGIT_URI_APPEND=${PN}
+ EGIT_BRANCH=${PN}-1.7
+else
+ SRC_URI="http://download.enlightenment.org/releases/${P}.tar.bz2"
+ EKEY_STATE="snap"
+fi
+
+inherit enlightenment
+
+DESCRIPTION="Enlightenment's (Ecore) integration to DBus"
+
+LICENSE="BSD-2"
+IUSE="bluetooth +connman +libnotify ofono static-libs test-binaries +udev"
+
+RDEPEND=">=dev-libs/efl-1.8.4
+ sys-apps/dbus
+ connman? ( >=net-misc/connman-0.75 )
+ udev? ( || ( sys-power/upower sys-power/upower-pm-utils ) sys-fs/udisks:0 )
+"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${PN}-${PV%%_*}
+
+src_configure() {
+ E_ECONF=(
+ $(use_enable bluetooth ebluez)
+ $(use_enable connman econnman0_7x)
+ $(use_enable doc)
+ --disable-ehal
+ $(use_enable libnotify enotify)
+ $(use_enable ofono eofono)
+ $(use_enable test-binaries edbus-test)
+ $(use_enable test-binaries edbus-test-client)
+ $(use_enable udev eukit)
+ )
+ if use test-binaries ; then
+ E_ECONF+=(
+ $(use_enable bluetooth edbus-bluez-test)
+ $(use_enable connman edbus-connman0_7x-test)
+ $(use_enable libnotify edbus-notification-daemon-test)
+ $(use_enable libnotify edbus-notify-test)
+ $(use_enable ofono edbus-ofono-test)
+ $(use_enable udev edbus-ukit-test)
+ )
+ else
+ E_ECONF+=(
+ --disable-edbus-bluez-test
+ --disable-edbus-connman0_7x-test
+ --disable-edbus-notification-daemon-test
+ --disable-edbus-notify-test
+ --disable-edbus-ofono-test
+ --disable-edbus-ukit-test
+ --disable-edbus-async-test
+ --disable-edbus-performance-test
+ )
+ fi
+ enlightenment_src_configure
+}
diff --git a/dev-libs/e_dbus/metadata.xml b/dev-libs/e_dbus/metadata.xml
new file mode 100644
index 000000000000..cbc5ba0dda2f
--- /dev/null
+++ b/dev-libs/e_dbus/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>enlightenment</herd>
+<use>
+ <flag name="bluetooth">Enable interfacing with <pkg>net-wireless/bluez</pkg> DBus API.</flag>
+ <flag name="ofono">Enable interfacing with <pkg>net-misc/ofono</pkg> DBus API.</flag>
+ <flag name="test-binaries">Enable building of test binaries for enabled features</flag>
+</use>
+</pkgmetadata>