summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2017-06-07 23:49:32 +0200
committerSebastian Pipping <sping@gentoo.org>2017-06-08 00:26:40 +0200
commit715a2315ee2b841e38843e61b43ee058b5678cab (patch)
tree33876b50d9246530e663931d367d3ac2f94b4a8f /dev-libs/expat
parentnet-dns/dnsmasq: Update the DHCP version of the init script as well (diff)
downloadgentoo-715a2315ee2b841e38843e61b43ee058b5678cab.tar.gz
gentoo-715a2315ee2b841e38843e61b43ee058b5678cab.tar.bz2
gentoo-715a2315ee2b841e38843e61b43ee058b5678cab.zip
dev-libs/expat: Sync USE=unicode with Debian
* Drop libexpatu.so * Turn libexpatw.so from XML_UNICODE_WCHAR_T to XML_UNICODE * Upgrade to EAPI 6 * Add myself as a maintainer Discussion: https://archives.gentoo.org/gentoo-dev/message/2c202e403a223a397a32bc8991628335 Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-libs/expat')
-rw-r--r--dev-libs/expat/expat-2.2.0-r2.ebuild83
-rw-r--r--dev-libs/expat/metadata.xml4
2 files changed, 87 insertions, 0 deletions
diff --git a/dev-libs/expat/expat-2.2.0-r2.ebuild b/dev-libs/expat/expat-2.2.0-r2.ebuild
new file mode 100644
index 000000000000..e94a4b0ede23
--- /dev/null
+++ b/dev-libs/expat/expat-2.2.0-r2.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils libtool multilib toolchain-funcs multilib-minimal
+
+DESCRIPTION="Stream-oriented XML parser library"
+HOMEPAGE="http://expat.sourceforge.net/"
+SRC_URI="mirror://sourceforge/expat/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
+IUSE="elibc_FreeBSD examples static-libs unicode"
+RDEPEND="abi_x86_32? ( !<=app-emulation/emul-linux-x86-baselibs-20130224-r6
+ !app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)] )"
+
+DOCS=( Changes README )
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.1.1-CVE-2016-0718-regression.patch
+ eapply_user
+}
+
+multilib_src_configure() {
+ local myconf="$(use_enable static-libs static)"
+
+ mkdir -p "${BUILD_DIR}"{u,w} || die
+
+ ECONF_SOURCE="${S}" econf ${myconf}
+
+ if use unicode; then
+ pushd "${BUILD_DIR}"w >/dev/null
+ CPPFLAGS="${CPPFLAGS} -DXML_UNICODE" ECONF_SOURCE="${S}" econf ${myconf}
+ popd >/dev/null
+ fi
+}
+
+multilib_src_compile() {
+ emake
+
+ if use unicode; then
+ pushd "${BUILD_DIR}"w >/dev/null
+ emake buildlib LIBRARY=libexpatw.la
+ popd >/dev/null
+ fi
+}
+
+multilib_src_install() {
+ emake install DESTDIR="${D}"
+
+ if use unicode; then
+ pushd "${BUILD_DIR}"w >/dev/null
+ emake installlib DESTDIR="${D}" LIBRARY=libexpatw.la
+ popd >/dev/null
+
+ pushd "${ED}"/usr/$(get_libdir)/pkgconfig >/dev/null
+ cp expat.pc expatw.pc
+ sed -i -e '/^Libs/s:-lexpat:&w:' expatw.pc || die
+ popd >/dev/null
+ fi
+
+ if multilib_is_native_abi ; then
+ # libgeom in /lib and ifconfig in /sbin require libexpat on FreeBSD since
+ # we stripped the libbsdxml copy starting from freebsd-lib-8.2-r1
+ use elibc_FreeBSD && gen_usr_ldscript -a expat
+ fi
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ # Note: Use of HTML_DOCS would add unwanted "doc" subfolder
+ docinto html
+ dodoc doc/*.{css,html,png}
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*.c
+ fi
+
+ prune_libtool_files
+}
diff --git a/dev-libs/expat/metadata.xml b/dev-libs/expat/metadata.xml
index 938cef8d9921..173bc1d11186 100644
--- a/dev-libs/expat/metadata.xml
+++ b/dev-libs/expat/metadata.xml
@@ -5,6 +5,10 @@
<email>freedesktop-bugs@gentoo.org</email>
<name>Gentoo Freedesktop Project</name>
</maintainer>
+ <maintainer type="person">
+ <email>sping@gentoo.org</email>
+ <name>Sebastian Pipping</name>
+ </maintainer>
<upstream>
<remote-id type="cpe">cpe:/a:libexpat:expat</remote-id>
<remote-id type="sourceforge">expat</remote-id>