summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-04-23 02:39:39 +0200
committerLars Wendler <polynomial-c@gentoo.org>2018-04-23 02:39:54 +0200
commitbe61b94e57ae696b4c39c4c47f0d5498b477535f (patch)
tree541fb5c03227c329f0e3c379c18ffa42ab548200 /dev-libs/libbytesize
parentx11-libs/libdrm-2.4.89: hppa stable, bug 652350 (diff)
downloadgentoo-be61b94e57ae696b4c39c4c47f0d5498b477535f.tar.gz
gentoo-be61b94e57ae696b4c39c4c47f0d5498b477535f.tar.bz2
gentoo-be61b94e57ae696b4c39c4c47f0d5498b477535f.zip
dev-libs/libbytesize: Bump to version 1.3
Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'dev-libs/libbytesize')
-rw-r--r--dev-libs/libbytesize/Manifest1
-rw-r--r--dev-libs/libbytesize/libbytesize-1.3.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/dev-libs/libbytesize/Manifest b/dev-libs/libbytesize/Manifest
index 8beb212156db..37a98d6f41a3 100644
--- a/dev-libs/libbytesize/Manifest
+++ b/dev-libs/libbytesize/Manifest
@@ -1 +1,2 @@
DIST libbytesize-1.2.tar.gz 70598 BLAKE2B e136b1274703da7b3596e7583cea1ac773c1594af09c626f4dbb481dfcc23a3186b03ebdc54bba67d0a063c5d6587f6b7f8b610828c461cfd114eea1388dd193 SHA512 a8151e7440d0ec43d10239ddf08a9924827cdf08f20a16dff6177b444c1022fab905a0567384531e7610d854998111adb77f9a6a98e2d9648c02521f84ea2bf2
+DIST libbytesize-1.3.tar.gz 71648 BLAKE2B 40794a38af8ee1fcc03ef8000b20123c0e02e208f329a75e7da3a18b224e4a8456ce5982d72e4eefa2ff9d9dcd90b98142037dd37be6bc31f25e2ff347010829 SHA512 a50f5d4ea07a295909e09168518f8fc25da8dcd52859beca9c9c3b8c8c180b025c774c730d449ffbd4c7fd5aba07b5d071b6d9ad36f9d9ebc96bb06699aa08f3
diff --git a/dev-libs/libbytesize/libbytesize-1.3.ebuild b/dev-libs/libbytesize/libbytesize-1.3.ebuild
new file mode 100644
index 000000000000..ec3d92738f16
--- /dev/null
+++ b/dev-libs/libbytesize/libbytesize-1.3.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+
+inherit autotools python-r1
+
+DESCRIPTION="Tiny library providing a C \"class\" for working with arbitrary big sizes in bytes"
+HOMEPAGE="https://github.com/rhinstaller/libbytesize"
+SRC_URI="https://github.com/rhinstaller/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc test"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-libs/gmp:0=
+ dev-libs/mpfr:=
+ >=dev-libs/libpcre-8.32
+"
+
+DEPEND="
+ ${RDEPEND}
+ sys-devel/gettext
+ doc? ( dev-util/gtk-doc )
+ test? (
+ dev-python/pocketlint
+ dev-python/polib
+ )
+"
+
+RESTRICT="test"
+
+pkg_setup() {
+ python_setup
+}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_with python_targets_python2_7 python2)
+ $(use_with doc gtk-doc)
+ )
+ if use python_targets_python3_4 || use python_targets_python3_5 || use python_targets_python3_6 ; then
+ myeconfargs+=( --with-python3 )
+ else
+ myeconfargs+=( --without-python3 )
+ fi
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ emake install DESTDIR="${D}"
+
+ python_install() {
+ emake -C src/python install DESTDIR="${D}"
+ python_optimize
+ }
+ python_foreach_impl python_install
+
+ find "${ED}" -name "*.la*" -delete || die
+}