summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2020-03-04 12:42:34 -0800
committerMatt Turner <mattst88@gentoo.org>2020-03-04 12:44:53 -0800
commitc80686ffa38465feef3dc3da17795b80c8d2abe1 (patch)
tree15703971e4d2a72ac6aa79ec6a75d8bd5ec84dd9 /dev-libs/libevdev/libevdev-9999.ebuild
parentmedia-video/vdr: drop old buggy version (diff)
downloadgentoo-c80686ffa38465feef3dc3da17795b80c8d2abe1.tar.gz
gentoo-c80686ffa38465feef3dc3da17795b80c8d2abe1.tar.bz2
gentoo-c80686ffa38465feef3dc3da17795b80c8d2abe1.zip
dev-libs/libevdev: Port to Meson
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-libs/libevdev/libevdev-9999.ebuild')
-rw-r--r--dev-libs/libevdev/libevdev-9999.ebuild38
1 files changed, 24 insertions, 14 deletions
diff --git a/dev-libs/libevdev/libevdev-9999.ebuild b/dev-libs/libevdev/libevdev-9999.ebuild
index ffddd6b0bd13..c975e202b807 100644
--- a/dev-libs/libevdev/libevdev-9999.ebuild
+++ b/dev-libs/libevdev/libevdev-9999.ebuild
@@ -3,16 +3,16 @@
EAPI=7
-PYTHON_COMPAT=( python{3_6,3_7} )
+PYTHON_COMPAT=( python3_{6,7,8} )
-inherit multilib-minimal python-any-r1
+inherit meson multilib-minimal python-any-r1
DESCRIPTION="Handler library for evdev events"
HOMEPAGE="https://www.freedesktop.org/wiki/Software/libevdev/ https://gitlab.freedesktop.org/libevdev/libevdev"
if [[ ${PV} == 9999* ]] ; then
EGIT_REPO_URI="https://gitlab.freedesktop.org/libevdev/libevdev.git"
- inherit autotools git-r3
+ inherit git-r3
else
SRC_URI="https://www.freedesktop.org/software/libevdev/${P}.tar.xz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
@@ -20,28 +20,38 @@ fi
LICENSE="MIT"
SLOT="0"
-IUSE="doc static-libs"
+IUSE="doc test"
+DEPEND="test? ( dev-libs/check[${MULTILIB_USEDEP}] )"
BDEPEND="
${PYTHON_DEPS}
doc? ( app-doc/doxygen )
- virtual/pkgconfig
+ virtual/pkgconfig[${MULTILIB_USEDEP}]
"
-RESTRICT="test" # Tests need to run as root.
+RESTRICT="!test? ( test )"
-src_prepare() {
- default
- [[ ${PV} == 9999* ]] && eautoreconf
+multilib_src_configure() {
+ local emesonargs=(
+ $(meson_feature doc documentation)
+ $(meson_feature test tests)
+ )
+ meson_src_configure
}
-multilib_src_configure() {
- ECONF_SOURCE="${S}" econf $(use_enable static-libs static)
+multilib_src_compile() {
+ meson_src_compile
+}
+
+multilib_src_test() {
+ meson_src_test
}
multilib_src_install() {
- default
- find "${D}" -name '*.la' -delete || die
- if use doc ;then
+ meson_src_install
+}
+
+multilib_src_install_all() {
+ if use doc; then
local HTML_DOCS=( doc/html/. )
einstalldocs
fi