summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/liborcus/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/liborcus/files')
-rw-r--r--dev-libs/liborcus/files/liborcus-0.5.1-linking.patch13
-rw-r--r--dev-libs/liborcus/files/liborcus-0.5.1-mdds.patch12
-rw-r--r--dev-libs/liborcus/files/liborcus-0.5.1-oldnamespace.patch11
-rw-r--r--dev-libs/liborcus/files/liborcus-0.7.0-boost-1.56.patch25
4 files changed, 61 insertions, 0 deletions
diff --git a/dev-libs/liborcus/files/liborcus-0.5.1-linking.patch b/dev-libs/liborcus/files/liborcus-0.5.1-linking.patch
new file mode 100644
index 000000000000..f9cb64d9b7a8
--- /dev/null
+++ b/dev-libs/liborcus/files/liborcus-0.5.1-linking.patch
@@ -0,0 +1,13 @@
+diff -urN liborcus-0.5.1/src/parser/Makefile.am liborcus-0.5.1.new/src/parser/Makefile.am
+--- liborcus-0.5.1/src/parser/Makefile.am 2013-04-12 16:25:03.000000000 +0200
++++ liborcus-0.5.1.new/src/parser/Makefile.am 2013-04-23 19:45:47.794480191 +0200
+@@ -20,7 +20,8 @@
+
+ liborcus_parser_@ORCUS_API_VERSION@_la_LDFLAGS = -no-undefined
+ liborcus_parser_@ORCUS_API_VERSION@_la_LIBADD = \
+- $(ZLIB_LIBS)
++ $(BOOST_SYSTEM_LIB) \
++ $(ZLIB_LIBS)
+
+ EXTRA_PROGRAMS = \
+ parser-test-string-pool \
diff --git a/dev-libs/liborcus/files/liborcus-0.5.1-mdds.patch b/dev-libs/liborcus/files/liborcus-0.5.1-mdds.patch
new file mode 100644
index 000000000000..740376b36be1
--- /dev/null
+++ b/dev-libs/liborcus/files/liborcus-0.5.1-mdds.patch
@@ -0,0 +1,12 @@
+diff -urN liborcus-0.5.1.old/src/spreadsheet/sheet.cpp liborcus-0.5.1/src/spreadsheet/sheet.cpp
+--- liborcus-0.5.1.old/src/spreadsheet/sheet.cpp 2013-05-27 19:07:41.712302036 +0200
++++ liborcus-0.5.1/src/spreadsheet/sheet.cpp 2013-05-27 19:08:51.432302028 +0200
+@@ -734,7 +734,7 @@
+ con.build_tree();
+
+ size_t index;
+- if (!con.search_tree(col, index))
++ if (!con.search_tree(col, index).second)
+ return 0;
+
+ return index;
diff --git a/dev-libs/liborcus/files/liborcus-0.5.1-oldnamespace.patch b/dev-libs/liborcus/files/liborcus-0.5.1-oldnamespace.patch
new file mode 100644
index 000000000000..c8a669ecaf25
--- /dev/null
+++ b/dev-libs/liborcus/files/liborcus-0.5.1-oldnamespace.patch
@@ -0,0 +1,11 @@
+diff -urN liborcus-0.5.1.old/src/orcus_xml_main.cpp liborcus-0.5.1/src/orcus_xml_main.cpp
+--- liborcus-0.5.1.old/src/orcus_xml_main.cpp 2013-05-27 19:07:41.713302036 +0200
++++ liborcus-0.5.1/src/orcus_xml_main.cpp 2013-05-27 20:01:44.007301649 +0200
+@@ -36,6 +36,7 @@
+
+ #include <cstdlib>
+ #include <cstring>
++#include <iostream>
+ #include <fstream>
+
+ using namespace orcus;
diff --git a/dev-libs/liborcus/files/liborcus-0.7.0-boost-1.56.patch b/dev-libs/liborcus/files/liborcus-0.7.0-boost-1.56.patch
new file mode 100644
index 000000000000..f72d66be11af
--- /dev/null
+++ b/dev-libs/liborcus/files/liborcus-0.7.0-boost-1.56.patch
@@ -0,0 +1,25 @@
+From c01874c7770f4f56c031d7463156e03f2945e015 Mon Sep 17 00:00:00 2001
+From: Dmitry Roshchin <dmitry@roshchin.org>
+Date: Mon, 27 Oct 2014 16:19:32 +0300
+Subject: [PATCH] Fix build with boost 1.56
+
+---
+ src/parser/string_pool_test.cpp | 2 ++
+ 1 files changed, 2 insertions(+), 0 deletions(-)
+
+diff --git a/src/parser/string_pool_test.cpp b/src/parser/string_pool_test.cpp
+index ad7d7c8..0d32c62 100644
+--- a/src/parser/string_pool_test.cpp
++++ b/src/parser/string_pool_test.cpp
+@@ -5,6 +5,8 @@
+ * file, You can obtain one at http://mozilla.org/MPL/2.0/.
+ */
+
++#include <iostream>
++
+ #include "orcus/string_pool.hpp"
+ #include "orcus/pstring.hpp"
+
+--
+1.7.1
+