summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/libotf
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/libotf')
-rw-r--r--dev-libs/libotf/Manifest1
-rw-r--r--dev-libs/libotf/files/libotf-0.9.13-build.patch22
-rw-r--r--dev-libs/libotf/libotf-0.9.13.ebuild45
-rw-r--r--dev-libs/libotf/metadata.xml6
4 files changed, 74 insertions, 0 deletions
diff --git a/dev-libs/libotf/Manifest b/dev-libs/libotf/Manifest
new file mode 100644
index 000000000000..c3567814332b
--- /dev/null
+++ b/dev-libs/libotf/Manifest
@@ -0,0 +1 @@
+DIST libotf-0.9.13.tar.gz 388832 SHA256 7bc466ba50425f95b52de12b4ad35320acefcef13ce67bf33edc14abdcfe6908 SHA512 86ddf071df371ee44910afc02432352356bfa1c2a55b44274c95fc4e7ec4fca982a7fcde35aaa63a8cb332e98388a9faf9a94fbf0f39e85668630f77d841ef31 WHIRLPOOL efdfb7b90b3710a81a070b2b07c2af6b622cbd093d66ddf3beeeff1a4a7c26d5ad1372cd8a65b13913e5d2531aafb1b54becf3cb3db06a7437f1879a945a455a
diff --git a/dev-libs/libotf/files/libotf-0.9.13-build.patch b/dev-libs/libotf/files/libotf-0.9.13-build.patch
new file mode 100644
index 000000000000..519722f43371
--- /dev/null
+++ b/dev-libs/libotf/files/libotf-0.9.13-build.patch
@@ -0,0 +1,22 @@
+--- example/Makefile.am
++++ example/Makefile.am
+@@ -37,8 +37,7 @@
+ otfdump_LDADD = ${CommonLDADD}
+
+ otfview_SOURCE = otfview.c
+-otfview_LDADD = ${CommonLDADD}
+-otfview_LDFLAGS = ${X_LIBS} ${X_PRE_LIBS} @X11_XT_XAW_XMU@ ${X_EXTRA_LIBS}
++otfview_LDADD = ${CommonLDADD} ${X_LIBS} ${X_PRE_LIBS} @X11_XT_XAW_XMU@ ${X_EXTRA_LIBS}
+
+ otftobdf_SOURCE = otftobdf.c
+ otftobdf_LDADD = ${CommonLDADD}
+--- libotf.pc.in
++++ libotf.pc.in
+@@ -7,5 +7,6 @@
+ Description: OpenType font library
+ Version: @PACKAGE_VERSION@
+ Requires: freetype2
+-Libs: @FREETYPE_LD_FLAGS@ -L${libdir} -lotf
++Libs: -L${libdir} -lotf
++Libs.private: @FREETYPE_LD_FLAGS@
+ Cflags: @FREETYPE_INC@ -I${includedir}
diff --git a/dev-libs/libotf/libotf-0.9.13.ebuild b/dev-libs/libotf/libotf-0.9.13.ebuild
new file mode 100644
index 000000000000..43afa4e71007
--- /dev/null
+++ b/dev-libs/libotf/libotf-0.9.13.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils
+
+DESCRIPTION="Library for handling OpenType fonts (OTF)"
+HOMEPAGE="http://www.nongnu.org/m17n/"
+SRC_URI="mirror://nongnu/m17n/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sh sparc x86 ~amd64-linux ~x86-linux"
+IUSE="static-libs X"
+
+RDEPEND=">=media-libs/freetype-2.4.9
+ X? (
+ x11-libs/libX11
+ x11-libs/libXaw
+ x11-libs/libXt
+ )"
+DEPEND="${RDEPEND}
+ X? (
+ x11-libs/libICE
+ x11-libs/libXmu
+ x11-proto/xproto
+ )"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-build.patch
+ eautoreconf
+}
+
+src_configure() {
+ export ac_cv_header_X11_Xaw_Command_h=$(usex X)
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}
diff --git a/dev-libs/libotf/metadata.xml b/dev-libs/libotf/metadata.xml
new file mode 100644
index 000000000000..cdee2535d93e
--- /dev/null
+++ b/dev-libs/libotf/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>cjk</herd>
+<herd>fonts</herd>
+</pkgmetadata>