summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2016-06-25 19:20:12 -0400
committerAnthony G. Basile <blueness@gentoo.org>2016-06-25 19:20:12 -0400
commit73f32fd505fc7f47508ffbe02d07f08d4ef9e53c (patch)
tree68320fcd907acab166e8b6a62790c4f5f447b1d1 /dev-libs/libp11
parentdev-libs/libmowgli: add libressl support (diff)
downloadgentoo-73f32fd505fc7f47508ffbe02d07f08d4ef9e53c.tar.gz
gentoo-73f32fd505fc7f47508ffbe02d07f08d4ef9e53c.tar.bz2
gentoo-73f32fd505fc7f47508ffbe02d07f08d4ef9e53c.zip
dev-libs/libp11: add libressl support
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-libs/libp11')
-rw-r--r--dev-libs/libp11/libp11-0.2.8-r4.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-libs/libp11/libp11-0.2.8-r4.ebuild b/dev-libs/libp11/libp11-0.2.8-r4.ebuild
new file mode 100644
index 000000000000..7159519f8500
--- /dev/null
+++ b/dev-libs/libp11/libp11-0.2.8-r4.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils autotools
+
+DESCRIPTION="Abstraction layer to simplify PKCS#11 API"
+HOMEPAGE="https://github.com/opensc/libp11/wiki"
+SRC_URI="mirror://sourceforge/opensc/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="libressl doc"
+
+RDEPEND="
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-no-ltdl.patch
+ epatch "${FILESDIR}"/${P}-variable-buffer-size.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --docdir="/usr/share/doc/${PF}" \
+ --htmldir="/usr/share/doc/${PF}/html" \
+ --enable-shared --disable-static \
+ --enable-doc \
+ $(use_enable doc api-doc)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}