summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/libsigsegv
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/libsigsegv')
-rw-r--r--dev-libs/libsigsegv/Manifest1
-rw-r--r--dev-libs/libsigsegv/libsigsegv-2.10.ebuild32
-rw-r--r--dev-libs/libsigsegv/metadata.xml18
3 files changed, 51 insertions, 0 deletions
diff --git a/dev-libs/libsigsegv/Manifest b/dev-libs/libsigsegv/Manifest
new file mode 100644
index 000000000000..fe09d1c8a73f
--- /dev/null
+++ b/dev-libs/libsigsegv/Manifest
@@ -0,0 +1 @@
+DIST libsigsegv-2.10.tar.gz 402279 SHA256 8460a4a3dd4954c3d96d7a4f5dd5bc4d9b76f5754196aa245287553b26d2199a SHA512 9464b3343af5042169f208781ffa9d1f7e5e1ee8654c1e6aca5581157b43eedc5ee504a56eb905c61443273bcfc8da6822ecc6499c5f589570ad0ba02d8d8cc2 WHIRLPOOL 1c222c1d47adeb4fbcd82f4d15df0aa6aeaa1479efa4a1e51ce3595001e437f1355b79e84d47dc63acadbf8917591bae1a8fe68fedab76f72f4b3f52f91d9282
diff --git a/dev-libs/libsigsegv/libsigsegv-2.10.ebuild b/dev-libs/libsigsegv/libsigsegv-2.10.ebuild
new file mode 100644
index 000000000000..761cfb191310
--- /dev/null
+++ b/dev-libs/libsigsegv/libsigsegv-2.10.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+
+DESCRIPTION="library for handling page faults in user mode"
+HOMEPAGE="http://libsigsegv.sourceforge.net/"
+SRC_URI="mirror://gnu/libsigsegv/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 ~s390 ~sh sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+src_configure () {
+ econf --enable-shared || die "Configure phase failed"
+}
+
+src_test () {
+ if [[ ${FEATURES} = *sandbox* ]]
+ then
+ # skip tests as they will fail
+ return 0
+ fi
+ emake check || die "Tests failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog* NEWS PORTING README
+}
diff --git a/dev-libs/libsigsegv/metadata.xml b/dev-libs/libsigsegv/metadata.xml
new file mode 100644
index 000000000000..97a389e9f868
--- /dev/null
+++ b/dev-libs/libsigsegv/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>common-lisp</herd>
+<longdescription>
+This is a library for handling page faults in user mode. A page fault occurs
+when a program tries to access to a region of memory that is currently not
+available. Catching and handling a page fault is a useful technique for
+implementing:
+
+ - pageable virtual memory,
+ - memory-mapped access to persistent databases,
+ - generational garbage collectors,
+ - stack overflow handlers,
+ - distributed shared memory,
+</longdescription>
+</pkgmetadata>
+