summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2018-04-21 14:23:40 +0300
committerMart Raudsepp <leio@gentoo.org>2018-04-21 15:33:02 +0300
commite39d23cb4ddf16005e6dc6417c929219bbb16b85 (patch)
treece8e8f2d6d2fd74924653e466aee985e1de250a8 /dev-libs/libxslt/libxslt-1.1.32.ebuild
parentdev-ada/gprbuild: x86 stable (diff)
downloadgentoo-e39d23cb4ddf16005e6dc6417c929219bbb16b85.tar.gz
gentoo-e39d23cb4ddf16005e6dc6417c929219bbb16b85.tar.bz2
gentoo-e39d23cb4ddf16005e6dc6417c929219bbb16b85.zip
dev-libs/libxslt: bump to 1.1.32
Drop the m4 patch that adds CXXFLAGS with unknown reasons of existing; it shouldn't be necessary as no AC_LANG([C++]) or such is used in configure.ac, so lets try without. simplify-python and python static modules disabling patches are kept for now, just having to adjust for the upstream rename of configure.in to configure.ac xslt-config breakage was fixed upstream in a different way, thus should not need that patch anymore, either. xlocale.h glibc removal was handled differently as well, via AC_CHECK_HEADERS([locale.h xlocale.h]) AC_CHECK_FUNCS([strxfrm_l]) with HAVE_LOCALE_H and HAVE_XLOCALE_H in the installed xsltlocale.h, about which I'm not sure how consumers are supposed to handle it when directly or indirectly including xsltlocale.h (presumably doing their own AC_CHECK_HEADERS call?), but that similar before as well via ifdef XSLT_LOCALE_XLOCALE in 1.1.30. "rm -r .. || die" instead of "rm -rf .." while here and fix unnecessary removal of non-existing non-python examples. There actually is a C example, but not installed (due to requiring ICU), so we'd have to doins it instead with USE=examples, but meh. Due to no -f, python examples have to be removed only if use python. Closes: https://bugs.gentoo.org/632214 Bug: https://bugs.gentoo.org/637310 Package-Manager: Portage-2.3.28, Repoman-2.3.9
Diffstat (limited to 'dev-libs/libxslt/libxslt-1.1.32.ebuild')
-rw-r--r--dev-libs/libxslt/libxslt-1.1.32.ebuild123
1 files changed, 123 insertions, 0 deletions
diff --git a/dev-libs/libxslt/libxslt-1.1.32.ebuild b/dev-libs/libxslt/libxslt-1.1.32.ebuild
new file mode 100644
index 000000000000..81bf7991ed37
--- /dev/null
+++ b/dev-libs/libxslt/libxslt-1.1.32.ebuild
@@ -0,0 +1,123 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="xml"
+
+inherit autotools ltprune python-r1 toolchain-funcs multilib-minimal
+
+DESCRIPTION="XSLT libraries and tools"
+HOMEPAGE="http://www.xmlsoft.org/"
+SRC_URI="ftp://xmlsoft.org/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+IUSE="crypt debug examples python static-libs elibc_Darwin"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+ >=dev-libs/libxml2-2.9.1-r5:2[${MULTILIB_USEDEP}]
+ crypt? ( >=dev-libs/libgcrypt-1.5.3:0=[${MULTILIB_USEDEP}] )
+ python? (
+ ${PYTHON_DEPS}
+ dev-libs/libxml2:2[python,${PYTHON_USEDEP}] )
+"
+DEPEND="${RDEPEND}"
+
+MULTILIB_CHOST_TOOLS=(
+ /usr/bin/xslt-config
+)
+
+MULTILIB_WRAPPED_HEADERS=(
+ /usr/include/libxslt/xsltconfig.h
+)
+
+src_prepare() {
+ default
+
+ DOCS=( AUTHORS ChangeLog FEATURES NEWS README TODO )
+
+ # Simplify python setup
+ # https://bugzilla.gnome.org/show_bug.cgi?id=758095
+ eapply "${FILESDIR}"/${PV}-simplify-python.patch
+ eapply "${FILESDIR}"/${PN}-1.1.28-disable-static-modules.patch
+
+ eautoreconf
+ # If eautoreconf'd with new autoconf, then epunt_cxx is not necessary
+ # and it is propably otherwise too if upstream generated with new
+ # autoconf
+# epunt_cxx
+ # But Prefix always needs elibtoolize if not eautoreconf'd.
+# elibtoolize
+}
+
+multilib_src_configure() {
+ libxslt_configure() {
+ ECONF_SOURCE="${S}" econf \
+ --with-html-dir="${EPREFIX}"/usr/share/doc/${PF} \
+ --with-html-subdir=html \
+ $(use_with crypt crypto) \
+ $(use_with debug) \
+ $(use_with debug mem-debug) \
+ $(use_enable static-libs static) \
+ "$@"
+ }
+
+ libxslt_py_configure() {
+ mkdir -p "${BUILD_DIR}" || die # ensure python build dirs exist
+ run_in_build_dir libxslt_configure --with-python
+ }
+
+ libxslt_configure --without-python # build python bindings separately
+
+ if multilib_is_native_abi && use python; then
+ python_foreach_impl libxslt_py_configure
+ fi
+}
+
+multilib_src_compile() {
+ default
+ multilib_is_native_abi && use python && libxslt_foreach_py_emake all
+}
+
+multilib_src_test() {
+ default
+ multilib_is_native_abi && use python && libxslt_foreach_py_emake test
+}
+
+multilib_src_install() {
+ # "default" does not work here - docs are installed by multilib_src_install_all
+ emake DESTDIR="${D}" install
+
+ if multilib_is_native_abi && use python; then
+ libxslt_foreach_py_emake \
+ DESTDIR="${D}" \
+ docsdir="${EPREFIX}"/usr/share/doc/${PF}/python \
+ EXAMPLE_DIR="${EPREFIX}"/usr/share/doc/${PF}/python/examples \
+ install
+ python_foreach_impl python_optimize
+ fi
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ if ! use examples && use python; then
+ rm -r "${ED}"/usr/share/doc/${PF}/python/examples || die
+ fi
+
+ prune_libtool_files --modules
+}
+
+libxslt_foreach_py_emake() {
+ libxslt_py_emake() {
+ pushd "${BUILD_DIR}/python" > /dev/null || die
+ emake "$@"
+ popd > /dev/null
+ }
+ local native_builddir=${BUILD_DIR}
+ python_foreach_impl libxslt_py_emake top_builddir="${native_builddir}" "$@"
+}