summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/mapm
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/mapm')
-rw-r--r--dev-libs/mapm/Manifest1
-rw-r--r--dev-libs/mapm/files/4.9.5-missing_include.patch12
-rw-r--r--dev-libs/mapm/mapm-4.9.5.ebuild46
-rw-r--r--dev-libs/mapm/metadata.xml7
4 files changed, 66 insertions, 0 deletions
diff --git a/dev-libs/mapm/Manifest b/dev-libs/mapm/Manifest
new file mode 100644
index 000000000000..08a7b26a9d6b
--- /dev/null
+++ b/dev-libs/mapm/Manifest
@@ -0,0 +1 @@
+DIST mapm-4.9.5.tar.gz 162943 SHA256 5ee2bb31a3006d0d94d19ebebd618e0a738f7ab5fcb17f2eb31cc2b8f0d9dac9 SHA512 1d0b489395fdfcb0c23ce2d242c63de739c45e33827411c976f6e7c48b18fc2afe599270139f40108b1f30573134d9d5950f3316613a45f567f53cfd59f4dc3e WHIRLPOOL c93ab67e9e7796280702179ee7409e7dc05405637522d5884b3fb646f513361fdb327e698369bfa53d01c00ea23e740f4bfed1b2665650a48af7415b05f720cd
diff --git a/dev-libs/mapm/files/4.9.5-missing_include.patch b/dev-libs/mapm/files/4.9.5-missing_include.patch
new file mode 100644
index 000000000000..e03b122ea0dc
--- /dev/null
+++ b/dev-libs/mapm/files/4.9.5-missing_include.patch
@@ -0,0 +1,12 @@
+diff -Naur mapm_4.9.5.orig/m_apm.h mapm_4.9.5/m_apm.h
+--- mapm_4.9.5.orig/m_apm.h 2009-03-02 11:55:18.914770612 +0100
++++ mapm_4.9.5/m_apm.h 2009-03-02 11:56:19.585923499 +0100
+@@ -159,6 +159,8 @@
+ #ifndef M__APM__INCLUDED
+ #define M__APM__INCLUDED
+
++#include <stdlib.h>
++
+ #ifdef __cplusplus
+ /* Comment this line out if you've compiled the library as C++. */
+ #define APM_CONVERT_FROM_C
diff --git a/dev-libs/mapm/mapm-4.9.5.ebuild b/dev-libs/mapm/mapm-4.9.5.ebuild
new file mode 100644
index 000000000000..08e03db8a321
--- /dev/null
+++ b/dev-libs/mapm/mapm-4.9.5.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="Mike's Arbitrary Precision Math Library"
+HOMEPAGE="http://www.tc.umn.edu/~ringx004/mapm-main.html"
+SRC_URI="http://www.tc.umn.edu/~ringx004/${P}.tar.gz"
+
+LICENSE="mapm-4.9.5"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~sparc x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/${PN}_${PV}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PV}-missing_include.patch"
+}
+
+src_compile() {
+ $(tc-getCC) -c -Wall ${CFLAGS} -fPIC map*.c || die "compiling sources failed"
+ $(tc-getCC) -shared ${LDFLAGS} -Wl,--soname=libmapm.so -o libmapm.so.0 map*.o || die "linking sources failed"
+}
+
+src_install() {
+ dolib.so libmapm.so.0
+# dosym libmapm.so.0 /usr/$(get_libdir)/libmapm.so
+
+ insinto /usr/include
+ doins m_apm.h
+
+ insinto /usr/share/doc/${PF}/examples
+ doins calc.c validate.c primenum.c cpp_demo.cpp
+
+ cd DOCS
+ dodoc README article.pdf algorithms.used commentary.txt \
+ cpp_function.ref function.ref history.txt struct.ref
+
+}
diff --git a/dev-libs/mapm/metadata.xml b/dev-libs/mapm/metadata.xml
new file mode 100644
index 000000000000..ff62877c67ae
--- /dev/null
+++ b/dev-libs/mapm/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+</maintainer>
+</pkgmetadata>