summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/qcodeedit
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/qcodeedit')
-rw-r--r--dev-libs/qcodeedit/Manifest1
-rw-r--r--dev-libs/qcodeedit/metadata.xml10
-rw-r--r--dev-libs/qcodeedit/qcodeedit-2.2.3.ebuild31
3 files changed, 42 insertions, 0 deletions
diff --git a/dev-libs/qcodeedit/Manifest b/dev-libs/qcodeedit/Manifest
new file mode 100644
index 000000000000..615aee280d25
--- /dev/null
+++ b/dev-libs/qcodeedit/Manifest
@@ -0,0 +1 @@
+DIST qcodeedit-2.2.3.zip 381305 SHA256 39a8109efb3d9814d9827f08b524fc8e7d475af3a2466ccf6e08b2236c1dc46e SHA512 39618bf130127d2824a38de77448d02a1d07cc2d4861d3381a7c2c6107fc2816b0e030c6b6725e8f4782a0967c67a07767e9eb625aee6fce5dfbca10d850ebaa WHIRLPOOL 988f45e14ff3161c11336e150e419ef7bb0b3b5914c1f545ac41245a26c6c0075b26ef136b245bf530d4919dd9bb72cd069b69c48981aa44eaae354bf8b20bf3
diff --git a/dev-libs/qcodeedit/metadata.xml b/dev-libs/qcodeedit/metadata.xml
new file mode 100644
index 000000000000..462299addaf8
--- /dev/null
+++ b/dev-libs/qcodeedit/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">edyuk</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-libs/qcodeedit/qcodeedit-2.2.3.ebuild b/dev-libs/qcodeedit/qcodeedit-2.2.3.ebuild
new file mode 100644
index 000000000000..f32dd65841e5
--- /dev/null
+++ b/dev-libs/qcodeedit/qcodeedit-2.2.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit qt4-r2
+
+DESCRIPTION="Qt-Framework for code editing"
+HOMEPAGE="http://edyuk.sourceforge.net/"
+SRC_URI="mirror://sourceforge/project/edyuk/${PN}/${PV}/${P}.zip"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ dev-qt/qtgui:4
+ dev-qt/qtcore:4
+ dev-qt/qtxmlpatterns:4
+"
+DEPEND="${RDEPEND}
+"
+
+MAKEOPTS+=" -j1"
+
+src_install() {
+ qt4-r2_src_install
+ dolib.so libqcodeedit.so*
+}