summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/starpu
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/starpu')
-rw-r--r--dev-libs/starpu/Manifest2
-rw-r--r--dev-libs/starpu/metadata.xml22
-rw-r--r--dev-libs/starpu/starpu-1.1.2.ebuild84
-rw-r--r--dev-libs/starpu/starpu-1.1.4.ebuild84
4 files changed, 192 insertions, 0 deletions
diff --git a/dev-libs/starpu/Manifest b/dev-libs/starpu/Manifest
new file mode 100644
index 000000000000..94acbe2649b3
--- /dev/null
+++ b/dev-libs/starpu/Manifest
@@ -0,0 +1,2 @@
+DIST starpu-1.1.2.tar.gz 4704168 SHA256 971e324a936ab5a572202d3356a1e783e6fcca8d068ab2814209f737fcf03dfa SHA512 8601fe1564e86f731211993d2aa851898e20b4ce110943dd5037824b2d538aca5cd2fe8bc868805c1e48c20d47e15bc1db8c22be60113d2aabf191882a7039f8 WHIRLPOOL fc572857269339b68120286b829f259f565ef19947ac017dd61e3d3b663f555dc918139f5a3a88f2a17be6df088a05ae9261d08dbf6f966948a3663dc33667c0
+DIST starpu-1.1.4.tar.gz 5022944 SHA256 ba36e605bd3915afb5b8ac6582b33ebd2ca65139b879d928e6b218f6d2e4b37e SHA512 a448839e33675b17cdef389dbf91e85b7ef9cafcf93ce0c99f755bf8eb548ecb3240b97602b2f3c9799128c651e889446ae3013e62f391c05b279ae38fb041d6 WHIRLPOOL acb58667379ec67635af853b41881479fcdfbda1b6ba27b353aac57bdeed0cbc2cb5a6b923f003b222d0ef685778fa3445003ed4f34606e6eb41d1d45dcc0c21
diff --git a/dev-libs/starpu/metadata.xml b/dev-libs/starpu/metadata.xml
new file mode 100644
index 000000000000..362d9440a0a6
--- /dev/null
+++ b/dev-libs/starpu/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>bicatali@gentoo.org</email>
+ <description>Feel free to update and/or fix</description>
+</maintainer>
+<longdescription lang='en'>
+ StarPU is a runtime system that offers support for heterogeneous
+ multicore machines. While many efforts are devoted to design efficient
+ computation kernels for those architectures (e.g. to implement BLAS
+ kernels on GPUs or on Cell's SPUs), StarPU not only takes care of
+ offloading such kernels (and implementing data coherency across
+ the machine), but it also makes sure the kernels are executed as
+ efficiently as possible.
+</longdescription>
+<use>
+ <flag name="cuda">Enable NVIDIA CUDA toolkit support</flag>
+ <flag name="gcc-plugin">Enable GCC extension plugin (experimental)</flag>
+ <flag name="opencl">Enable OpenCL support</flag>
+</use>
+</pkgmetadata>
diff --git a/dev-libs/starpu/starpu-1.1.2.ebuild b/dev-libs/starpu/starpu-1.1.2.ebuild
new file mode 100644
index 000000000000..6293be00a4d5
--- /dev/null
+++ b/dev-libs/starpu/starpu-1.1.2.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=1
+inherit autotools-utils toolchain-funcs cuda
+
+DESCRIPTION="Unified runtime system for heterogeneous multicore architectures"
+HOMEPAGE="http://runtime.bordeaux.inria.fr/StarPU/"
+SRC_URI="${HOMEPAGE}/files/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+IUSE="blas cuda debug doc examples fftw gcc-plugin mpi opencl opengl qt4
+ static-libs test"
+
+RDEPEND="
+ sys-apps/hwloc:0=
+ sci-mathematics/glpk:0=
+ blas? ( virtual/blas )
+ cuda? ( dev-util/nvidia-cuda-toolkit
+ x11-drivers/nvidia-drivers
+ blas? ( sci-libs/magma ) )
+ fftw? ( sci-libs/fftw:3.0= )
+ mpi? ( virtual/mpi )
+ opencl? ( virtual/opencl )
+ opengl? ( media-libs/freeglut:0= )
+ qt4? ( >=dev-qt/qtgui-4.7:4
+ >=dev-qt/qtopengl-4.7:4
+ >=dev-qt/qtsql-4.7:4
+ x11-libs/qwt )"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen virtual/latex-base )
+ test? ( gcc-plugin? ( dev-scheme/guile ) )"
+
+src_prepare() {
+ # upstream did not want the patches so apply sed's
+ sed -i -e 's/-O3 $CFLAGS/$CFLAGS/' configure.ac || die
+ sed -i -e '/Libs.private/s/@LDFLAGS@//g' *.pc.in */*.pc.in || die
+ autotools-utils_src_prepare
+ use cuda && cuda_src_prepare
+}
+
+src_configure() {
+ use blas && export BLAS_LIBS="$($(tc-getPKG_CONFIG) --libs blas)"
+
+ local myeconfargs=(
+ --disable-build-examples
+ $(use_enable cuda)
+ $(use_enable debug)
+ $(use_enable doc build-doc)
+ $(use_enable fftw starpufft)
+ $(use_enable gcc-plugin gcc-extensions)
+ $(use_enable opencl)
+ $(use_enable opengl opengl-render)
+ $(use_enable qt4 starpu-top)
+ $(use_with mpi mpicc "$(type -P mpicc)")
+ $(use cuda && use_enable blas magma)
+ $(use mpi && use_enable test mpi-check)
+ )
+ autotools-utils_src_configure
+}
+
+src_test() {
+ autotools-utils_src_test -j1 showcheck
+}
+
+src_install() {
+ autotools-utils_src_install
+ if use doc; then
+ dodoc "${BUILD_DIR}"/doc/doxygen/*.pdf
+ dohtml -r "${BUILD_DIR}"/doc/doxygen/html/*
+ fi
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins -r examples/*
+ fi
+}
diff --git a/dev-libs/starpu/starpu-1.1.4.ebuild b/dev-libs/starpu/starpu-1.1.4.ebuild
new file mode 100644
index 000000000000..94a9c8a8bc10
--- /dev/null
+++ b/dev-libs/starpu/starpu-1.1.4.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=1
+inherit autotools-utils toolchain-funcs cuda
+
+DESCRIPTION="Unified runtime system for heterogeneous multicore architectures"
+HOMEPAGE="http://runtime.bordeaux.inria.fr/StarPU/"
+SRC_URI="${HOMEPAGE}/files/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+IUSE="blas cuda debug doc examples fftw gcc-plugin mpi opencl opengl qt4
+ static-libs test"
+
+RDEPEND="
+ sys-apps/hwloc:0=
+ sci-mathematics/glpk:0=
+ blas? ( virtual/blas )
+ cuda? ( dev-util/nvidia-cuda-toolkit
+ x11-drivers/nvidia-drivers
+ blas? ( sci-libs/magma ) )
+ fftw? ( sci-libs/fftw:3.0= )
+ mpi? ( virtual/mpi )
+ opencl? ( virtual/opencl )
+ opengl? ( media-libs/freeglut:0= )
+ qt4? ( >=dev-qt/qtgui-4.7:4
+ >=dev-qt/qtopengl-4.7:4
+ >=dev-qt/qtsql-4.7:4
+ x11-libs/qwt )"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen virtual/latex-base )
+ test? ( gcc-plugin? ( dev-scheme/guile ) )"
+
+src_prepare() {
+ # upstream did not want the patches so apply sed's
+ sed -i -e 's/-O3 $CFLAGS/$CFLAGS/' configure.ac || die
+ sed -i -e '/Libs.private/s/@LDFLAGS@//g' *.pc.in */*.pc.in || die
+ autotools-utils_src_prepare
+ use cuda && cuda_src_prepare
+}
+
+src_configure() {
+ use blas && export BLAS_LIBS="$($(tc-getPKG_CONFIG) --libs blas)"
+
+ local myeconfargs=(
+ --disable-build-examples
+ $(use_enable cuda)
+ $(use_enable debug)
+ $(use_enable doc build-doc)
+ $(use_enable fftw starpufft)
+ $(use_enable gcc-plugin gcc-extensions)
+ $(use_enable opencl)
+ $(use_enable opengl opengl-render)
+ $(use_enable qt4 starpu-top)
+ $(use_with mpi mpicc "$(type -P mpicc)")
+ $(use cuda && use_enable blas magma)
+ $(use mpi && use_enable test mpi-check)
+ )
+ autotools-utils_src_configure
+}
+
+src_test() {
+ autotools-utils_src_test -j1 showcheck
+}
+
+src_install() {
+ autotools-utils_src_install
+ if use doc; then
+ dodoc "${BUILD_DIR}"/doc/doxygen/*.pdf
+ dohtml -r "${BUILD_DIR}"/doc/doxygen/html/*
+ fi
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins -r examples/*
+ fi
+}