summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/tvision
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/tvision')
-rw-r--r--dev-libs/tvision/Manifest1
-rw-r--r--dev-libs/tvision/files/tvision-2.1.0_pre2-asneeded.patch45
-rw-r--r--dev-libs/tvision/files/tvision-2.1.0_pre2-flags.patch11
-rw-r--r--dev-libs/tvision/files/tvision-2.1.0_pre2-gcc41.patch11
-rw-r--r--dev-libs/tvision/files/tvision-2.1.0_pre2-gcc44.patch21
-rw-r--r--dev-libs/tvision/files/tvision-2.1.0_pre2-ldconfig.patch15
-rw-r--r--dev-libs/tvision/files/tvision-2.1.0_pre2-outb.patch41
-rw-r--r--dev-libs/tvision/files/tvision-2.1.0_pre2-underflow.patch14
-rw-r--r--dev-libs/tvision/metadata.xml10
-rw-r--r--dev-libs/tvision/tvision-2.1.0_pre2-r3.ebuild43
10 files changed, 212 insertions, 0 deletions
diff --git a/dev-libs/tvision/Manifest b/dev-libs/tvision/Manifest
new file mode 100644
index 000000000000..e976d4ba28ae
--- /dev/null
+++ b/dev-libs/tvision/Manifest
@@ -0,0 +1 @@
+DIST rhtvision_2.1.0-2.tar.gz 1590449 SHA256 fef19d839069dea2cd5459f24a190883a3b2b600a60d6f7823f456d8e6889412 SHA512 0593cd2eee9490d5cd6e79a6b8f4c0b384f78e5bb24b0728876fb9df482a43ee97c141d89127254210b4e012970327adfc5c8815d7c3c580a6d54a09291d42a1 WHIRLPOOL 5ce2e0bd7eb161aaef520a3bfafde7146784ac5a9d528ce73a51f502b23d790f42caeee5028508a8902615dfa31e295a988daef341f3fa3f6bb1c360b4b90d2b
diff --git a/dev-libs/tvision/files/tvision-2.1.0_pre2-asneeded.patch b/dev-libs/tvision/files/tvision-2.1.0_pre2-asneeded.patch
new file mode 100644
index 000000000000..314ab225f051
--- /dev/null
+++ b/dev-libs/tvision/files/tvision-2.1.0_pre2-asneeded.patch
@@ -0,0 +1,45 @@
+--- tvision/config.pl
++++ tvision/config.pl
+@@ -206,6 +206,7 @@
+ }
+ # Flags to link as a dynamic lib
+ $MakeDefsRHIDE[6]='RHIDE_LDFLAGS=';
++$MakeDefsRHIDE[7]='RHIDE_LIBS=';
+ if ($OS eq 'UNIX')
+ {
+ if ($OSf ne 'Darwin')
+@@ -229,15 +230,15 @@
+ }
+ $libs=$conf{'X11Lib'};
+ $libs=~s/(\S+)/-l$1/g;
+- $MakeDefsRHIDE[6].=" -L".$conf{'X11LibPath'}." $libs" if @conf{'HAVE_X11'} eq 'yes';
++ $MakeDefsRHIDE[7].=" -L".$conf{'X11LibPath'}." $libs" if @conf{'HAVE_X11'} eq 'yes';
+- $MakeDefsRHIDE[6].=' -lgpm' if @conf{'HAVE_GPM'} eq 'yes';
++ $MakeDefsRHIDE[7].=' -lgpm' if @conf{'HAVE_GPM'} eq 'yes';
+- $MakeDefsRHIDE[6].=(($OSf eq 'QNXRtP') ? ' -lncursesS' : ' -lncurses') unless $conf{'ncurses'} eq 'no';
++ $MakeDefsRHIDE[7].=(($OSf eq 'QNXRtP') ? ' -lncursesS' : ' -lncurses') unless $conf{'ncurses'} eq 'no';
+- $MakeDefsRHIDE[6].=" $stdcxx -lm -lc";
++ $MakeDefsRHIDE[7].=" $stdcxx -lm -lc";
+- $MakeDefsRHIDE[6].=' -lpthread' if $conf{'HAVE_LINUX_PTHREAD'} eq 'yes';
++ $MakeDefsRHIDE[7].=' -lpthread' if $conf{'HAVE_LINUX_PTHREAD'} eq 'yes';
+- $MakeDefsRHIDE[6].=' libtvfintl.a' if ($OSf eq 'Darwin') && $UseDummyIntl;
++ $MakeDefsRHIDE[7].=' libtvfintl.a' if ($OSf eq 'Darwin') && $UseDummyIntl;
+ }
+-$MakeDefsRHIDE[7]="LIB_VER=$Version";
++$MakeDefsRHIDE[8]="LIB_VER=$Version";
+-$MakeDefsRHIDE[8]="LIB_VER_MAJOR=$VersionMajor";
++$MakeDefsRHIDE[9]="LIB_VER_MAJOR=$VersionMajor";
+
+ ModifyMakefiles('intl/dummy/Makefile');
+ CreateRHIDEenvs('examples/rhide.env','makes/rhide.env','compat/rhide.env');
+--- tvision/makes/common.imk
++++ tvision/makes/common.imk
+@@ -54,7 +54,7 @@
+ C_EXTRA_FLAGS=$(SHARED_CODE_OPTION)
+ RHIDE_COMPILE_ARCHIVE=$(RHIDE_LD) $(RHIDE_LIBDIRS) $(LDFLAGS) \
+ $(RHIDE_LDFLAGS) $(C_EXTRA_FLAGS) -o $(OUTFILE) \
+- $(OBJFILES)
++ $(OBJFILES) $(addprefix -l,$(RHIDE_OS_LIBS))
+ else
+ RHIDE_COMPILE_ARCHIVE=$(RHIDE_AR) $(RHIDE_ARFLAGS) $(OUTFILE)\
+ $(ALL_PREREQ)
diff --git a/dev-libs/tvision/files/tvision-2.1.0_pre2-flags.patch b/dev-libs/tvision/files/tvision-2.1.0_pre2-flags.patch
new file mode 100644
index 000000000000..e74b09ee57d0
--- /dev/null
+++ b/dev-libs/tvision/files/tvision-2.1.0_pre2-flags.patch
@@ -0,0 +1,11 @@
+--- tvision/Makefile.in
++++ tvision/Makefile.in
+@@ -31,7 +31,7 @@ examples:
+ $(MAKE) -C examples
+
+ rhtv-config$(EXE_EXT): rhtv-config.c include/tv/configtv.h
+- @GCC@ -o rhtv-config$(EXE_EXT) -Iinclude rhtv-config.c
++ @GCC@ -o rhtv-config$(EXE_EXT) $(CFLAGS) $(LDFLAGS) -Iinclude rhtv-config.c
+
+ install-headers:
+ @install_headers@
diff --git a/dev-libs/tvision/files/tvision-2.1.0_pre2-gcc41.patch b/dev-libs/tvision/files/tvision-2.1.0_pre2-gcc41.patch
new file mode 100644
index 000000000000..36246b214f99
--- /dev/null
+++ b/dev-libs/tvision/files/tvision-2.1.0_pre2-gcc41.patch
@@ -0,0 +1,11 @@
+--- tvision/include/tv/inputln.h
++++ tvision/include/tv/inputln.h
+@@ -201,7 +201,7 @@
+ { return name; }
+
+ protected:
+- TInputLine::TInputLine(StreamableInit) :
++ TInputLine(StreamableInit) :
+ TInputLineBaseT<char,TDrawBuffer>(streamableInit) {}
+
+ public:
diff --git a/dev-libs/tvision/files/tvision-2.1.0_pre2-gcc44.patch b/dev-libs/tvision/files/tvision-2.1.0_pre2-gcc44.patch
new file mode 100644
index 000000000000..40911f3a3e29
--- /dev/null
+++ b/dev-libs/tvision/files/tvision-2.1.0_pre2-gcc44.patch
@@ -0,0 +1,21 @@
+--- tvision/classes/ipstream.cc
++++ tvision/classes/ipstream.cc
+@@ -19,6 +19,7 @@
+ *
+ */
+ #include <assert.h>
++#include <stdio.h>
+ #define Uses_string
+ #define Uses_TStreamable
+ #define Uses_TStreamableClass
+--- tvision/include/tv/textdev.h
++++ tvision/include/tv/textdev.h
+@@ -16,6 +16,8 @@
+ #if defined( Uses_TTextDevice ) && !defined( __TTextDevice )
+ #define __TTextDevice
+
++#include <stdio.h>
++
+ class TRect;
+ class TScrollBar;
+
diff --git a/dev-libs/tvision/files/tvision-2.1.0_pre2-ldconfig.patch b/dev-libs/tvision/files/tvision-2.1.0_pre2-ldconfig.patch
new file mode 100644
index 000000000000..6d7d94fe8a0d
--- /dev/null
+++ b/dev-libs/tvision/files/tvision-2.1.0_pre2-ldconfig.patch
@@ -0,0 +1,15 @@
+--- tvision/config.pl
++++ tvision/config.pl
+@@ -1193,12 +1193,6 @@
+ $rep.="\t".GenInstallFiles('0644',"$makeDir/$ver",'$(libdir)');
+ $stripDebug=($OSf eq 'Darwin') ? '-S' : '--strip-debug';
+ $rep.="\tstrip $stripDebug \$(libdir)/$ver\n" unless $conf{'debugInfo'} eq 'yes';
+- # FreeBSD: merge data from libdir.
+- # Darwin: doesn't have ldconfig.
+- if ($OSf ne 'Darwin')
+- {
+- $rep.=($OSf eq 'FreeBSD') ? "\t-ldconfig -m \$(libdir)\n" : "\t-ldconfig\n";
+- }
+ }
+ if ($internac)
+ {
diff --git a/dev-libs/tvision/files/tvision-2.1.0_pre2-outb.patch b/dev-libs/tvision/files/tvision-2.1.0_pre2-outb.patch
new file mode 100644
index 000000000000..0735f8ffeb77
--- /dev/null
+++ b/dev-libs/tvision/files/tvision-2.1.0_pre2-outb.patch
@@ -0,0 +1,41 @@
+Recent kernel headers no longer provide asm/io.h.
+
+--- tvision/classes/linux/linuxdis.cc
++++ tvision/classes/linux/linuxdis.cc
+@@ -300,7 +300,11 @@
+ *****************************************************************************/
+
+ #ifdef h386LowLevel
++#if HAVE_OUTB_IN_SYS
++#include <sys/io.h>
++#else
+ #include <asm/io.h>
++#endif
+
+ static inline
+ unsigned char I(unsigned char i)
+--- tvision/classes/linux/linuxscr.cc
++++ tvision/classes/linux/linuxscr.cc
+@@ -123,7 +123,11 @@
+ #include <tv/linux/log.h>
+
+ #ifdef h386LowLevel
++ #if HAVE_OUTB_IN_SYS
++ #include <sys/io.h>
++ #else
+ #include <asm/io.h>
++ #endif
+ #endif
+
+ // What a hell is that?!
+--- tvision/config.pl
++++ tvision/config.pl
+@@ -77,7 +77,7 @@
+ # glibc I use but the fact is that the needed tricks make it very Linux
+ # dependent.
+ LookForPThread() if $OSf eq 'Linux';
+- #LookForOutB();
++ LookForOutB();
+ }
+ if ($Compf eq 'Cygwin')
+ {# Cygwin incorporates a XFree86 port
diff --git a/dev-libs/tvision/files/tvision-2.1.0_pre2-underflow.patch b/dev-libs/tvision/files/tvision-2.1.0_pre2-underflow.patch
new file mode 100644
index 000000000000..d693a359a6cf
--- /dev/null
+++ b/dev-libs/tvision/files/tvision-2.1.0_pre2-underflow.patch
@@ -0,0 +1,14 @@
+Bug #160591; fixes a buffer underflow.
+Reported by B Douglas Hilton <b.d.hilton@verizon.net>
+
+--- tvision/classes/ttermina.cc
++++ tvision/classes/ttermina.cc
+@@ -233,7 +233,7 @@
+ }
+ }
+ }
+- while (pos-->=queBack);
++ while (pos-->queBack);
+
+ return queBack;
+ }
diff --git a/dev-libs/tvision/metadata.xml b/dev-libs/tvision/metadata.xml
new file mode 100644
index 000000000000..4cde498cb7c8
--- /dev/null
+++ b/dev-libs/tvision/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">tvision</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-libs/tvision/tvision-2.1.0_pre2-r3.ebuild b/dev-libs/tvision/tvision-2.1.0_pre2-r3.ebuild
new file mode 100644
index 000000000000..41b30885424f
--- /dev/null
+++ b/dev-libs/tvision/tvision-2.1.0_pre2-r3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils multilib
+
+DESCRIPTION="Text User Interface that implements the well known CUA widgets"
+HOMEPAGE="http://tvision.sourceforge.net/"
+SRC_URI="mirror://sourceforge/tvision/rhtvision_${PV/_pre/-}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gcc41.patch
+ epatch "${FILESDIR}"/${P}-outb.patch
+ epatch "${FILESDIR}"/${P}-underflow.patch
+ epatch "${FILESDIR}"/${P}-asneeded.patch
+ epatch "${FILESDIR}"/${P}-gcc44.patch
+ epatch "${FILESDIR}"/${P}-ldconfig.patch
+ epatch "${FILESDIR}"/${P}-flags.patch
+}
+
+src_compile() {
+ ./configure \
+ --prefix=/usr \
+ --fhs \
+ || die
+ emake || die
+}
+
+src_install() {
+ einstall libdir="\$(prefix)/$(get_libdir)"|| die
+ dosym rhtvision /usr/include/tvision
+ dodoc readme.txt THANKS TODO
+ dohtml -r www-site
+}