summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2018-04-30 00:06:51 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2018-04-30 00:07:00 +0200
commit0a594acda7bfbae3c55c54c9d0c521f362c2843d (patch)
treef92e1a6a2393600994cc0091e12bbbbbb46a3524 /dev-libs/weston
parentsci-visualization/mayavi: amd64 stable wrt bug #644746 (diff)
downloadgentoo-0a594acda7bfbae3c55c54c9d0c521f362c2843d.tar.gz
gentoo-0a594acda7bfbae3c55c54c9d0c521f362c2843d.tar.bz2
gentoo-0a594acda7bfbae3c55c54c9d0c521f362c2843d.zip
dev-libs/weston: Add build fix for glibc-2.26, bug 610652
Oh well, this one was really easy. Closes: https://bugs.gentoo.org/610652 Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'dev-libs/weston')
-rw-r--r--dev-libs/weston/files/weston-1.11.0-sysmacros.patch11
-rw-r--r--dev-libs/weston/weston-1.11.0.ebuild5
2 files changed, 14 insertions, 2 deletions
diff --git a/dev-libs/weston/files/weston-1.11.0-sysmacros.patch b/dev-libs/weston/files/weston-1.11.0-sysmacros.patch
new file mode 100644
index 000000000000..6f54bfc11cd5
--- /dev/null
+++ b/dev-libs/weston/files/weston-1.11.0-sysmacros.patch
@@ -0,0 +1,11 @@
+diff -ruN weston-1.11.0.orig/src/weston-launch.c weston-1.11.0/src/weston-launch.c
+--- weston-1.11.0.orig/src/weston-launch.c 2015-10-24 02:02:43.000000000 +0200
++++ weston-1.11.0/src/weston-launch.c 2018-04-30 00:02:42.528120347 +0200
+@@ -37,6 +37,7 @@
+ #include <getopt.h>
+
+ #include <sys/types.h>
++#include <sys/sysmacros.h>
+ #include <sys/ioctl.h>
+ #include <sys/stat.h>
+ #include <sys/wait.h>
diff --git a/dev-libs/weston/weston-1.11.0.ebuild b/dev-libs/weston/weston-1.11.0.ebuild
index 9574ec16fc79..81098bc0289f 100644
--- a/dev-libs/weston/weston-1.11.0.ebuild
+++ b/dev-libs/weston/weston-1.11.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -11,7 +11,7 @@ fi
VIRTUALX_REQUIRED="test"
RESTRICT="test"
-inherit autotools readme.gentoo-r1 toolchain-funcs virtualx $GIT_ECLASS
+inherit autotools readme.gentoo-r1 toolchain-funcs virtualx epatch $GIT_ECLASS
DESCRIPTION="Wayland reference compositor"
HOMEPAGE="https://wayland.freedesktop.org/"
@@ -95,6 +95,7 @@ DEPEND="${RDEPEND}
"
src_prepare() {
+ epatch "${FILESDIR}/${P}-sysmacros.patch"
if [[ ${PV} = 9999* ]]; then
eautoreconf
fi