summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2016-03-10 19:19:56 +0100
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2016-03-10 19:19:56 +0100
commit4d6dbd30c3d82aa46e5112f33f4d3b1d926f2035 (patch)
treecf07070dcd979e724c23ca7f3d93259a676a4d64 /dev-libs/weston
parentmedia-gfx/hugin: version bump (diff)
downloadgentoo-4d6dbd30c3d82aa46e5112f33f4d3b1d926f2035.tar.gz
gentoo-4d6dbd30c3d82aa46e5112f33f4d3b1d926f2035.tar.bz2
gentoo-4d6dbd30c3d82aa46e5112f33f4d3b1d926f2035.zip
dev-libs/weston: version bump
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-libs/weston')
-rw-r--r--dev-libs/weston/Manifest1
-rw-r--r--dev-libs/weston/weston-1.10.0.ebuild150
-rw-r--r--dev-libs/weston/weston-9999.ebuild18
3 files changed, 163 insertions, 6 deletions
diff --git a/dev-libs/weston/Manifest b/dev-libs/weston/Manifest
index cf0d59ca6cea..8957ccca87a1 100644
--- a/dev-libs/weston/Manifest
+++ b/dev-libs/weston/Manifest
@@ -1,3 +1,4 @@
+DIST weston-1.10.0.tar.xz 1239280 SHA256 e0b2004d00d8293ddf7903ca283c1746afa9ccb5919ab50fd04397ff472aa5c1 SHA512 0eaa339c5fb18f75526dbd0a172dbcf9c98320e657d4dbd2ce8975d9dfdc780800283f44774b5ded320276918d57e7f7dc6ee08d98605fd5ce07fbc23c9b0937 WHIRLPOOL 2248a6c715010de0545cbef241858afa7044fbca46a11c7c554bb3cfaaa6d8966c2e57ea7162092de5d9773fb0c0c0bb038472b3b8a0d860472a1f35b88a31c6
DIST weston-1.6.1.tar.xz 734968 SHA256 e9ef779fda4008b7081ee6c64df7971c50954c5cf0d166d8a2fcb104ec1042fd SHA512 837c632d47dc496d7daf488e9887e6ff3d6baf9d954c3a283640722f068165955c22677c26abb9f8c0142352084d6a22054edf0963deb9a62b0f7e84e1c0e6cf WHIRLPOOL 6dc60bb64841fb77af30aca532ad069a169ebdababeaa3a14b3974ff3b32e04159157b0c270f333fcc5ac97c5061a44fb1387be358bcf1ded45f6dc55f366445
DIST weston-1.7.0.tar.xz 1286904 SHA256 1c4511945f3f476c24af712e82a7b500ae91a99cbc0fe2e381da1449125166cd SHA512 2ba9c7cfd2a18354af8996bf8d78bbccd12bff1ee99102d5057758cdc54311632f7e7583ffcb075efb75e702a8fa210ea0c4f0f8bb8b18e9df39a9db77d03d19 WHIRLPOOL 48ee5e4b8676cc84fbeef019034b9961fe1be51f31af11d3df24ba1d5d446133b747ac1494ef080647d8b845492125fbb453a037d0b552b43a5167bbba8c36aa
DIST weston-1.8.0.tar.xz 1317032 SHA256 8963e69f328e815cec42c58046c4af721476c7541bb7d9edc71740fada5ad312 SHA512 3ad527259d17f67f48796be6c378a8958dffbe8668d1e7079253c2d52420523ea1cef81e82ff02403fde81cf33c7b93a9702ef077bdb07762df904e368541039 WHIRLPOOL d3b2d4846bca176078d535f7ba2d26d177988f7d1d0f38163d0177534c112dfb54aef928a7608ecb531a69b4d55709c6ab72949d5a6f7a85baa1e9ec37ba368f
diff --git a/dev-libs/weston/weston-1.10.0.ebuild b/dev-libs/weston/weston-1.10.0.ebuild
new file mode 100644
index 000000000000..31eafda37fea
--- /dev/null
+++ b/dev-libs/weston/weston-1.10.0.ebuild
@@ -0,0 +1,150 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="git://anongit.freedesktop.org/git/wayland/${PN}"
+ GIT_ECLASS="git-r3"
+ EXPERIMENTAL="true"
+fi
+VIRTUALX_REQUIRED="test"
+RESTRICT="test"
+
+inherit autotools readme.gentoo-r1 toolchain-funcs virtualx $GIT_ECLASS
+
+DESCRIPTION="Wayland reference compositor"
+HOMEPAGE="http://wayland.freedesktop.org/"
+
+if [[ $PV = 9999* ]]; then
+ SRC_URI="${SRC_PATCHES}"
+ KEYWORDS=""
+else
+ SRC_URI="http://wayland.freedesktop.org/releases/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~x86 ~arm-linux"
+fi
+
+LICENSE="MIT CC-BY-SA-3.0"
+SLOT="0"
+
+IUSE_VIDEO_CARDS="video_cards_intel video_cards_v4l"
+IUSE="colord dbus +drm editor examples fbdev +gles2 headless ivi lcms rdp +resize-optimization rpi +launch screen-sharing static-libs +suid systemd test unwind wayland-compositor +X xwayland ${IUSE_VIDEO_CARDS}"
+
+REQUIRED_USE="
+ drm? ( gles2 )
+ screen-sharing? ( rdp )
+ test? ( X )
+ wayland-compositor? ( gles2 )
+"
+
+RDEPEND="
+ >=dev-libs/libinput-0.8.0
+ >=dev-libs/wayland-1.9.90
+ >=dev-libs/wayland-protocols-1.0
+ lcms? ( media-libs/lcms:2 )
+ media-libs/libpng:0=
+ media-libs/libwebp:0=
+ virtual/jpeg:0=
+ >=x11-libs/cairo-1.11.3
+ >=x11-libs/libdrm-2.4.30
+ x11-libs/libxkbcommon
+ x11-libs/pixman
+ x11-misc/xkeyboard-config
+ fbdev? (
+ >=sys-libs/mtdev-1.1.0
+ >=virtual/udev-136
+ )
+ colord? ( >=x11-misc/colord-0.1.27 )
+ dbus? ( sys-apps/dbus )
+ drm? (
+ media-libs/mesa[gbm]
+ >=sys-libs/mtdev-1.1.0
+ >=virtual/udev-136
+ )
+ editor? ( x11-libs/pango )
+ gles2? (
+ media-libs/mesa[gles2,wayland]
+ )
+ rdp? ( >=net-misc/freerdp-1.1.0_beta1_p20130710 )
+ rpi? (
+ >=sys-libs/mtdev-1.1.0
+ >=virtual/udev-136
+ )
+ systemd? (
+ sys-auth/pambase[systemd]
+ sys-apps/systemd[pam]
+ )
+ launch? ( sys-auth/pambase )
+ unwind? ( sys-libs/libunwind )
+ X? (
+ x11-libs/libxcb
+ x11-libs/libX11
+ )
+ xwayland? (
+ x11-base/xorg-server[wayland]
+ x11-libs/cairo[xcb]
+ x11-libs/libxcb
+ x11-libs/libXcursor
+ )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ if [[ ${PV} = 9999* ]]; then
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ local myconf
+ if use examples || use test; then
+ myconf="--enable-simple-clients"
+ else
+ myconf="--disable-simple-clients"
+ fi
+
+ myconf+=" --with-cairo=image --disable-simple-egl-clients"
+
+ econf \
+ $(use_enable examples demo-clients-install) \
+ $(use_enable fbdev fbdev-compositor) \
+ $(use_enable dbus) \
+ $(use_enable drm drm-compositor) \
+ $(use_enable headless headless-compositor) \
+ $(use_enable ivi ivi-shell) \
+ $(use_enable lcms) \
+ $(use_enable rdp rdp-compositor) \
+ $(use_enable rpi rpi-compositor) \
+ $(use_enable wayland-compositor) \
+ $(use_enable X x11-compositor) \
+ $(use_enable launch weston-launch) \
+ $(use_enable colord) \
+ $(use_enable gles2 egl) \
+ $(use_enable unwind libunwind) \
+ $(use_enable resize-optimization) \
+ $(use_enable screen-sharing) \
+ $(use_enable suid setuid-install) \
+ $(use_enable xwayland) \
+ $(use_enable xwayland xwayland-test) \
+ $(use_enable video_cards_intel simple-dmabuf-intel-client) \
+ $(use_enable video_cards_v4l simple-dmabuf-v4l-client) \
+ ${myconf}
+}
+
+src_test() {
+ export XDG_RUNTIME_DIR="${T}/runtime-dir"
+ mkdir "${XDG_RUNTIME_DIR}" || die
+ chmod 0700 "${XDG_RUNTIME_DIR}" || die
+
+ cd "${BUILD_DIR}" || die
+ Xemake check
+}
+
+src_install() {
+ default
+
+ readme.gentoo_create_doc
+}
diff --git a/dev-libs/weston/weston-9999.ebuild b/dev-libs/weston/weston-9999.ebuild
index 308920a07a3d..31eafda37fea 100644
--- a/dev-libs/weston/weston-9999.ebuild
+++ b/dev-libs/weston/weston-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -12,7 +12,7 @@ fi
VIRTUALX_REQUIRED="test"
RESTRICT="test"
-inherit autotools readme.gentoo toolchain-funcs virtualx $GIT_ECLASS
+inherit autotools readme.gentoo-r1 toolchain-funcs virtualx $GIT_ECLASS
DESCRIPTION="Wayland reference compositor"
HOMEPAGE="http://wayland.freedesktop.org/"
@@ -27,7 +27,9 @@ fi
LICENSE="MIT CC-BY-SA-3.0"
SLOT="0"
-IUSE="colord dbus +drm editor examples fbdev +gles2 headless ivi rdp +resize-optimization rpi +launch screen-sharing static-libs +suid systemd test unwind wayland-compositor +X xwayland"
+
+IUSE_VIDEO_CARDS="video_cards_intel video_cards_v4l"
+IUSE="colord dbus +drm editor examples fbdev +gles2 headless ivi lcms rdp +resize-optimization rpi +launch screen-sharing static-libs +suid systemd test unwind wayland-compositor +X xwayland ${IUSE_VIDEO_CARDS}"
REQUIRED_USE="
drm? ( gles2 )
@@ -38,8 +40,9 @@ REQUIRED_USE="
RDEPEND="
>=dev-libs/libinput-0.8.0
- >=dev-libs/wayland-1.9.0
- media-libs/lcms:2
+ >=dev-libs/wayland-1.9.90
+ >=dev-libs/wayland-protocols-1.0
+ lcms? ( media-libs/lcms:2 )
media-libs/libpng:0=
media-libs/libwebp:0=
virtual/jpeg:0=
@@ -112,6 +115,7 @@ src_configure() {
$(use_enable drm drm-compositor) \
$(use_enable headless headless-compositor) \
$(use_enable ivi ivi-shell) \
+ $(use_enable lcms) \
$(use_enable rdp rdp-compositor) \
$(use_enable rpi rpi-compositor) \
$(use_enable wayland-compositor) \
@@ -125,6 +129,8 @@ src_configure() {
$(use_enable suid setuid-install) \
$(use_enable xwayland) \
$(use_enable xwayland xwayland-test) \
+ $(use_enable video_cards_intel simple-dmabuf-intel-client) \
+ $(use_enable video_cards_v4l simple-dmabuf-v4l-client) \
${myconf}
}
@@ -140,5 +146,5 @@ src_test() {
src_install() {
default
- readme.gentoo_src_install
+ readme.gentoo_create_doc
}