summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMykyta Holubakha <hilobakho@gmail.com>2016-08-07 22:59:42 +0300
committerPatrice Clement <monsieurp@gentoo.org>2016-08-25 19:51:03 +0200
commit376ba4d80669b517dc0c1f168366f3f34f955f0f (patch)
tree68b53eba808b5570453db75b5c75e5608638663b /dev-libs/wlc
parentdev-lang/mono: bump to 4.6.0.150 (diff)
downloadgentoo-376ba4d80669b517dc0c1f168366f3f34f955f0f.tar.gz
gentoo-376ba4d80669b517dc0c1f168366f3f34f955f0f.tar.bz2
gentoo-376ba4d80669b517dc0c1f168366f3f34f955f0f.zip
dev-libs/wlc: version bump to 0.0.5.
Closes: https://github.com/gentoo/gentoo/pull/2040 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'dev-libs/wlc')
-rw-r--r--dev-libs/wlc/Manifest1
-rw-r--r--dev-libs/wlc/wlc-0.0.5.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/dev-libs/wlc/Manifest b/dev-libs/wlc/Manifest
index c98c3a5dfd06..54e1db359cd9 100644
--- a/dev-libs/wlc/Manifest
+++ b/dev-libs/wlc/Manifest
@@ -1 +1,2 @@
DIST wlc-0.0.3.tar.bz2 206972 SHA256 086556f97e635469afd1f73e191ac57c888925f4480d526346946350273ebb3f SHA512 e1e3c7d80d8888a8fe3102e8ea891d4c52fa160f99fdb3fb837c6ff69ef3468ca2ec2b1f850cfac3d64a7df0e426f1113963395a562ef252c096af48b55c99d4 WHIRLPOOL c59b51b37a6fe9bcc580cd3aa4ecae224f680be507a160a0cb88d5ce68de1c31fedd1e236e8a19c84175364aa26987f1b053b4d41fee2ecd5b1f9d470da544fa
+DIST wlc-0.0.5.tar.bz2 207900 SHA256 17aa8e8f4beb62b630433dd69247f272caf0575d2638726cfc1808a4239db136 SHA512 d5d0f299e713306b6c08e78b87ab8eaf9ff974aedd29b353c0db5a1a23602248306e7cd1918136f95663726fa028aa531bd496a7f24f5eaba8ba309e9af801f7 WHIRLPOOL 04f46251eac5dc21ec3071d46020819330452f61f7d60f4b9a3ac44104d0da8e65a8cd073d4a74968cb0bbf3eab57d13a62a09fd942a45157b470c2a89f742bc
diff --git a/dev-libs/wlc/wlc-0.0.5.ebuild b/dev-libs/wlc/wlc-0.0.5.ebuild
new file mode 100644
index 000000000000..5e48480d5db9
--- /dev/null
+++ b/dev-libs/wlc/wlc-0.0.5.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="A helper library for Wayland compositors"
+HOMEPAGE="https://github.com/Cloudef/wlc"
+
+SRC_URI="https://github.com/Cloudef/wlc/releases/download/v${PV}/${P}.tar.bz2"
+
+LICENSE="MIT ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="X static-libs systemd"
+
+RDEPEND="virtual/opengl
+ media-libs/mesa[wayland,gbm,gles2,egl]
+ x11-libs/libdrm
+ x11-libs/pixman
+ x11-libs/libxkbcommon
+ x11-misc/xkeyboard-config
+ dev-libs/libinput
+ dev-libs/wayland
+ X? ( x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/xcb-util-image
+ x11-libs/xcb-util-wm
+ x11-libs/libXfixes )
+ systemd? ( sys-apps/systemd sys-apps/dbus )"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ dev-libs/wayland-protocols"
+
+src_configure() {
+ local mycmakeargs=(
+ -DWLC_BUILD_EXAMPLES=OFF
+ -DWLC_BUILD_TESTS=OFF
+
+ -DWLC_BUILD_STATIC=$(usex static-libs)
+
+ -DWLC_X11_SUPPORT=$(usex X)
+
+ $(cmake-utils_use_find_package systemd Systemd)
+ $(cmake-utils_use_find_package systemd Dbus)
+ )
+
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ if use X && !has_version 'x11-base/xorg-server[wayland]'
+ then
+ elog "You have enabled wlc's X11 support. To use Xwayland, you must emerge"
+ elog "'x11-base/xorg-server[wayland]'."
+ fi
+}