summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMykyta Holubakha <hilobakho@gmail.com>2017-11-10 01:26:00 +0200
committerPatrice Clement <monsieurp@gentoo.org>2017-11-12 19:01:25 +0100
commit6986ba508aec1d3901bf7294e04102ba0ad3df50 (patch)
tree87810ad42637ab910010aa2d06955ce446f9752f /dev-libs/wlc
parentwww-client/chromium: fix build failure with gcc5 (diff)
downloadgentoo-6986ba508aec1d3901bf7294e04102ba0ad3df50.tar.gz
gentoo-6986ba508aec1d3901bf7294e04102ba0ad3df50.tar.bz2
gentoo-6986ba508aec1d3901bf7294e04102ba0ad3df50.zip
dev-libs/wlc: version bump to 0.0.11.
Closes: https://github.com/gentoo/gentoo/pull/6158
Diffstat (limited to 'dev-libs/wlc')
-rw-r--r--dev-libs/wlc/Manifest1
-rw-r--r--dev-libs/wlc/wlc-0.0.11.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-libs/wlc/Manifest b/dev-libs/wlc/Manifest
index 9199ccb732a1..0c6855f9df18 100644
--- a/dev-libs/wlc/Manifest
+++ b/dev-libs/wlc/Manifest
@@ -1,2 +1,3 @@
DIST wlc-0.0.10.tar.bz2 249721 SHA256 f8273940eaceb0661d365d284aceef7cb0ca83e641b7722d818dcac464fb0b01 SHA512 93474b04aad6534d850d9666cb7ba2b588d8beda89d785de1d569951e3c410ec66da84cdaab5e99060e61360b9bdffa96226f20e1d1e906873edc6850c34500c WHIRLPOOL d76c2d4571146939cf935dabbd8a2fe0bbfce3f832c4baffa057fdd1de636c989cb07d63db0fba88fb4d351f097e97b7a6262befb6a50d1bd4554685662a164c
+DIST wlc-0.0.11.tar.bz2 247642 SHA256 c2061f5d6c627688ea8b822ac5f4d3ba4d407b3f8d79267677ce4011b6390d22 SHA512 29e7d734cee76b9d0d1fabac71bab33a7146fec8557e583be2d0e85413fa77ed938f23f3bc8728f1f0766239d5eb023ace52abb9b78d40ce1edf876185a60ea5 WHIRLPOOL 33bcafab5955005c691315f133b1805d2ab067eba305b9378a43885e264627fc2a3f926f2aab3867ef59e8e58fa8dac8fb1dd52f5c8a16c2b30721b42b40c1f2
DIST wlc-0.0.9.tar.bz2 240932 SHA256 cc239283c1d87aff9d258e0f4dd5a3ad441d8c6e52be8204abd8694435e4c3b5 SHA512 d34a29c779a39ffb95413f26c62d545f29ed7890529296b837bb153687600582dbe927c65558923bd1614c5fe904aa9cff760c272e79c6c0eff10ba38eee895b WHIRLPOOL 002eb60fbec28fdd599996b10daaa2c2f1b15ace077e4f80bd56c906e32a51cf47a58f6c0dcbb510f333a2fcd0dccf307f5e91cc0330418b09e7d5003c4960ea
diff --git a/dev-libs/wlc/wlc-0.0.11.ebuild b/dev-libs/wlc/wlc-0.0.11.ebuild
new file mode 100644
index 000000000000..dfd3d6fd8a5a
--- /dev/null
+++ b/dev-libs/wlc/wlc-0.0.11.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="A helper library for Wayland compositors"
+HOMEPAGE="https://github.com/Cloudef/wlc"
+
+SRC_URI="https://github.com/Cloudef/wlc/releases/download/v${PV}/${P}.tar.bz2"
+
+LICENSE="MIT ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="X static-libs systemd +xwayland"
+
+RDEPEND="virtual/opengl
+ virtual/libudev
+ media-libs/mesa[wayland,gbm,gles2,egl]
+ x11-libs/libdrm
+ x11-libs/pixman
+ x11-libs/libxkbcommon
+ x11-misc/xkeyboard-config
+ dev-libs/libinput
+ dev-libs/wayland
+ X? (
+ x11-libs/libX11
+ x11-libs/libxcb[xkb]
+ x11-libs/xcb-util-image
+ x11-libs/xcb-util-wm
+ x11-libs/libXfixes
+ )
+ xwayland? (
+ x11-libs/libxcb[xkb]
+ x11-libs/xcb-util-image
+ x11-libs/xcb-util-wm
+ x11-base/xorg-server[wayland]
+ )
+ systemd? ( sys-apps/systemd sys-apps/dbus )"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ >=dev-libs/wayland-protocols-1.7"
+
+src_configure() {
+ local mycmakeargs=(
+ -DWLC_BUILD_EXAMPLES=OFF
+ -DWLC_BUILD_TESTS=OFF
+
+ -DWLC_BUILD_STATIC=$(usex static-libs)
+
+ -DWLC_X11_BACKEND_SUPPORT=$(usex X)
+ -DWLC_XWAYLAND_SUPPORT=$(usex xwayland)
+
+ $(cmake-utils_use_find_package systemd Systemd)
+ $(cmake-utils_use_find_package systemd Dbus)
+ )
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ if use X && ! use xwayland; then
+ elog "xwayland use flag is required for X11 applications support"
+ fi
+}