summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2018-07-31 15:27:11 -0700
committerPatrick McLean <chutzpah@gentoo.org>2018-07-31 15:27:11 -0700
commit224556f6e9363673a864d8fd7fe98d37beb8051e (patch)
treec01ead24bb04b419c7a1f543b268fa5ac2427b3e /dev-libs
parentdev-util/boost-build: Unkeyworded version bump to 1.67.0 (bug #653878) (diff)
downloadgentoo-224556f6e9363673a864d8fd7fe98d37beb8051e.tar.gz
gentoo-224556f6e9363673a864d8fd7fe98d37beb8051e.tar.bz2
gentoo-224556f6e9363673a864d8fd7fe98d37beb8051e.zip
dev-libs/boost: Unkeyworded version bump to 1.67.0 (bug #653878)
Bug: https://bugs.gentoo.org/653878 Package-Manager: Portage-2.3.44, Repoman-2.3.10
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/boost/Manifest1
-rw-r--r--dev-libs/boost/boost-1.67.0.ebuild419
-rw-r--r--dev-libs/boost/files/boost-1.67.0-fix-python.patch153
3 files changed, 573 insertions, 0 deletions
diff --git a/dev-libs/boost/Manifest b/dev-libs/boost/Manifest
index f5513e8c1364..19a425758e86 100644
--- a/dev-libs/boost/Manifest
+++ b/dev-libs/boost/Manifest
@@ -1,3 +1,4 @@
DIST boost_1_63_0.tar.bz2 81984414 BLAKE2B 227c4432bd3ca0eb390048ec85047958fcb6ae289996501812cd8b13bf74bbe9b677d0110948265cab59a60deb36c4fc08440af74ac5a5219ea4eaea4fa6918f SHA512 c915c5f5778dee49b8e9d0a40f37f90f56fb1fdb1d8ce92d97bf48bc7bc462212487badfe4bbe30b06196d1149cfb221da12ac54e97499b0d4cb6466813bb4ad
DIST boost_1_65_0.tar.bz2 82597718 BLAKE2B 0080956d6ad2f14130ce4a4734b1bd1ce83d3651b226653689e02770baa83cf11811ef4e44948ff68a168d9ce5cbfaea4f758970df2b4e9faa2d410181885f5b SHA512 7142650fb8d61e3ef16ba066fc918e087f19e9bc2ad1d6a11fb10bf0d6b1b5ad05ab032f076a5233a1624b3669e952b2cc38b7dc074bbf53018e2970ee90fcdd
DIST boost_1_66_0.tar.bz2 85995778 BLAKE2B 9ab1fe396b10ab85d7e4084ec7abb8d785ecd892c8f51aea5a401cb565b111c256533364fe028da74ed376534889f43c5ccbdcd703cd236526ae66a064220765 SHA512 0f34075d35391d66876e5189a01a11880a79428e1b267456348ee148dba9dc3abdc74d568f1853be631d20b584b1c804b42443c266f7622164acfc10be3dab8b
+DIST boost_1_67_0.tar.bz2 87336566 BLAKE2B 85ea00fc2197b1bbfc35d69427c87f23ea43d7592f1c9ce66e2afcde8476bdec86f6debdac815b23de59f4665a8e0c7f1519ab66a31d39df629723bc45710058 SHA512 82bf33d7d2c3db109c9d1f12d40bc2d364c8c95262386f906ccd1a71cd71433bcc01829e968b4a13a5003cf0b50cbdf0b435a1d76530cea7bb05725c327411e8
diff --git a/dev-libs/boost/boost-1.67.0.ebuild b/dev-libs/boost/boost-1.67.0.ebuild
new file mode 100644
index 000000000000..7eb5c945be41
--- /dev/null
+++ b/dev-libs/boost/boost-1.67.0.ebuild
@@ -0,0 +1,419 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_{4,5,6,7}} )
+
+inherit eutils flag-o-matic multiprocessing python-r1 toolchain-funcs multilib-minimal
+
+MY_P="${PN}_$(ver_rs 1- _)"
+MAJOR_V="$(ver_cut 1-2)"
+
+DESCRIPTION="Boost Libraries for C++"
+HOMEPAGE="https://www.boost.org/"
+SRC_URI="https://downloads.sourceforge.net/project/boost/${PN}/${PV}/${MY_P}.tar.bz2"
+
+LICENSE="Boost-1.0"
+SLOT="0/${PV}" # ${PV} instead ${MAJOR_V} due to bug 486122
+#KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x86-solaris ~x86-winnt"
+
+IUSE="context debug doc icu +nls mpi python static-libs +threads tools"
+
+RDEPEND="icu? ( >=dev-libs/icu-3.6:=[${MULTILIB_USEDEP}] )
+ !icu? ( virtual/libiconv[${MULTILIB_USEDEP}] )
+ mpi? ( >=virtual/mpi-2.0-r4[${MULTILIB_USEDEP},cxx,threads] )
+ python? (
+ ${PYTHON_DEPS}
+ >dev-python/numpy-1.7[${PYTHON_USEDEP}]
+ )
+ app-arch/bzip2[${MULTILIB_USEDEP}]
+ sys-libs/zlib[${MULTILIB_USEDEP}]
+ !app-admin/eselect-boost"
+DEPEND="${RDEPEND}
+ =dev-util/boost-build-${MAJOR_V}*"
+REQUIRED_USE="
+ mpi? ( threads )
+ python? ( ${PYTHON_REQUIRED_USE} )"
+
+S="${WORKDIR}/${MY_P}"
+
+# the tests will never fail because these are not intended as sanity
+# tests at all. They are more a way for upstream to check their own code
+# on new compilers. Since they would either be completely unreliable
+# (failing for no good reason) or completely useless (never failing)
+# there is no point in having them in the ebuild to begin with.
+RESTRICT="test"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.48.0-disable_icu_rpath.patch"
+ "${FILESDIR}/${PN}-1.55.0-context-x32.patch"
+ "${FILESDIR}/${PN}-1.56.0-build-auto_index-tool.patch"
+ "${FILESDIR}/${PN}-1.67.0-fix-python.patch"
+)
+
+python_bindings_needed() {
+ multilib_is_native_abi && use python
+}
+
+tools_needed() {
+ multilib_is_native_abi && use tools
+}
+
+create_user-config.jam() {
+ local compiler compiler_version compiler_executable
+
+ if [[ ${CHOST} == *-darwin* ]]; then
+ compiler="darwin"
+ compiler_version="$(gcc-fullversion)"
+ compiler_executable="$(tc-getCXX)"
+ else
+ compiler="gcc"
+ compiler_version="$(gcc-version)"
+ compiler_executable="$(tc-getCXX)"
+ fi
+ local mpi_configuration python_configuration
+
+ if use mpi; then
+ mpi_configuration="using mpi ;"
+ fi
+
+ if python_bindings_needed; then
+ # boost expects libpython$(pyver) and doesn't allow overrides
+ # and the build system is so creepy that it's easier just to
+ # provide a symlink (linker's going to use SONAME anyway)
+ # TODO: replace it with proper override one day
+ ln -f -s "$(python_get_library_path)" "${T}/lib${EPYTHON}$(get_libname)" || die
+
+ if tc-is-cross-compiler; then
+ python_configuration="using python : ${EPYTHON#python} : : ${SYSROOT:-${EROOT}}/usr/include/${EPYTHON} : ${SYSROOT:-${EROOT}}/usr/$(get_libdir) ;"
+ else
+ # note: we need to provide version explicitly because of
+ # a bug in the build system:
+ # https://github.com/boostorg/build/pull/104
+ python_configuration="using python : ${EPYTHON#python} : ${PYTHON} : $(python_get_includedir) : ${T} ;"
+ fi
+ fi
+
+ cat > "${BOOST_ROOT}/user-config.jam" << __EOF__ || die
+using ${compiler} : ${compiler_version} : ${compiler_executable} : <cflags>"${CFLAGS}" <cxxflags>"${CXXFLAGS}" <linkflags>"${LDFLAGS}" ;
+${mpi_configuration}
+${python_configuration}
+__EOF__
+}
+
+pkg_setup() {
+ # Bail out on unsupported build configuration, bug #456792
+ if [[ -f "${EROOT%/}/etc/site-config.jam" ]]; then
+ grep -q gentoorelease "${EROOT%/}/etc/site-config.jam" && grep -q gentoodebug "${EROOT%/}/etc/site-config.jam" ||
+ (
+ eerror "You are using custom ${EROOT%/}/etc/site-config.jam without defined gentoorelease/gentoodebug targets."
+ eerror "Boost can not be built in such configuration."
+ eerror "Please, either remove this file or add targets from ${EROOT%/}/usr/share/boost-build/site-config.jam to it."
+ die
+ )
+ fi
+}
+
+src_prepare() {
+ default
+
+ # Do not try to build missing 'wave' tool, bug #522682
+ # Upstream bugreport - https://svn.boost.org/trac/boost/ticket/10507
+ sed -i -e 's:wave/build//wave::' tools/Jamfile.v2 || die
+
+ multilib_copy_sources
+}
+
+ejam() {
+ local b2_opts=(
+ "--user-config=${BOOST_ROOT}/user-config.jam"
+ "$@"
+ )
+ echo b2 "${b2_opts[@]}"
+ b2 "${b2_opts[@]}"
+}
+
+src_configure() {
+ # Workaround for too many parallel processes requested, bug #506064
+ [[ "$(makeopts_jobs)" -gt 64 ]] && MAKEOPTS="${MAKEOPTS} -j64"
+
+ OPTIONS=(
+ $(usex debug gentoodebug gentoorelease)
+ "-j$(makeopts_jobs)"
+ -q
+ -d+2
+ pch=off
+ $(usex icu "-sICU_PATH=${EPREFIX}/usr" '--disable-icu boost.locale.icu=off')
+ $(usex mpi '' '--without-mpi')
+ $(usex nls '' '--without-locale')
+ $(usex context '' '--without-context --without-coroutine --without-fiber')
+ $(usex threads '' '--without-thread')
+ --boost-build="${EPREFIX}"/usr/share/boost-build
+ --prefix="${ED%/}/usr"
+ --layout=system
+ # building with threading=single is currently not possible
+ # https://svn.boost.org/trac/boost/ticket/7105
+ threading=multi
+ link=$(usex static-libs shared,static shared)
+ $([[ ${CHOST} == *-winnt* ]] && printf -- '-sNO_BZIP2=1\n')
+ )
+
+ if [[ ${CHOST} == *-darwin* ]]; then
+ # We need to add the prefix, and in two cases this exceeds, so prepare
+ # for the largest possible space allocation.
+ append-ldflags -Wl,-headerpad_max_install_names
+ elif [[ ${CHOST} == *-winnt* ]]; then
+ compiler=parity
+ if [[ $($(tc-getCXX) -v) == *trunk* ]]; then
+ compilerVersion=trunk
+ else
+ compilerVersion=$($(tc-getCXX) -v | sed '1q' \
+ | sed -e 's,\([a-z]*\) \([0-9]\.[0-9]\.[0-9][^ \t]*\) .*,\2,') || die "sed failed"
+ fi
+ compilerExecutable=$(tc-getCXX)
+ fi
+
+ # bug 298489
+ if use ppc || use ppc64; then
+ [[ $(gcc-version) > 4.3 ]] && append-flags -mno-altivec
+ fi
+
+ # Use C++14 globally as of 1.62
+ append-cxxflags -std=c++14
+}
+
+multilib_src_compile() {
+ local -x BOOST_ROOT="${BUILD_DIR}"
+ PYTHON_DIRS=""
+ MPI_PYTHON_MODULE=""
+
+ building() {
+ create_user-config.jam
+
+ local PYTHON_OPTIONS
+ if python_bindings_needed; then
+ PYTHON_OPTIONS=" --python-buildid=${EPYTHON#python}"
+ else
+ PYTHON_OPTIONS=" --without-python"
+ fi
+
+ ejam \
+ "${OPTIONS[@]}" \
+ ${PYTHON_OPTIONS} \
+ || die "Building of Boost libraries failed"
+
+ if python_bindings_needed; then
+ if [[ -z "${PYTHON_DIRS}" ]]; then
+ PYTHON_DIRS="$(find bin.v2/libs -name python | sort)"
+ else
+ if [[ "${PYTHON_DIRS}" != "$(find bin.v2/libs -name python | sort)" ]]; then
+ die "Inconsistent structure of build directories"
+ fi
+ fi
+
+ local dir
+ for dir in ${PYTHON_DIRS}; do
+ mv ${dir} ${dir}-${EPYTHON} \
+ || die "Renaming of '${dir}' to '${dir}-${EPYTHON}' failed"
+ done
+
+ if use mpi; then
+ if [[ -z "${MPI_PYTHON_MODULE}" ]]; then
+ MPI_PYTHON_MODULE="$(find bin.v2/libs/mpi/build/*/gentoo* -name mpi.so)"
+ if [[ "$(echo "${MPI_PYTHON_MODULE}" | wc -l)" -ne 1 ]]; then
+ die "Multiple mpi.so files found"
+ fi
+ else
+ if [[ "${MPI_PYTHON_MODULE}" != "$(find bin.v2/libs/mpi/build/*/gentoo* -name mpi.so)" ]]; then
+ die "Inconsistent structure of build directories"
+ fi
+ fi
+
+ mv stage/lib/mpi.so stage/lib/mpi.so-${EPYTHON} \
+ || die "Renaming of 'stage/lib/mpi.so' to 'stage/lib/mpi.so-${EPYTHON}' failed"
+ fi
+ fi
+ }
+ if python_bindings_needed; then
+ python_foreach_impl building
+ else
+ building
+ fi
+
+ if tools_needed; then
+ pushd tools >/dev/null || die
+
+ ejam \
+ "${OPTIONS[@]}" \
+ ${PYTHON_OPTIONS} \
+ || die "Building of Boost tools failed"
+ popd >/dev/null || die
+ fi
+}
+
+multilib_src_install_all() {
+ if ! use python; then
+ rm -r "${ED%/}"/usr/include/boost/python* || die
+ fi
+
+ if ! use nls; then
+ rm -r "${ED%/}"/usr/include/boost/locale || die
+ fi
+
+ if ! use context; then
+ rm -r "${ED%/}"/usr/include/boost/context || die
+ rm -r "${ED%/}"/usr/include/boost/coroutine{,2} || die
+ rm "${ED%/}"/usr/include/boost/asio/spawn.hpp || die
+ fi
+
+ if use doc; then
+ # find extraneous files that shouldn't be installed
+ # as part of the documentation and remove them.
+ find libs/*/* \( -iname 'test' -o -iname 'src' \) -exec rm -rf '{}' + || die
+ find doc \( -name 'Jamfile.v2' -o -name 'build' -o -name '*.manifest' \) -exec rm -rf '{}' + || die
+ find tools \( -name 'Jamfile.v2' -o -name 'src' -o -name '*.cpp' -o -name '*.hpp' \) -exec rm -rf '{}' + || die
+
+ docinto html
+ dodoc *.{htm,html,png,css}
+ dodoc -r doc libs more tools
+
+ # To avoid broken links
+ dodoc LICENSE_1_0.txt
+
+ dosym ../../../../include/boost /usr/share/doc/${PF}/html/boost
+ fi
+}
+
+multilib_src_install() {
+ local -x BOOST_ROOT="${BUILD_DIR}"
+ installation() {
+ create_user-config.jam
+
+ local PYTHON_OPTIONS
+ if python_bindings_needed; then
+ local dir
+ for dir in ${PYTHON_DIRS}; do
+ cp -pr ${dir}-${EPYTHON} ${dir} \
+ || die "Copying of '${dir}-${EPYTHON}' to '${dir}' failed"
+ done
+
+ if use mpi; then
+ cp -p stage/lib/mpi.so-${EPYTHON} "${MPI_PYTHON_MODULE}" \
+ || die "Copying of 'stage/lib/mpi.so-${EPYTHON}' to '${MPI_PYTHON_MODULE}' failed"
+ cp -p stage/lib/mpi.so-${EPYTHON} stage/lib/mpi.so \
+ || die "Copying of 'stage/lib/mpi.so-${EPYTHON}' to 'stage/lib/mpi.so' failed"
+ fi
+ PYTHON_OPTIONS=" --python-buildid=${EPYTHON#python}"
+ else
+ PYTHON_OPTIONS=" --without-python"
+ fi
+
+ ejam \
+ "${OPTIONS[@]}" \
+ ${PYTHON_OPTIONS} \
+ --includedir="${ED%/}/usr/include" \
+ --libdir="${ED%/}/usr/$(get_libdir)" \
+ install || die "Installation of Boost libraries failed"
+
+ if python_bindings_needed; then
+ rm -r ${PYTHON_DIRS} || die
+
+ # Move mpi.so Python module to Python site-packages directory.
+ # https://svn.boost.org/trac/boost/ticket/2838
+ if use mpi; then
+ local moddir=$(python_get_sitedir)/boost
+ # moddir already includes eprefix
+ mkdir -p "${D}${moddir}" || die
+ mv "${ED%/}/usr/$(get_libdir)/mpi.so" "${D}${moddir}" || die
+ cat << EOF > "${D}${moddir}/__init__.py" || die
+import sys
+if sys.platform.startswith('linux'):
+ import DLFCN
+ flags = sys.getdlopenflags()
+ sys.setdlopenflags(DLFCN.RTLD_NOW | DLFCN.RTLD_GLOBAL)
+ from . import mpi
+ sys.setdlopenflags(flags)
+ del DLFCN, flags
+else:
+ from . import mpi
+del sys
+EOF
+ fi
+
+ python_optimize
+ fi
+ }
+ if python_bindings_needed; then
+ python_foreach_impl installation
+ else
+ installation
+ fi
+
+ pushd "${ED%/}/usr/$(get_libdir)" >/dev/null || die
+
+ local ext=$(get_libname)
+ if use threads; then
+ local f
+ for f in *${ext}; do
+ dosym ${f} /usr/$(get_libdir)/${f/${ext}/-mt${ext}}
+ done
+ fi
+
+ popd >/dev/null || die
+
+ if tools_needed; then
+ dobin dist/bin/*
+
+ insinto /usr/share
+ doins -r dist/share/boostbook
+ fi
+
+ # boost's build system truely sucks for not having a destdir. Because for
+ # this reason we are forced to build with a prefix that includes the
+ # DESTROOT, dynamic libraries on Darwin end messed up, referencing the
+ # DESTROOT instread of the actual EPREFIX. There is no way out of here
+ # but to do it the dirty way of manually setting the right install_names.
+ if [[ ${CHOST} == *-darwin* ]]; then
+ einfo "Working around completely broken build-system(tm)"
+ local d
+ for d in "${ED%/}"/usr/lib/*.dylib; do
+ if [[ -f ${d} ]]; then
+ # fix the "soname"
+ ebegin " correcting install_name of ${d#${ED}}"
+ install_name_tool -id "/${d#${D}}" "${d}"
+ eend $?
+ # fix references to other libs
+ refs=$(otool -XL "${d}" | \
+ sed -e '1d' -e 's/^\t//' | \
+ grep "^libboost_" | \
+ cut -f1 -d' ')
+ local r
+ for r in ${refs}; do
+ ebegin " correcting reference to ${r}"
+ install_name_tool -change \
+ "${r}" \
+ "${EPREFIX}/usr/lib/${r}" \
+ "${d}"
+ eend $?
+ done
+ fi
+ done
+ fi
+}
+
+pkg_preinst() {
+ # Yai for having symlinks that are nigh-impossible to remove without
+ # resorting to dirty hacks like these. Removes lingering symlinks
+ # from the slotted versions.
+ local symlink
+ for symlink in "${EROOT%/}/usr/include/boost" "${EROOT%/}/usr/share/boostbook"; do
+ if [[ -L ${symlink} ]]; then
+ rm -f "${symlink}" || die
+ fi
+ done
+
+ # some ancient installs still have boost cruft lying around
+ # for unknown reasons, causing havoc for reverse dependencies
+ # Bug: 607734
+ rm -rf "${EROOT%/}"/usr/include/boost-1_[3-5]? || die
+}
diff --git a/dev-libs/boost/files/boost-1.67.0-fix-python.patch b/dev-libs/boost/files/boost-1.67.0-fix-python.patch
new file mode 100644
index 000000000000..6f51152d12e3
--- /dev/null
+++ b/dev-libs/boost/files/boost-1.67.0-fix-python.patch
@@ -0,0 +1,153 @@
+Python module needs to be built without these extra renames.
+MPI module needs to reference correct python
+
+~Index: boost_1_64_0/libs/mpi/build/Jamfile.v2
+~===================================================================
+~--- boost_1_64_0.orig/libs/mpi/build/Jamfile.v2
+~+++ boost_1_64_0/libs/mpi/build/Jamfile.v2
+~@@ -61,10 +61,10 @@ libraries += boost_mpi ;
+~ lib boost_mpi_python
+~ : # Sources
+~ python/serialize.cpp
+~+ /user-config//boost_python_alias
+~ : # Requirements
+~ <library>boost_mpi
+~ <library>/mpi//mpi [ mpi.extra-requirements ]
+~- <library>/boost/python//boost_python
+~ <link>shared:<define>BOOST_MPI_DYN_LINK=1
+~ <link>shared:<define>BOOST_MPI_PYTHON_DYN_LINK=1
+~ <link>shared:<define>BOOST_PYTHON_DYN_LINK=1
+~@@ -92,8 +92,8 @@ libraries += boost_mpi ;
+~ python/skeleton_and_content.cpp
+~ python/status.cpp
+~ python/py_timer.cpp
+~+ /user-config//boost_python_alias
+~ : # Requirements
+~- <library>/boost/python//boost_python
+~ <library>boost_mpi_python
+~ <library>boost_mpi
+~ <library>/mpi//mpi [ mpi.extra-requirements ]
+Index: boost_1_67_0/libs/mpi/build/Jamfile.v2
+===================================================================
+--- boost_1_67_0.orig/libs/mpi/build/Jamfile.v2
++++ boost_1_67_0/libs/mpi/build/Jamfile.v2
+@@ -60,33 +60,13 @@ libraries += boost_mpi ;
+
+ if [ python.configured ]
+ {
+- py2-version = [ py-version 2 ] ;
+- py3-version = [ py-version 3 ] ;
+-
+- # These library names are synchronized with those defined by Boost.Python, see libs/python/build/Jamfile.
+- lib_boost_python(2) = boost_python ;
+- lib_boost_python(3) = boost_python3 ;
+-
+- lib_boost_python($(py2-version)) = $(lib_boost_python(2)) ;
+- lib_boost_python($(py3-version)) = $(lib_boost_python(3)) ;
+-
+- lib_boost_mpi_python(2) = boost_mpi_python ;
+- lib_boost_mpi_python(3) = boost_mpi_python3 ;
+-
+- lib_boost_mpi_python($(py2-version)) = $(lib_boost_mpi_python(2)) ;
+- lib_boost_mpi_python($(py3-version)) = $(lib_boost_mpi_python(3)) ;
+-
+- for local N in 2 3
+- {
+- if $(py$(N)-version)
+- {
+- lib $(lib_boost_mpi_python($(py$(N)-version)))
++ lib boost_mpi_python
+ : # Sources
+ python/serialize.cpp
+ : # Requirements
+ <library>boost_mpi
+ <library>/mpi//mpi [ mpi.extra-requirements ]
+- <library>/boost/python//$(lib_boost_python($(py$(N)-version)))
++ <library>/boost/python//boost_python
+ <link>shared:<define>BOOST_MPI_DYN_LINK=1
+ <link>shared:<define>BOOST_MPI_PYTHON_DYN_LINK=1
+ <link>shared:<define>BOOST_PYTHON_DYN_LINK=1
+@@ -94,12 +74,12 @@ libraries += boost_mpi ;
+ -<tag>@$(BOOST_JAMROOT_MODULE)%$(BOOST_JAMROOT_MODULE).tag
+ <tag>@$(BOOST_JAMROOT_MODULE)%$(BOOST_JAMROOT_MODULE).python-tag
+ <python-debugging>on:<define>BOOST_DEBUG_PYTHON
+- <python>$(py$(N)-version)
+ : # Default build
+ <link>shared
+ : # Usage requirements
+ <library>/mpi//mpi [ mpi.extra-requirements ]
+ ;
++ libraries += boost_mpi_python ;
+
+ python-extension mpi
+ : # Sources
+@@ -116,8 +96,8 @@ libraries += boost_mpi ;
+ python/status.cpp
+ python/py_timer.cpp
+ : # Requirements
+- <library>/boost/python//$(lib_boost_python($(py$(N)-version)))
+- <library>$(lib_boost_mpi_python($(py$(N)-version)))
++ <library>/boost/python//boost_python
++ <library>boost_mpi_python
+ <library>boost_mpi
+ <library>/mpi//mpi [ mpi.extra-requirements ]
+ <link>shared:<define>BOOST_MPI_DYN_LINK=1
+@@ -125,16 +105,7 @@ libraries += boost_mpi ;
+ <link>shared:<define>BOOST_PYTHON_DYN_LINK=1
+ <link>shared <runtime-link>shared
+ <python-debugging>on:<define>BOOST_DEBUG_PYTHON
+- <python>$(py$(N)-version)
+ ;
+-
+- libraries += $(lib_boost_mpi_python($(py$(N)-version))) ;
+- }
+- else
+- {
+- alias $(lib_boost_mpi_python($(N))) ;
+- }
+- }
+ }
+ }
+ else if ! ( --without-mpi in [ modules.peek : ARGV ] )
+Index: boost_1_67_0/libs/python/Jamfile
+===================================================================
+--- boost_1_67_0.orig/libs/python/Jamfile
++++ boost_1_67_0/libs/python/Jamfile
+@@ -36,9 +36,10 @@ local rule split-version ( version )
+ # For example, Boost.Python built for Python 2.7 uses the suffix "27"
+ rule version-suffix ( version )
+ {
+- local major-minor = [ split-version $(version) ] ;
+- local suffix = $(major-minor:J="") ;
+- return $(suffix) ;
++ # local major-minor = [ split-version $(version) ] ;
++ # local suffix = $(major-minor:J="") ;
++ # return $(suffix) ;
++ return "" ;
+ }
+
+
+diff -ur boost_1_67_0.orig/boostcpp.jam boost_1_67_0/boostcpp.jam
+--- boost_1_67_0.orig/boostcpp.jam 2018-07-30 16:26:03.346187542 -0700
++++ boost_1_67_0/boostcpp.jam 2018-07-30 16:26:18.839081472 -0700
+@@ -105,7 +105,7 @@
+ python-id = [ option.get "python-buildid" ] ;
+ if $(python-id)
+ {
+- PYTHON_ID = [ regex.replace $(python-id) "[*\\/:.\"\']" _ ] ;
++ PYTHON_ID = [ regex.replace $(python-id) "[*\\/:\"\']" _ ] ;
+ }
+
+
+diff -ur boost_1_67_0.orig/libs/python/Jamfile boost_1_67_0/libs/python/Jamfile
+--- boost_1_67_0.orig/libs/python/Jamfile 2018-07-30 14:56:15.591366992 -0700
++++ boost_1_67_0/libs/python/Jamfile 2018-07-30 16:26:31.662993677 -0700
+@@ -47,7 +47,7 @@
+ python-id = [ option.get "python-buildid" ] ;
+ if $(python-id)
+ {
+- PYTHON_ID = [ regex.replace $(python-id) "[*\\/:.\"\']" _ ] ;
++ PYTHON_ID = [ regex.replace $(python-id) "[*\\/:\"\']" _ ] ;
+ }
+
+ rule python-tag ( name : type ? : property-set )