summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2018-07-02 14:44:19 -0400
committerAnthony G. Basile <blueness@gentoo.org>2018-07-02 14:44:53 -0400
commit3471297f43cdbcbe191db3bd049ae1aa5a69fbc4 (patch)
tree8f6e28f05d708baed2b518780d2759e6040b542e /dev-libs
parentnet-libs/rpcsvc-proto: arm stable, bug #657148 (diff)
downloadgentoo-3471297f43cdbcbe191db3bd049ae1aa5a69fbc4.tar.gz
gentoo-3471297f43cdbcbe191db3bd049ae1aa5a69fbc4.tar.bz2
gentoo-3471297f43cdbcbe191db3bd049ae1aa5a69fbc4.zip
dev-libs/xapian-bindings: version bump to 1.4.6
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/xapian-bindings/Manifest1
-rw-r--r--dev-libs/xapian-bindings/xapian-bindings-1.4.6.ebuild305
2 files changed, 306 insertions, 0 deletions
diff --git a/dev-libs/xapian-bindings/Manifest b/dev-libs/xapian-bindings/Manifest
index e863175d7b2a..a1acf851067b 100644
--- a/dev-libs/xapian-bindings/Manifest
+++ b/dev-libs/xapian-bindings/Manifest
@@ -2,3 +2,4 @@ DIST xapian-bindings-1.2.24.tar.xz 886148 BLAKE2B b3ed571022f24754b21e64479b7d83
DIST xapian-bindings-1.2.25.tar.xz 1711860 BLAKE2B 66367dbc503333c4f59da8bb5bd4885fe9678aace45365573bac8e0e8e2c712795af2021ff52de9eeabb91f65a2f0447d1963424b1ae6558be95b737d1279e98 SHA512 5d27b2ae2722409ea99a1b9e6bf3f5c61ed9195b67121c090f1533340d3b11c546014985d0989a0725b60a07b392b9705bce054495f423bd3a7c99835aa336c7
DIST xapian-bindings-1.4.4.tar.xz 1117140 BLAKE2B 2240ecbe136443e9beea8871731a720a7382f0b59533ecb50983ff3cf8142500aaf762e4d1282be26de9f7e862c1071e21fa3cd67c50203d7bbc687fb202fb6d SHA512 006e771b3ea654130b4f76f1a1caee576fd5a3fa6317ca44f1e5483671e8c83073ecbde4f3fc7f84c75590eec53acb59701af4cf9bcd72355ed9d53924492b53
DIST xapian-bindings-1.4.5.tar.xz 1118884 BLAKE2B 507b06f0121e5a56224250bfe7b19795eb9fd2fba977d12022d054e7b832fd70af70085ad576dab41efcde261f9ecd48179646f1ea67aaa266fb6272358eb69a SHA512 e39ece495e25077990db3d06554306567c52c6f45ad55a65005cb97e18086ee18947e41d0d612157b891b61e015881385bcb082a03aa0c6452565e90d09e8275
+DIST xapian-bindings-1.4.6.tar.xz 1121532 BLAKE2B ecac35f9510fadb39f260c1ebd03220ebe01131e4a5fcc2842778adccdf9bf3e3ae6161dd66dc75774bfb1643f1dccc99a3bbb99894e49dbbdd65f838f827a4d SHA512 e1d8d4c79ef8eb1b890be955b14eca7e9c7aafc6051cf9080d67948455f82ed68ab518343f532cde2a1c9e07d94b3aae8b8f5130db158c6badc9b6d118ceb733
diff --git a/dev-libs/xapian-bindings/xapian-bindings-1.4.6.ebuild b/dev-libs/xapian-bindings/xapian-bindings-1.4.6.ebuild
new file mode 100644
index 000000000000..863e7f5c4340
--- /dev/null
+++ b/dev-libs/xapian-bindings/xapian-bindings-1.4.6.ebuild
@@ -0,0 +1,305 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+PYTHON_REQ_USE="threads(+)"
+
+USE_PHP="php5-6 php7-0 php7-1 php7-2"
+
+PHP_EXT_NAME="xapian"
+PHP_EXT_INI="yes"
+PHP_EXT_OPTIONAL_USE="php"
+
+USE_RUBY="ruby22 ruby23 ruby24"
+RUBY_OPTIONAL="yes"
+
+inherit java-pkg-opt-2 mono-env multibuild php-ext-source-r3 python-r1 ruby-ng toolchain-funcs
+
+DESCRIPTION="SWIG and JNI bindings for Xapian"
+HOMEPAGE="http://www.xapian.org/"
+SRC_URI="http://oligarchy.co.uk/xapian/${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="java lua mono perl php python ruby tcl"
+REQUIRED_USE="|| ( java lua mono perl php python ruby tcl )
+ python? ( ${PYTHON_REQUIRED_USE} )
+ ruby? ( || ( $(ruby_get_use_targets) ) )"
+
+COMMONDEPEND=">=dev-libs/xapian-1.4.6:0/30
+ lua? ( dev-lang/lua:= )
+ perl? ( dev-lang/perl:= )
+ python? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ ${PYTHON_DEPS}
+ )
+ ruby? ( $(ruby_implementations_depend) )
+ tcl? ( dev-lang/tcl:= )
+ mono? ( dev-lang/mono )"
+DEPEND="${COMMONDEPEND}
+ virtual/pkgconfig
+ java? ( >=virtual/jdk-1.6 )"
+RDEPEND="${COMMONDEPEND}
+ java? ( >=virtual/jre-1.6 )"
+
+S="${WORKDIR}/${P}"
+
+has_basic_bindings() {
+ # Update this list if new bindings are added that are not built
+ # multiple times for multiple versions like php, python and ruby are
+ return $(use mono || use java || use lua || use perl || use tcl)
+}
+
+php_copy_sources() {
+ local MULTIBUILD_VARIANTS=($(php_get_slots))
+ multibuild_copy_sources
+}
+
+php_foreach_impl() {
+ local MULTIBUILD_VARIANTS=($(php_get_slots))
+ multibuild_foreach_variant "$@"
+}
+
+ruby_copy_sources() {
+ local MULTIBUILD_VARIANTS=($(ruby_get_use_implementations))
+ multibuild_copy_sources
+}
+
+ruby_foreach_impl() {
+ local MULTIBUILD_VARIANTS=($(ruby_get_use_implementations))
+ multibuild_foreach_variant "$@"
+}
+
+pkg_setup() {
+ use mono && mono-env_pkg_setup
+ use java && java-pkg-opt-2_pkg_setup
+}
+
+src_unpack() {
+ default
+
+ if use php; then
+ local php_slot
+ for php_slot in $(php_get_slots); do
+ # Unfortunately required for php-ext-source-r3_createinifiles().
+ mkdir "${WORKDIR}/${php_slot}"
+ done
+ fi
+}
+
+src_prepare() {
+ use java && java-pkg-opt-2_src_prepare
+
+ # http://trac.xapian.org/ticket/702
+ export XAPIAN_CONFIG="/usr/bin/xapian-config"
+
+ if use php; then
+ php_copy_sources
+ fi
+
+ if use python; then
+ python_copy_sources
+ fi
+
+ if use ruby; then
+ ruby_copy_sources
+ fi
+
+ eapply_user
+}
+
+src_configure() {
+ if has_basic_bindings ; then
+ local conf=(
+ --disable-documentation
+ $(use_with mono csharp)
+ $(use_with java)
+ $(use_with lua)
+ $(use_with perl)
+ $(use_with tcl)
+ --without-php
+ --without-php7
+ --without-python
+ --without-python3
+ --without-ruby
+ )
+
+ if use java; then
+ local -x CXXFLAGS="${CXXFLAGS} $(java-pkg_get-jni-cflags)"
+ fi
+
+ if use perl; then
+ local -x PERL_ARCH="$(perl -MConfig -e 'print $Config{installvendorarch}')"
+ local -x PERL_LIB="$(perl -MConfig -e 'print $Config{installvendorlib}')"
+ fi
+
+ if use lua; then
+ local -x LUA_INC="$("$(tc-getPKG_CONFIG)" --variable=INSTALL_INC lua)"
+ local -x LUA_LIB="$("$(tc-getPKG_CONFIG)" --variable=INSTALL_CMOD lua)"
+ fi
+
+ econf "${conf[@]}"
+ fi
+
+ php_configure() {
+ local myconf=(
+ --disable-documentation
+ --without-java
+ --without-lua
+ --without-csharp
+ --without-perl
+ --without-python
+ --without-python3
+ --without-ruby
+ --without-tcl
+ )
+ if [[ ${MULTIBUILD_VARIANT} == php5.* ]]; then
+ myconf+=(
+ --with-php
+ --without-php7
+ )
+ local -x PHP_CONFIG="${EPREFIX}/usr/$(get_libdir)/${MULTIBUILD_VARIANT/-/.}/bin/php-config"
+ elif [[ ${MULTIBUILD_VARIANT} == php7.* ]]; then
+ myconf+=(
+ --without-php
+ --with-php7
+ )
+ local -x PHP_CONFIG7="${EPREFIX}/usr/$(get_libdir)/${MULTIBUILD_VARIANT/-/.}/bin/php-config"
+ fi
+
+ econf "${myconf[@]}"
+ }
+
+ if use php; then
+ addpredict /usr/share/snmp/mibs/.index
+ addpredict /var/lib/net-snmp/mib_indexes
+
+ php_foreach_impl run_in_build_dir php_configure
+ fi
+
+ python_configure() {
+ local myconf=(
+ --disable-documentation
+ --without-java
+ --without-lua
+ --without-csharp
+ --without-perl
+ --without-php
+ --without-php7
+ --without-ruby
+ --without-tcl
+ )
+ if python_is_python3; then
+ myconf+=( --with-python3 )
+ else
+ myconf+=( --with-python )
+ fi
+
+ # Avoid sandbox failures when compiling modules
+ addpredict "$(python_get_sitedir)"
+
+ econf "${myconf[@]}"
+ }
+
+ if use python; then
+ python_foreach_impl run_in_build_dir python_configure
+ fi
+
+ ruby_configure() {
+ local myconf=(
+ --disable-documentation
+ --without-java
+ --without-lua
+ --without-csharp
+ --without-perl
+ --without-php
+ --without-php7
+ --without-python
+ --without-python3
+ --with-ruby
+ --without-tcl
+ )
+ local -x RUBY="${EPREFIX}/usr/bin/${MULTIBUILD_VARIANT}"
+
+ econf "${myconf[@]}"
+ }
+
+ if use ruby; then
+ ruby_foreach_impl run_in_build_dir ruby_configure
+ fi
+}
+
+src_compile() {
+ if has_basic_bindings ; then
+ default
+ fi
+
+ if use php; then
+ php_foreach_impl run_in_build_dir emake
+ fi
+
+ if use python; then
+ unset PYTHONDONTWRITEBYTECODE
+ python_foreach_impl run_in_build_dir emake
+ fi
+
+ if use ruby; then
+ ruby_foreach_impl run_in_build_dir emake
+ fi
+}
+
+src_test() {
+ if has_basic_bindings ; then
+ default
+ fi
+
+ if use php; then
+ php_foreach_impl run_in_build_dir emake check
+ fi
+
+ if use python; then
+ python_foreach_impl run_in_build_dir emake check
+ fi
+
+ if use ruby; then
+ ruby_foreach_impl run_in_build_dir emake check
+ fi
+}
+
+src_install() {
+ if has_basic_bindings ; then
+ emake DESTDIR="${D}" install
+ fi
+
+ if use java; then
+ java-pkg_dojar java/built/xapian.jar
+ # TODO: make the build system not install this...
+ java-pkg_doso java/.libs/libxapian_jni.so
+ rm -rf "${D}var" || die "could not remove java cruft!"
+ fi
+
+ if use php; then
+ php_foreach_impl run_in_build_dir emake DESTDIR="${D}" install
+ php-ext-source-r3_createinifiles
+ # php-ext-source-r3_createinifiles() changes current directory.
+ cd "${S}"
+ fi
+
+ if use python; then
+ python_foreach_impl run_in_build_dir emake DESTDIR="${D}" install
+ fi
+
+ if use ruby; then
+ ruby_foreach_impl run_in_build_dir emake DESTDIR="${D}" install
+ fi
+
+ # For some USE combinations this directory is not created
+ if [[ -d "${D}/usr/share/doc/xapian-bindings" ]]; then
+ mv "${D}/usr/share/doc/xapian-bindings" "${D}/usr/share/doc/${PF}" || die
+ fi
+
+ dodoc AUTHORS HACKING NEWS TODO README
+}