summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-07-02 12:20:01 +0200
committerPacho Ramos <pacho@gentoo.org>2016-07-02 12:43:13 +0200
commit426b0930dcfedee003e4ee4e7d9fa5de46c83fb3 (patch)
treee003c02dc47886608220386a365493b70ed5c90c /dev-libs
parentdev-libs/appstream-glib: Drop old (diff)
downloadgentoo-426b0930dcfedee003e4ee4e7d9fa5de46c83fb3.tar.gz
gentoo-426b0930dcfedee003e4ee4e7d9fa5de46c83fb3.tar.bz2
gentoo-426b0930dcfedee003e4ee4e7d9fa5de46c83fb3.zip
dev-libs/appstream-glib: Version bump
Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/appstream-glib/Manifest1
-rw-r--r--dev-libs/appstream-glib/appstream-glib-0.5.16.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/dev-libs/appstream-glib/Manifest b/dev-libs/appstream-glib/Manifest
index 945c3bc9aef0..5a31262eee1e 100644
--- a/dev-libs/appstream-glib/Manifest
+++ b/dev-libs/appstream-glib/Manifest
@@ -1,2 +1,3 @@
DIST appstream-glib-0.5.15.tar.xz 1884660 SHA256 cc21f213f4aa1693e68b9edf3b79933ef510c936bf9a8ff6e5edfc1ce15b5b3e SHA512 038dcabc48c868d0d1f6fa0841a465970fd28811c910dde3020beb641ffc89f2a6567d5b16cbf2c9e3100d71b39bc2a2584a2fbe502b77b74c8ad8cb4c0067da WHIRLPOOL 754330dd9ef5450781f978a880ed08d3c98248d2ad79f3c0c693addc1c8453348df4018d12bdca9a99b404fa1336994de12c89c29567928fdce9fc578afb88bb
+DIST appstream-glib-0.5.16.tar.xz 1885896 SHA256 788de3f6480789ad1adc144b0e16978af5863365b7a1650b4f14d29ad848ec62 SHA512 c047d2f6a3cb46ebbcd4dd6165bcbfbaba6d0b20b45d94b933b36cfd62f8821c0e062c4932d0d9d846cdb866bddd611a1055baf21d9438b1fa50b8480ecd7c17 WHIRLPOOL b09d0335a28b138dac58d70257773c2f653808c53c6ea2c923f94612a8a86147e793b36194716a3e58897bff5d9c9d1b677244044020236391d63e05e1be19e5
DIST appstream-glib-0.5.9.tar.xz 1868132 SHA256 f0e4818553fe763894c660fec2c461b8815f83869acbf165daf32e2e41a5b166 SHA512 3c39233df97c464bfc993b54cee7eea01407220de39f833e34a017f6efc4c9bad0eb1762d72aed5eee94bb6a66044c7e031ede6685e1804b7ad6833b12fa9f7b WHIRLPOOL bbcc4318fafb1c3d94a8d695b924d2dec6f8c1bc968de3ca1480a8db6df47b7f30d2b656be09d7b6c2d7ed919b943452eca5b35e4559ff869872e97374228234
diff --git a/dev-libs/appstream-glib/appstream-glib-0.5.16.ebuild b/dev-libs/appstream-glib/appstream-glib-0.5.16.ebuild
new file mode 100644
index 000000000000..cd57507c5262
--- /dev/null
+++ b/dev-libs/appstream-glib/appstream-glib-0.5.16.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+
+inherit bash-completion-r1 gnome2
+
+DESCRIPTION="Provides GObjects and helper methods to read and write AppStream metadata"
+HOMEPAGE="https://people.freedesktop.org/~hughsient/appstream-glib/"
+SRC_URI="https://people.freedesktop.org/~hughsient/${PN}/releases/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/8" # soname version
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+introspection nls"
+
+# FIXME: yaml is optional with --enable-dep11 but not
+# properly handled in autofoo bug#????
+RDEPEND="
+ app-arch/gcab
+ app-arch/libarchive
+ dev-db/sqlite:3
+ >=dev-libs/glib-2.45.8:2
+ >=dev-libs/json-glib-1.1.1
+ dev-libs/libyaml
+ >=media-libs/fontconfig-2.11:1.0
+ >=media-libs/freetype-2.4:2
+ >=net-libs/libsoup-2.51.92:2.4
+ sys-apps/util-linux
+ >=x11-libs/gdk-pixbuf-2.31.5:2
+ x11-libs/gtk+:3
+ x11-libs/pango
+ introspection? ( >=dev-libs/gobject-introspection-0.9.8:= )
+"
+DEPEND="${RDEPEND}
+ app-text/docbook-xml-dtd:4.3
+ dev-libs/libxslt
+ >=dev-util/gtk-doc-am-1.9
+ >=dev-util/intltool-0.40
+ >=sys-devel/gettext-0.17
+"
+# ${PN} superseeds appdata-tools, require dummy package until all ebuilds
+# are migrated to appstream-glib
+RDEPEND="${RDEPEND}
+ !<dev-util/appdata-tools-0.1.8-r1
+"
+
+src_configure() {
+ gnome2_src_configure \
+ --enable-builder \
+ --enable-firmware \
+ --disable-rpm \
+ --disable-static \
+ --enable-dep11 \
+ --enable-man \
+ $(use_enable nls) \
+ $(use_enable introspection) \
+ --with-bashcompletiondir="$(get_bashcompdir)"
+}