summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Kenzelmann <gentoo@k8n.de>2019-08-17 15:14:55 +0200
committerJoonas Niilola <juippis@gentoo.org>2019-08-17 18:52:04 +0300
commit565a66fcdf65964cf319c74eddc719310376b848 (patch)
tree3a99baec1170d43efb9b759729e88d5527a30253 /dev-libs
parentapp-benchmarks/sysbench: drop old (diff)
downloadgentoo-565a66fcdf65964cf319c74eddc719310376b848.tar.gz
gentoo-565a66fcdf65964cf319c74eddc719310376b848.tar.bz2
gentoo-565a66fcdf65964cf319c74eddc719310376b848.zip
dev-libs/pigpio: new version 71
new upstream version, revbump Signed-off-by: Daniel Kenzelmann <gentoo@k8n.de> Closes: https://github.com/gentoo/gentoo/pull/12730 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/pigpio/Manifest1
-rw-r--r--dev-libs/pigpio/pigpio-71.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-libs/pigpio/Manifest b/dev-libs/pigpio/Manifest
index 0f01a744f391..9cff9ed247c9 100644
--- a/dev-libs/pigpio/Manifest
+++ b/dev-libs/pigpio/Manifest
@@ -1,3 +1,4 @@
DIST pigpio-67.tar.gz 369268 BLAKE2B a9d59369f5eed4b733e0e5c0e85013a132e55ff63a2393d79a3fb52d1fcb2513559d4dfeea84c4842d6281936b6e116bd81cd63e4542bbcffaf813ee356ee0d1 SHA512 9792f8402ee0dd204f4a975ab0513099a1fe3d398a28b766f412c08d7908e8e307de4cc92b2a2519b6484f15a043bd40008b7707486015c08bda5f97b1e7e00b
DIST pigpio-68.tar.gz 371251 BLAKE2B c0118854d18ce158a3d5c96380289cc8bc68f35f72ce28f207dfbb827f97f538acd82cec2af11590e59985b77ef08834d55b3ac7578e1f6b6d1a0b5d5d594632 SHA512 125364eab9dd33c39fda148c6018679ac91b099914d7f0c6362f61566a9c957065189ace03ad4668b29f25d4d542b81d42c0befe0712867b48977b755dc03edc
DIST pigpio-70.tar.gz 374569 BLAKE2B a2caadf0e1307c8c3ce936d5fd4d31e18185aa53900f6b2cf8b92a31f423b9a82bf4d2b7212fa8cd5b2d26773598a138ef8331884410f3f418542f43ca1fe2d4 SHA512 00db37b9c0f9751e6179b19e7018583abd9e11d78d01ff9f99b713004cf4e6a224e93644206599378a34dd46fd75c08557021b706015b0bc2bd8b34e363691db
+DIST pigpio-71.tar.gz 374952 BLAKE2B a79a408915285674211e50e30d3cafa433a9ee364cacced501e109d6c31a3a03c14f9d25c3c18e3df252801de65c60ca67cd5f1a8e08f05be8098ad591a14fee SHA512 c3bf029bebff9a7ee02b48597f624a5dcdf277c5c1a7ffa2f6cb83885a93cd6713935d9502127d11c4e9c11e7f6f6be49c8af367707eca2fff469728b5248e2f
diff --git a/dev-libs/pigpio/pigpio-71.ebuild b/dev-libs/pigpio/pigpio-71.ebuild
new file mode 100644
index 000000000000..f4a86cfd1b13
--- /dev/null
+++ b/dev-libs/pigpio/pigpio-71.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
+
+inherit distutils-r1 systemd toolchain-funcs
+
+DESCRIPTION="A library for the Raspberry which allows control of the GPIOs"
+HOMEPAGE="http://abyz.me.uk/rpi/pigpio/index.html"
+SRC_URI="https://github.com/joan2937/pigpio/archive/V${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS="~arm"
+IUSE="python"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+src_prepare() {
+ eapply "${FILESDIR}/${PN}-70-makefile.patch"
+ eapply_user
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" STRIP=: STRIPLIB=: SIZE=:
+ use python && distutils-r1_src_compile
+}
+
+src_install() {
+ emake DESTDIR="${D}" LDCONFIG=: PYTHON2=: PYTHON3=: \
+ libdir="${EPREFIX}/usr/$(get_libdir)" prefix="${EPREFIX}/usr" \
+ mandir="${EPREFIX}/usr/share/man" install
+ einstalldocs
+ newinitd "${FILESDIR}"/pigpiod.initd pigpiod
+ newconfd "${FILESDIR}"/pigpiod.confd pigpiod
+ systemd_newunit "${FILESDIR}"/pigpiod.systemd pigpiod.service
+ use python && distutils-r1_src_install
+}