summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-01-09 16:07:47 +0100
committerPacho Ramos <pacho@gentoo.org>2016-01-09 16:15:50 +0100
commitbee9ee5ff7e5e1655772286fb2153eb54f7f9bd9 (patch)
treea5e30e18ec147be478b4c49b2fbbcd6d13320534 /dev-libs
parentprofiles: drop mask for last-rited app-arch/ppmd (diff)
downloadgentoo-bee9ee5ff7e5e1655772286fb2153eb54f7f9bd9.tar.gz
gentoo-bee9ee5ff7e5e1655772286fb2153eb54f7f9bd9.tar.bz2
gentoo-bee9ee5ff7e5e1655772286fb2153eb54f7f9bd9.zip
dev-libs/libbsd: Version bump (#571294 by Chí-Thanh Christopher Nguyễn)
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libbsd/Manifest1
-rw-r--r--dev-libs/libbsd/libbsd-0.8.1.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-libs/libbsd/Manifest b/dev-libs/libbsd/Manifest
index 257d9c69a282..ea2adf348237 100644
--- a/dev-libs/libbsd/Manifest
+++ b/dev-libs/libbsd/Manifest
@@ -1,2 +1,3 @@
DIST libbsd-0.7.0.tar.xz 322908 SHA256 0f3b0e17e5c34c038126e0a04351b11e23c6101a7d0ce3beeab29bb6415c10bb SHA512 2c4c8fb2ae7fb5e5aab90f7a59a679220922dfeeaf0d54f80976914fcd507171bb9359f0837c32499e63a0f3e9342c9dcd387a466b359d20e3790ddc8ca17cea WHIRLPOOL 06083651f5678362d3422f96e59d30d8010493f9d1c8c43a94f7ab310daead491c70bce7838cc8302cb448e4a8fa99c7456f0ba9a3b411b292829ba949712b59
DIST libbsd-0.8.0.tar.xz 342016 SHA256 fbb732084bd960e4c78b688aac875be98e290cc6fe462b2ff8ee946a6473e38c SHA512 a2235cde4d24ce55b0ad16eb12b421c3b35ea5ca35cd8dbf25dd9a01f6a12c737b877c8e1dd344d4cfdfbbbc872d17424e3b9944993395d752fc0b80ead7d06a WHIRLPOOL 96e429eb7b44db5bce2def2ab7ef1a773d8dc630deb636e422e96c6521b61f37082b4889e564409e3af779d8d93a85cb54079a15a1415073fd65169a91593ad1
+DIST libbsd-0.8.1.tar.xz 343624 SHA256 adbc8781ad720bce939b689f38a9f0247732a36792147a7c28027c393c2af9b0 SHA512 8ae687cf6baf0364661d8452c0f2817ba9d7fc59fbf198aceda33d3b8575fd385e2915f145132b1a7fd43b18c0a7ba9306c98f0d98fc7e35412918df456364c6 WHIRLPOOL 6c05f9e59b8ba5b05f2b576f552db97d08c7433e98b555ba26202153f3a6b2f3366e4e2d91d912d71935ec8240e4e6053bf3177a3c973c697c68febe4982599f
diff --git a/dev-libs/libbsd/libbsd-0.8.1.ebuild b/dev-libs/libbsd/libbsd-0.8.1.ebuild
new file mode 100644
index 000000000000..04ded18ea535
--- /dev/null
+++ b/dev-libs/libbsd/libbsd-0.8.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils multilib
+
+DESCRIPTION="An library to provide useful functions commonly found on BSD systems"
+HOMEPAGE="http://libbsd.freedesktop.org/wiki/"
+SRC_URI="http://${PN}.freedesktop.org/releases/${P}.tar.xz"
+
+LICENSE="BSD BSD-2 BSD-4 ISC"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="static-libs"
+
+pkg_setup() {
+ local f="${ROOT}/usr/$(get_libdir)/${PN}.a"
+ local m="You need to remove ${f} by hand or re-emerge sys-libs/glibc first."
+ if ! has_version ${CATEGORY}/${PN}; then
+ if [[ -e ${f} ]]; then
+ eerror "${m}"
+ die "${m}"
+ fi
+ fi
+}
+
+src_configure() {
+ # The build system will install libbsd-ctor.a despite of USE="-static-libs"
+ # which is correct, see:
+ # http://cgit.freedesktop.org/libbsd/commit/?id=c5b959028734ca2281250c85773d9b5e1d259bc8
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}