summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChema Alonso Josa <nimiux@gentoo.org>2017-04-05 17:32:54 +0200
committerChema Alonso Josa <nimiux@gentoo.org>2017-04-05 17:32:54 +0200
commit9874f1a0376b39a24487a43c4aaa2eef338b02b7 (patch)
treead85e49494e53d59653ddef9aa958edf82f92dc4 /dev-lisp/flexi-streams
parentdev-lisp/trivial-gray-streams: Updates live ebuild EAPI (diff)
downloadgentoo-9874f1a0376b39a24487a43c4aaa2eef338b02b7.tar.gz
gentoo-9874f1a0376b39a24487a43c4aaa2eef338b02b7.tar.bz2
gentoo-9874f1a0376b39a24487a43c4aaa2eef338b02b7.zip
dev-lisp/flexi-streams: Bumps version to 1.0.16
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-lisp/flexi-streams')
-rw-r--r--dev-lisp/flexi-streams/Manifest1
-rw-r--r--dev-lisp/flexi-streams/flexi-streams-1.0.16.ebuild25
-rw-r--r--dev-lisp/flexi-streams/metadata.xml9
3 files changed, 35 insertions, 0 deletions
diff --git a/dev-lisp/flexi-streams/Manifest b/dev-lisp/flexi-streams/Manifest
index 30ec1d3d8849..524f4af1facb 100644
--- a/dev-lisp/flexi-streams/Manifest
+++ b/dev-lisp/flexi-streams/Manifest
@@ -1 +1,2 @@
DIST flexi-streams-1.0.15.tar.gz 135550 SHA256 1c9d8020cfd2bf0344e5baf1dff8b01aa7cefcdc5bc3765d029bd2e723d00251 SHA512 103e6c53f8c0ffd6d218e08e49fd49c21f420c1221912121dba1218d4631b6869357002fb1a18444e58283e2d6e59ae3f43d5a23c06c506538d69f4a178b3973 WHIRLPOOL d8a88f21b26079f86d5deb55cfeae0bc4c7f34d853e4b2a887eeb829f38e5be8d8902dea675caa7d373503f25c798b2492d6a1212fb58ea15e352e1c3c9b90fa
+DIST flexi-streams-1.0.16.tar.gz 135698 SHA256 bcaaa51d4f8e176f3a532d54c9bf7b6f031b2a18761e0fa9888395dc799660b9 SHA512 66b7c5231616c7a6095a52d6c679717795c9308e33487536a5e1b7f0d25f26aacd2579a76c351f8e16a967a0611456cbc97b3824f4d9cf4875b8e48b0c4f7c78 WHIRLPOOL 0e5bfdc0b2fb00de56cf0cd3d7feac06ce68c0476969249a5c1fec03918da81c2596d4af2d3aa945e7ccaf1464543fb7aa2d23abd187b2f6fa5dba24fc266178
diff --git a/dev-lisp/flexi-streams/flexi-streams-1.0.16.ebuild b/dev-lisp/flexi-streams/flexi-streams-1.0.16.ebuild
new file mode 100644
index 000000000000..722cdce44efd
--- /dev/null
+++ b/dev-lisp/flexi-streams/flexi-streams-1.0.16.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit common-lisp-3
+
+DESCRIPTION="Flexible bivalent streams for Common Lisp"
+HOMEPAGE="http://weitz.de/flexi-streams/
+ http://www.cliki.net/flexi-streams/"
+SRC_URI="https://github.com/edicl/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="!dev-lisp/cl-${PN}
+ >=dev-lisp/trivial-gray-streams-20060925"
+
+src_install() {
+ common-lisp-install-sources *.lisp
+ common-lisp-install-asdf
+ dodoc doc/index.html
+}
diff --git a/dev-lisp/flexi-streams/metadata.xml b/dev-lisp/flexi-streams/metadata.xml
index 1afc5a80b59f..245d1e7eb09a 100644
--- a/dev-lisp/flexi-streams/metadata.xml
+++ b/dev-lisp/flexi-streams/metadata.xml
@@ -12,6 +12,15 @@
encodings which can be changed on the fly. It also supplies
in-memory binary streams which are similar to string streams.
</longdescription>
+ <longdescription lang="es">
+ FLEXI-STREAMS implementa flujos de datos bivalentes "virtuales"
+ que se pueden superponer a flujos de datos binarios reales o
+ bivalentes y que pueden ser utilizados para leer y escribir datos
+ en caracteres en distintas codificaciones sencillas o multi-octeto
+ que a su vez se pueden cambiar al vuelo. TambiƩn proporciona flujos
+ de datos en memoria que son similares a los flujos de datos de
+ cadenas de caracteres.
+ </longdescription>
<upstream>
<remote-id type="github">edicl/flexi-streams</remote-id>
</upstream>