summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2020-08-06 20:03:35 +0300
committerJoonas Niilola <juippis@gentoo.org>2020-08-24 17:38:44 +0300
commit2513f4e45d12860e82dbe2d2022acc83d7842b82 (patch)
tree74e19a6fb5b5ed10a79bbdaa2afc92bb62dfe5c7 /dev-lua/luaposix
parentdev-lua/lua-bit32: new package (diff)
downloadgentoo-2513f4e45d12860e82dbe2d2022acc83d7842b82.tar.gz
gentoo-2513f4e45d12860e82dbe2d2022acc83d7842b82.tar.bz2
gentoo-2513f4e45d12860e82dbe2d2022acc83d7842b82.zip
dev-lua/luaposix: new version 35.0
New version, new maintainer, added dependency dev-lua/lua-bit32 (#603812), changed license to MIT. Closes: https://bugs.gentoo.org/603812 Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Azamat H. Hackimov <azamat.hackimov@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-lua/luaposix')
-rw-r--r--dev-lua/luaposix/Manifest1
-rw-r--r--dev-lua/luaposix/luaposix-35.0.ebuild35
-rw-r--r--dev-lua/luaposix/metadata.xml15
3 files changed, 47 insertions, 4 deletions
diff --git a/dev-lua/luaposix/Manifest b/dev-lua/luaposix/Manifest
index bf3cf9b13a23..1a023e34a2ec 100644
--- a/dev-lua/luaposix/Manifest
+++ b/dev-lua/luaposix/Manifest
@@ -1 +1,2 @@
DIST luaposix-33.4.0.tar.gz 643523 BLAKE2B e407363eb6410d2636024371a169eefe8d0bc633b9fcbad6c2e7edb413b4aa0fc681e94b35c9ea39a561ecdcf225af1033ded1c67d87cd57bed2ba3e0d795aab SHA512 3cb78ccb343a55e2bf5b182410e2050356379e8f7a86d42a79853db6198628cae85f9984854f99f41505cb7e4fbb5288e4a46633a6db459649837729af76044c
+DIST luaposix-35.0.tar.gz 178091 BLAKE2B b2d2ca01f18f0e98b45008919fc886e05d2cad034c84e870900c33891dd5867d9bc7aa8deae06c3f3f0852db902c1e766e693162b32ed474eb710b379bf9e3ed SHA512 4bb61892b78d9e59418a9a6360b9f611fb9b5438b9261a2c6672f053a1b21dfd9a2060b8d2f0d3eac6185773cf84672c1769c081c4ab53d2ddae2232e4a9269b
diff --git a/dev-lua/luaposix/luaposix-35.0.ebuild b/dev-lua/luaposix/luaposix-35.0.ebuild
new file mode 100644
index 000000000000..a49f69845d1a
--- /dev/null
+++ b/dev-lua/luaposix/luaposix-35.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Bindings for POSIX APIs"
+HOMEPAGE="https://luaposix.github.io/luaposix/ https://github.com/luaposix/luaposix"
+SRC_URI="https://github.com/luaposix/luaposix/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="dev-lang/lua:0=
+ dev-lua/lua-bit32"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_compile() {
+ ./build-aux/luke package="${PN}" version="${PV}" \
+ PREFIX="${ED}/usr" \
+ INST_LIBDIR="${ED}/$($(tc-getPKG_CONFIG) --variable INSTALL_CMOD lua)" \
+ INST_LUADIR="${ED}/$($(tc-getPKG_CONFIG) --variable INSTALL_LMOD lua)" \
+ CFLAGS="${CFLAGS}" CC="$(tc-getCC)" || die
+}
+
+src_install() {
+ ./build-aux/luke install \
+ PREFIX="${ED}/usr" \
+ INST_LIBDIR="${ED}/$($(tc-getPKG_CONFIG) --variable INSTALL_CMOD lua)" \
+ INST_LUADIR="${ED}/$($(tc-getPKG_CONFIG) --variable INSTALL_LMOD lua)" \
+ || die
+ dodoc -r doc NEWS.md README.md
+}
diff --git a/dev-lua/luaposix/metadata.xml b/dev-lua/luaposix/metadata.xml
index 55f9ea8cfb05..142f40aa2588 100644
--- a/dev-lua/luaposix/metadata.xml
+++ b/dev-lua/luaposix/metadata.xml
@@ -1,8 +1,15 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
- <upstream>
- <remote-id type="github">luaposix/luaposix</remote-id>
- </upstream>
+ <maintainer type="person">
+ <email>azamat.hackimov@gmail.com</email>
+ <name>Azamat H. Hackimov</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">luaposix/luaposix</remote-id>
+ </upstream>
</pkgmetadata>