summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2019-02-07 13:10:09 -0500
committerBrian Evans <grknight@gentoo.org>2019-02-07 13:10:09 -0500
commit51b32bb9d4bd111a3400fab7cdc68c2c881ba29c (patch)
tree6d8432fc91060e4f0fac3c2fe866f3d0581c96ca /dev-lua
parentmedia-plugins/kodi-pvr-mythtv: 5.10.6 version bump (diff)
downloadgentoo-51b32bb9d4bd111a3400fab7cdc68c2c881ba29c.tar.gz
gentoo-51b32bb9d4bd111a3400fab7cdc68c2c881ba29c.tar.bz2
gentoo-51b32bb9d4bd111a3400fab7cdc68c2c881ba29c.zip
dev-lua/luadbi: Revbump for dependency and EAPI change
Bug: https://bugs.gentoo.org/665884 Package-Manager: Portage-2.3.59, Repoman-2.3.12 Signed-off-by: Brian Evans <grknight@gentoo.org>
Diffstat (limited to 'dev-lua')
-rw-r--r--dev-lua/luadbi/files/0.5-r2-Makefile.patch4
-rw-r--r--dev-lua/luadbi/luadbi-0.5-r6.ebuild66
2 files changed, 68 insertions, 2 deletions
diff --git a/dev-lua/luadbi/files/0.5-r2-Makefile.patch b/dev-lua/luadbi/files/0.5-r2-Makefile.patch
index b37b3c00efe..98e4988b281 100644
--- a/dev-lua/luadbi/files/0.5-r2-Makefile.patch
+++ b/dev-lua/luadbi/files/0.5-r2-Makefile.patch
@@ -1,5 +1,5 @@
---- Makefile.orig 2013-02-01 13:34:54.490898002 +0400
-+++ Makefile 2013-02-01 13:44:25.927772130 +0400
+--- a/Makefile 2013-02-01 13:34:54.490898002 +0400
++++ b/Makefile 2013-02-01 13:44:25.927772130 +0400
@@ -1,5 +1,6 @@
CC=gcc
-CFLAGS=-g -pedantic -Wall -O2 -shared -fpic -I /usr/include/lua5.1 -I /usr/include/mysql -I /usr/include/postgresql/ -I /opt/ibm/db2exc/V9.5/include/ -I /usr/lib/oracle/xe/app/oracle/product/10.2.0/client/rdbms/public/ -I .
diff --git a/dev-lua/luadbi/luadbi-0.5-r6.ebuild b/dev-lua/luadbi/luadbi-0.5-r6.ebuild
new file mode 100644
index 00000000000..2f194b5ab36
--- /dev/null
+++ b/dev-lua/luadbi/luadbi-0.5-r6.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs flag-o-matic
+
+DESCRIPTION="DBI module for Lua"
+HOMEPAGE="https://code.google.com/p/luadbi/"
+SRC_URI="https://luadbi.googlecode.com/files/${PN}.${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="mysql postgres +sqlite"
+REQUIRED_USE="|| ( mysql postgres sqlite )"
+
+RDEPEND=">=dev-lang/lua-5.1
+ mysql? ( dev-db/mysql-connector-c:0= )
+ postgres? ( dev-db/postgresql )
+ sqlite? ( >=dev-db/sqlite-3 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}"
+
+PATCHES=( "${FILESDIR}"/${PV}-r2-Makefile.patch )
+
+src_prepare() {
+ default
+ local pkgconf=$(tc-getPKG_CONFIG)
+ sed -i -e "s#^INSTALL_DIR_LUA=.*#INSTALL_DIR_LUA=$(${pkgconf} --variable INSTALL_LMOD lua)#" \
+ -e "s#^INSTALL_DIR_BIN=.*#INSTALL_DIR_BIN=$(${pkgconf} --variable INSTALL_CMOD lua)#" \
+ -e "s#^LUA_INC_DIR=.*#LUA_INC_DIR=$(${pkgconf} --variable INSTALL_INC lua)#" \
+ -e "s#^LUA_LIB_DIR=.*#LUA_LIB_DIR=$(${pkgconf} --variable INSTALL_LIB lua)#" \
+ -e "s#^LUA_LIB =.*#LUA_LIB=lua#" Makefile || die
+
+ drivers=""
+
+ if use mysql; then
+ drivers+="mysql "
+ sed -i -e "s#^\(INCLUDES.*\)#\1 $(mysql_config --include)#" \
+ -e "s#^\(MYSQL_LDFLAGS=\$(COMMON_LDFLAGS)\).*#\1 $(mysql_config --libs)#" Makefile || die
+ fi
+
+ if use postgres; then
+ drivers+="psql "
+ sed -i -e "s#^\(INCLUDES.*\)#\1 -I$(pg_config --includedir) -I$(pg_config --includedir-server)#" \
+ -e "s#^\(PSQL_LDFLAGS=\$(COMMON_LDFLAGS)\).*#\1 -L$(pg_config --libdir) -lpq#" Makefile || die
+ fi
+
+ use sqlite && drivers+="sqlite3"
+}
+
+src_compile() {
+ append-flags -fPIC
+ for driver in ${drivers}; do
+ emake CC="$(tc-getCC)" COMMON_LDFLAGS="${LDFLAGS}" ${driver}
+ done
+}
+
+src_install() {
+ for driver in ${drivers}; do
+ emake DESTDIR="${D}" "install_${driver// /}"
+ done
+}