summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-04-01 23:50:50 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-04-02 10:38:03 +0200
commit16548bfb167cf35e6d365fd4a08d8a82e40a352f (patch)
tree7b0fb92f580d03ad5f26d3e4f6ccbe1cbca8c22b /dev-ml/async_js
parentdev-ml/js_of_ocaml: Fix build with latest ppx tools. (diff)
downloadgentoo-16548bfb167cf35e6d365fd4a08d8a82e40a352f.tar.gz
gentoo-16548bfb167cf35e6d365fd4a08d8a82e40a352f.tar.bz2
gentoo-16548bfb167cf35e6d365fd4a08d8a82e40a352f.zip
dev-ml/async_js: initial import
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-ml/async_js')
-rw-r--r--dev-ml/async_js/Manifest1
-rw-r--r--dev-ml/async_js/async_js-0.9.0.ebuild35
-rw-r--r--dev-ml/async_js/metadata.xml8
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-ml/async_js/Manifest b/dev-ml/async_js/Manifest
new file mode 100644
index 000000000000..3cee5895782e
--- /dev/null
+++ b/dev-ml/async_js/Manifest
@@ -0,0 +1 @@
+DIST async_js-0.9.0.tar.gz 13597 SHA256 29b24ac1395754a9445b127225a82ebb0aa15b5c0d8783d32ce45090931931cc SHA512 f188a023e105d409c10ff1517eba5f7c543ed1bdb9e81863569c34d911379cc00b704b8b9081e0041dac2e63dc48efc01763f199de5e5b8693533d2815fe2b4b WHIRLPOOL 1abd7e710010afb3fd1cdb7a0eabad2f6c3cd190a2068a63f3df3e4a884a786f4b1693a1893b3b91fbf2f9e02dcf5215b0f3ff01d9b11714b1d1516e566ad539
diff --git a/dev-ml/async_js/async_js-0.9.0.ebuild b/dev-ml/async_js/async_js-0.9.0.ebuild
new file mode 100644
index 000000000000..fecdc074310d
--- /dev/null
+++ b/dev-ml/async_js/async_js-0.9.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Async support for JavaScript platforms"
+HOMEPAGE="https://github.com/janestreet/async_js"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ dev-lang/ocaml:=
+ dev-ml/async_kernel:=
+ dev-ml/async_rpc_kernel:=
+ dev-ml/ppx_driver:=
+ dev-ml/ppx_jane:=
+ dev-ml/js_of_ocaml:=
+ dev-ml/ocaml-migrate-parsetree:=
+"
+DEPEND="${RDEPEND}
+ dev-ml/opam
+ dev-ml/jbuilder
+"
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ ${PN}.install || die
+}
diff --git a/dev-ml/async_js/metadata.xml b/dev-ml/async_js/metadata.xml
new file mode 100644
index 000000000000..ffac4d7ebc01
--- /dev/null
+++ b/dev-ml/async_js/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>Gentoo ML Project</name>
+</maintainer>
+</pkgmetadata>