summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-06-23 14:22:29 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-06-23 14:31:21 +0200
commit4fd0cda1b6706cf4ab4c4052df7eca5c538c8897 (patch)
tree63e7df7abe4f516f7e1baac6dcd88b1ebdc67d45 /dev-ml/atd
parentdev-python/lxml: Remove old (diff)
downloadgentoo-4fd0cda1b6706cf4ab4c4052df7eca5c538c8897.tar.gz
gentoo-4fd0cda1b6706cf4ab4c4052df7eca5c538c8897.tar.bz2
gentoo-4fd0cda1b6706cf4ab4c4052df7eca5c538c8897.zip
dev-ml/atd: bump to 1.12.0
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-ml/atd')
-rw-r--r--dev-ml/atd/Manifest1
-rw-r--r--dev-ml/atd/atd-1.12.0.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-ml/atd/Manifest b/dev-ml/atd/Manifest
index e529ea6d8148..315dc2fac7bd 100644
--- a/dev-ml/atd/Manifest
+++ b/dev-ml/atd/Manifest
@@ -1,2 +1,3 @@
+DIST atd-1.12.0.tar.gz 145428 SHA256 3e81d562e74374b98c0f383c1ded46beb06d8416d2065645fd68d3b8b0238ddd SHA512 c24601b276da7837bc896bb42b2e0fa91ebfbf07759560c2490ed44bef722dcf8d586aaba1e62abff262805cab89996835611ab9fb68aa096dfc84bb55365475 WHIRLPOOL c39967976d80053680004e8c912af1d37da96e97f76e7056a89fb996ff629aec367ba68cc9783932b9fb49918ed60ef209a80af975535bc0382255e80b7d79c7
DIST atd-1.2.0.tar.gz 41300 SHA256 488e06e406824efab12f53845b648c1a592c2c8349d4ac1e12b94ce61e7453e9 SHA512 a52824c9784ac0f4d6f314972fa1d92be14730de3c6bde04032004579ac27408385bd4fa7d926f9d564657eb62050fd732a032f364bada62a1dc7a8acfacb727 WHIRLPOOL b0fe31df2282e5533c6c5bc769a9dfedfc60b5457ccf5e0b7fed82d1da287b72cee3bf1133891e2abe674afb70df781a94200e17bdb0011a45af3f492ae38b1e
DIST atd-1.2.1.tar.gz 39018 SHA256 515663f1c48c3592e360079f92eea6db82d3d989f1df19b45e8179aec0d48e34 SHA512 5dde8dd1e6ca53ae2ff7efc873211079678a824ae7a9d4182d58e3e10ce50a9dcd705de7168a8cfb12ea3d030a0d01b2485d436e77bfa48c14df7628b47161dc WHIRLPOOL 666cb45158769c98f1bd6b30e045447441cea0cfd54d803b88a3e1ae3b2fd355e351f5cfa5e86c8f96e9dbf44d56920748b639f31f7b4787f0d5f634ef7c2c57
diff --git a/dev-ml/atd/atd-1.12.0.ebuild b/dev-ml/atd/atd-1.12.0.ebuild
new file mode 100644
index 000000000000..da91321baad5
--- /dev/null
+++ b/dev-ml/atd/atd-1.12.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit findlib
+
+DESCRIPTION="Syntax for cross-language type definitions"
+HOMEPAGE="https://github.com/mjambon/atd"
+SRC_URI="https://github.com/mjambon/atd/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt"
+
+DEPEND="
+ dev-lang/ocaml:=[ocamlopt?]
+ dev-ml/easy-format:=[ocamlopt?]
+ dev-ml/menhir:=[ocamlopt?]
+ dev-ml/biniou:=
+ dev-ml/yojson:=
+ !dev-ml/atdgen
+"
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND}
+ dev-ml/jbuilder
+ dev-ml/opam
+"
+
+oinstall() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ ${1}.install || die
+}
+
+src_install() {
+ oinstall atd
+ oinstall atdgen
+}