summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-06-23 14:29:50 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-06-23 14:31:21 +0200
commit12af6772dd5fd574a4971da2fab398645c48405a (patch)
tree31254b5582442d1ce429322c3a1bd1188d51717f /dev-ml/atdgen/atdgen-1.12.0.ebuild
parentdev-ml/atd: split atdgen again (diff)
downloadgentoo-12af6772dd5fd574a4971da2fab398645c48405a.tar.gz
gentoo-12af6772dd5fd574a4971da2fab398645c48405a.tar.bz2
gentoo-12af6772dd5fd574a4971da2fab398645c48405a.zip
dev-ml/atdgen: bump to 1.12.0
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-ml/atdgen/atdgen-1.12.0.ebuild')
-rw-r--r--dev-ml/atdgen/atdgen-1.12.0.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-ml/atdgen/atdgen-1.12.0.ebuild b/dev-ml/atdgen/atdgen-1.12.0.ebuild
new file mode 100644
index 000000000000..7c98c9ed8ad7
--- /dev/null
+++ b/dev-ml/atdgen/atdgen-1.12.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit findlib
+
+DESCRIPTION="Generates optimized boilerplate OCaml code for JSON and Biniou IO from type definitions"
+HOMEPAGE="https://github.com/mjambon/atd"
+SRC_URI="https://github.com/mjambon/atd/archive/v${PV}.tar.gz -> atd-${PV}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt"
+
+DEPEND="
+ dev-lang/ocaml:=[ocamlopt?]
+ dev-ml/atd:=
+ dev-ml/biniou:=
+ dev-ml/yojson:=
+"
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND}
+ dev-ml/jbuilder
+ dev-ml/opam
+"
+
+S="${WORKDIR}/atd-${PV}"
+
+src_compile() {
+ jbuilder build -p atdgen || die
+}
+
+oinstall() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ ${1}.install || die
+}
+
+src_install() {
+ oinstall atdgen
+}