summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-06-26 13:10:03 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-06-26 13:43:22 +0200
commit4a51666e5848f25f06ca29517492be77890bb07c (patch)
tree9d327d4e5bcc1f973403c9ac6ca9e4c45df5a6a9 /dev-ml/camlp5/camlp5-7.00.ebuild
parentdev-util/jenkins-bin: Bump (diff)
downloadgentoo-4a51666e5848f25f06ca29517492be77890bb07c.tar.gz
gentoo-4a51666e5848f25f06ca29517492be77890bb07c.tar.bz2
gentoo-4a51666e5848f25f06ca29517492be77890bb07c.zip
dev-ml/camlp5: Bump to 7.00
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-ml/camlp5/camlp5-7.00.ebuild')
-rw-r--r--dev-ml/camlp5/camlp5-7.00.ebuild65
1 files changed, 65 insertions, 0 deletions
diff --git a/dev-ml/camlp5/camlp5-7.00.ebuild b/dev-ml/camlp5/camlp5-7.00.ebuild
new file mode 100644
index 000000000000..c0f52ab10e7f
--- /dev/null
+++ b/dev-ml/camlp5/camlp5-7.00.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit multilib findlib eutils versionator
+
+MY_P=${P%_p*}
+DESCRIPTION="A preprocessor-pretty-printer of ocaml"
+HOMEPAGE="https://camlp5.github.io/"
+SRC_URI="https://github.com/camlp5/camlp5/archive/rel$(replace_all_version_separators '').tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-rel$(replace_all_version_separators '')"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE="doc +ocamlopt"
+
+DEPEND=">=dev-lang/ocaml-3.10:=[ocamlopt?]"
+RDEPEND="${DEPEND}"
+
+PATCHLEVEL=${PV#*_p}
+PATCHLIST=""
+
+if [ "${PATCHLEVEL}" != "${PV}" ] ; then
+ for (( i=1; i<=PATCHLEVEL; i++ )) ; do
+ SRC_URI="${SRC_URI}
+ http://pauillac.inria.fr/~ddr/camlp5/distrib/src/patch-${PV%_p*}-${i} -> ${MY_P}-patch-${i}.patch"
+ PATCHLIST="${PATCHLIST} ${MY_P}-patch-${i}.patch"
+ done
+fi
+
+src_prepare() {
+ for i in ${PATCHLIST} ; do
+ epatch "${DISTDIR}/${i}"
+ done
+}
+
+src_configure() {
+ ./configure \
+ --strict \
+ -prefix /usr \
+ -bindir /usr/bin \
+ -libdir /usr/$(get_libdir)/ocaml \
+ -mandir /usr/share/man || die "configure failed"
+}
+
+src_compile(){
+ emake out
+ if use ocamlopt; then
+ emake opt
+ emake opt.opt
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ # findlib support
+ insinto "$(ocamlfind printconf destdir)/${PN}"
+ doins etc/META
+
+ use doc && dohtml -r doc/*
+
+ dodoc CHANGES DEVEL ICHANGES README UPGRADING MODE
+}