summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-04-30 20:07:26 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-04-30 20:07:36 +0200
commitb7e586a2ff0a4b1a699069dd38c1592f625ceacf (patch)
treeb28b8d5fbac2de782dba1589f0e238d57b135ca4 /dev-ml/camlp5
parentsys-kernel/hardened-sources: remove oldest stable version (diff)
downloadgentoo-b7e586a2ff0a4b1a699069dd38c1592f625ceacf.tar.gz
gentoo-b7e586a2ff0a4b1a699069dd38c1592f625ceacf.tar.bz2
gentoo-b7e586a2ff0a4b1a699069dd38c1592f625ceacf.zip
dev-ml/camlp5: bump to 6.16
Package-Manager: portage-2.2.28 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ml/camlp5')
-rw-r--r--dev-ml/camlp5/Manifest1
-rw-r--r--dev-ml/camlp5/camlp5-6.16.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/dev-ml/camlp5/Manifest b/dev-ml/camlp5/Manifest
index d38913a38e42..f4fb00163fb5 100644
--- a/dev-ml/camlp5/Manifest
+++ b/dev-ml/camlp5/Manifest
@@ -1,2 +1,3 @@
DIST camlp5-6.14.tgz 748674 SHA256 09f9ed12893d2ec39c88106af2306865c966096bedce0250f2fe52b67d2480e2 SHA512 7dd57b8725953099726fc2e5f6dda01ed74485a4bbf41cb30ccd2163ee38bc6dff36fd83069c58d7990522527d266c9e180a8e333b36a42bc216315dc88a25e9 WHIRLPOOL 305bb842e449775352cbbf3c89a301a188419c10462f0959b00e181596218b5251dac50856f152ad471fd680e557e6595978c395e9c2864c38ddacd7287c4e3b
DIST camlp5-6.15.tgz 756199 SHA256 2e0e1e31e0537f2179766820dd9bd0a4d424bc5ab9c610e6dbf9145f27747f2b SHA512 658ff32d1d124e91e85d8eba47039bb75573b3807d67fae723335bb06d3237c4151f6d671fb3b068ec4ebffdde03f7956174c9f0ca29eafa5990974987bc2aca WHIRLPOOL d449b7a485967b79efbc030527513d99dd19d4856ebc132133d09d7028c210b4314ac401de65ac7671d3066f6a2184df157a0091fc173f4d6e7ae8bc7ad2c432
+DIST camlp5-6.16.tgz 759877 SHA256 fd446cff6421f5144a521c7cecfdc7217b1424908186cddd3d5be543b35058b1 SHA512 b1bfa271bb7df169c5b0d0f0a20038ab95c2101475e1729f5a779fea0872165f73b04e0cd792e9fbc31e81bb37cbef06a9761f7748ea1ab87753dbd20202d5ed WHIRLPOOL 433a85b393ee6498c6ab86b7feb2cfec8188526ca628c796efafd1d1c9f6204e737074a63e9e448ef757ba9b7b1dce06433b58278352155f5405ea4a76bb6303
diff --git a/dev-ml/camlp5/camlp5-6.16.ebuild b/dev-ml/camlp5/camlp5-6.16.ebuild
new file mode 100644
index 000000000000..4fcf3b9f748d
--- /dev/null
+++ b/dev-ml/camlp5/camlp5-6.16.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit multilib findlib eutils
+
+MY_P=${P%_p*}
+DESCRIPTION="A preprocessor-pretty-printer of ocaml"
+HOMEPAGE="http://camlp5.gforge.inria.fr/"
+SRC_URI="http://camlp5.gforge.inria.fr/distrib/src/${MY_P}.tgz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE="doc +ocamlopt"
+
+DEPEND=">=dev-lang/ocaml-3.10:=[ocamlopt?]"
+RDEPEND="${DEPEND}"
+
+PATCHLEVEL=${PV#*_p}
+PATCHLIST=""
+
+if [ "${PATCHLEVEL}" != "${PV}" ] ; then
+ for (( i=1; i<=PATCHLEVEL; i++ )) ; do
+ SRC_URI="${SRC_URI}
+ http://pauillac.inria.fr/~ddr/camlp5/distrib/src/patch-${PV%_p*}-${i} -> ${MY_P}-patch-${i}.patch"
+ PATCHLIST="${PATCHLIST} ${MY_P}-patch-${i}.patch"
+ done
+fi
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ for i in ${PATCHLIST} ; do
+ epatch "${DISTDIR}/${i}"
+ done
+}
+
+src_configure() {
+ ./configure \
+ --strict \
+ -prefix /usr \
+ -bindir /usr/bin \
+ -libdir /usr/$(get_libdir)/ocaml \
+ -mandir /usr/share/man || die "configure failed"
+}
+
+src_compile(){
+ emake out
+ if use ocamlopt; then
+ emake opt
+ emake opt.opt
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ # findlib support
+ insinto "$(ocamlfind printconf destdir)/${PN}"
+ doins etc/META
+
+ use doc && dohtml -r doc/*
+
+ dodoc CHANGES DEVEL ICHANGES README UPGRADING MODE
+}