summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-04-01 19:13:59 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-04-02 10:38:01 +0200
commiteaade94eb1e80eb9f563563bafc3c9807ffc3e6d (patch)
treea09ce55d02906515fa93ea3a16d18f0936513136 /dev-ml/core_profiler
parentdev-ml/bignum: Bump to 0.9.0 (diff)
downloadgentoo-eaade94eb1e80eb9f563563bafc3c9807ffc3e6d.tar.gz
gentoo-eaade94eb1e80eb9f563563bafc3c9807ffc3e6d.tar.bz2
gentoo-eaade94eb1e80eb9f563563bafc3c9807ffc3e6d.zip
dev-ml/core_profiler: Bump to 0.9.0
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-ml/core_profiler')
-rw-r--r--dev-ml/core_profiler/Manifest3
-rw-r--r--dev-ml/core_profiler/core_profiler-0.9.0.ebuild33
-rw-r--r--dev-ml/core_profiler/core_profiler-113.33.00.ebuild56
-rw-r--r--dev-ml/core_profiler/core_profiler-113.33.03.ebuild56
4 files changed, 34 insertions, 114 deletions
diff --git a/dev-ml/core_profiler/Manifest b/dev-ml/core_profiler/Manifest
index b8ba15e8e298..c206cb3317a9 100644
--- a/dev-ml/core_profiler/Manifest
+++ b/dev-ml/core_profiler/Manifest
@@ -1,2 +1 @@
-DIST core_profiler-113.33.00.tar.gz 109835 SHA256 f170ca83f1d30017755b88251c52a2cbe473d57e1229ba48db29fe886412ee54 SHA512 9ebdf6066f0501db3fc258a8b1e6c4bb904cad55194946f28dca17be6dfee3ff428b7e9b6d0563ac7114cc403aee1281253ef50b998a5e12aabbce6fde9e7deb WHIRLPOOL 8d6a927055d51c8be1d8ef3e64e44f266d4f4747dc6d1d20d84d858435d001d4187bbdb9ae05dae4fcd80b6d21391576312cbad5ee6c1779183af4ec564dd222
-DIST core_profiler-113.33.03.tar.gz 108242 SHA256 2325f58a40a031c7bf27dd103ef076d4132deb9e450fb2a11030654760e2ff7c SHA512 fb17cfec3bed449106cf65bd6155f7390f362da6d2ed88971b769344b02c669cb822ecf0ed2b0595953b4148394f60c4de710285046e40c055db80fe73c4014b WHIRLPOOL a6b9ee8e3c31bbe277587f1fc7b30ba761743ce39ae797ccf0901b222b2303c19d110297ad45919fb4cf43c084cb7fa58dc2f58895726eb709bc2991878f3f75
+DIST core_profiler-0.9.0.tar.gz 60467 SHA256 57943906e5cfcbe0b77f8d0d30333877b47bbe2e9411e83a3706feb9b6bb3deb SHA512 6d3ad9cef7dd500642bf139503fc873668ca69733c29a4bcb224b27cad604422d87626431f38f29088807f577c4a6445fdc67531329bbcd842b0921976cbe5f9 WHIRLPOOL ee568c46f45dd2ac2a2bb432cb1a43c2c2aafa2112e2d4b6e1dff5bd6432615548897d2c098d8112ce8c72e9279e6936c9103c007ac5e8155096315a83ace010
diff --git a/dev-ml/core_profiler/core_profiler-0.9.0.ebuild b/dev-ml/core_profiler/core_profiler-0.9.0.ebuild
new file mode 100644
index 000000000000..bf5b496ea736
--- /dev/null
+++ b/dev-ml/core_profiler/core_profiler-0.9.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Jane Street's profiling library"
+HOMEPAGE="https://github.com/janestreet/core_profiler"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ dev-lang/ocaml:=
+ dev-ml/core:=
+ dev-ml/core_extended:=
+ dev-ml/ppx_driver:=
+ dev-ml/ppx_jane:=
+ dev-ml/re2:=
+ dev-ml/textutils:=
+ dev-ml/ocaml-migrate-parsetree:=
+ "
+DEPEND="${RDEPEND} dev-ml/opam dev-ml/jbuilder"
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ ${PN}.install || die
+}
diff --git a/dev-ml/core_profiler/core_profiler-113.33.00.ebuild b/dev-ml/core_profiler/core_profiler-113.33.00.ebuild
deleted file mode 100644
index 17d2bf4b652c..000000000000
--- a/dev-ml/core_profiler/core_profiler-113.33.00.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-OASIS_BUILD_DOCS=1
-OASIS_BUILD_TESTS=1
-
-inherit eutils oasis
-
-MY_P=${P/_/\~}
-DESCRIPTION="Jane Street's profiling library"
-HOMEPAGE="http://www.janestreet.com/ocaml"
-SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV%.*}/files/${P}.tar.gz"
-
-LICENSE="LGPL-2.1-with-linking-exception"
-SLOT="0/${PV}"
-KEYWORDS="~amd64"
-IUSE=""
-
-RDEPEND="
- dev-ml/core:=
- dev-ml/core_extended:=
- dev-ml/bin-prot:=
- dev-ml/fieldslib:=
- dev-ml/ppx_assert:=
- dev-ml/ppx_bench:=
- dev-ml/ppx_driver:=
- dev-ml/ppx_expect:=
- dev-ml/ppx_inline_test:=
- dev-ml/ppx_jane:=
- dev-ml/re2:=
- dev-ml/sexplib:=
- dev-ml/textutils:=
- dev-ml/typerep:=
- dev-ml/variantslib:=
- "
-DEPEND="${RDEPEND} dev-ml/opam"
-
-src_configure() {
- emake setup.exe
- OASIS_SETUP_COMMAND="./setup.exe" oasis_src_configure
-}
-
-src_compile() {
- emake
-}
-
-src_install() {
- opam-installer -i \
- --prefix="${ED}/usr" \
- --libdir="${D}/$(ocamlc -where)" \
- --docdir="${ED}/usr/share/doc/${PF}" \
- ${PN}.install || die
- dodoc CHANGES.md
-}
diff --git a/dev-ml/core_profiler/core_profiler-113.33.03.ebuild b/dev-ml/core_profiler/core_profiler-113.33.03.ebuild
deleted file mode 100644
index 311df974de96..000000000000
--- a/dev-ml/core_profiler/core_profiler-113.33.03.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-OASIS_BUILD_DOCS=1
-OASIS_BUILD_TESTS=1
-
-inherit eutils oasis
-
-MY_P=${P/_/\~}
-DESCRIPTION="Jane Street's profiling library"
-HOMEPAGE="http://www.janestreet.com/ocaml"
-SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV%.*}/files/${P}.tar.gz"
-
-LICENSE="LGPL-2.1-with-linking-exception"
-SLOT="0/${PV}"
-KEYWORDS="~amd64"
-IUSE=""
-
-RDEPEND="
- dev-ml/core:=
- dev-ml/core_extended:=
- dev-ml/bin-prot:=
- dev-ml/fieldslib:=
- dev-ml/ppx_assert:=
- dev-ml/ppx_bench:=
- dev-ml/ppx_driver:=
- dev-ml/ppx_expect:=
- dev-ml/ppx_inline_test:=
- dev-ml/ppx_jane:=
- dev-ml/re2:=
- dev-ml/sexplib:=
- dev-ml/textutils:=
- dev-ml/typerep:=
- dev-ml/variantslib:=
- "
-DEPEND="${RDEPEND} dev-ml/opam"
-
-src_configure() {
- emake setup.exe
- OASIS_SETUP_COMMAND="./setup.exe" oasis_src_configure
-}
-
-src_compile() {
- emake
-}
-
-src_install() {
- opam-installer -i \
- --prefix="${ED}/usr" \
- --libdir="${D}/$(ocamlc -where)" \
- --docdir="${ED}/usr/share/doc/${PF}" \
- ${PN}.install || die
- dodoc CHANGES.md
-}