summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-03-08 22:59:46 +0100
committerMichał Górny <mgorny@gentoo.org>2018-03-08 23:18:53 +0100
commit612b4fa3ec6076369e2cc87ba5dad1f89e773486 (patch)
tree4e50bf678bb03adec503eea7aeb902afbb530f6e /dev-ml/llvm-ocaml
parentsys-devel/llvm: Control lit job count (diff)
downloadgentoo-612b4fa3ec6076369e2cc87ba5dad1f89e773486.tar.gz
gentoo-612b4fa3ec6076369e2cc87ba5dad1f89e773486.tar.bz2
gentoo-612b4fa3ec6076369e2cc87ba5dad1f89e773486.zip
dev-ml/llvm-ocaml: Control lit job count
Closes: https://bugs.gentoo.org/649554
Diffstat (limited to 'dev-ml/llvm-ocaml')
-rw-r--r--dev-ml/llvm-ocaml/llvm-ocaml-6.0.9999.ebuild4
-rw-r--r--dev-ml/llvm-ocaml/llvm-ocaml-9999.ebuild6
2 files changed, 5 insertions, 5 deletions
diff --git a/dev-ml/llvm-ocaml/llvm-ocaml-6.0.9999.ebuild b/dev-ml/llvm-ocaml/llvm-ocaml-6.0.9999.ebuild
index 649569541d6a..a2e4b9a3c0e6 100644
--- a/dev-ml/llvm-ocaml/llvm-ocaml-6.0.9999.ebuild
+++ b/dev-ml/llvm-ocaml/llvm-ocaml-6.0.9999.ebuild
@@ -8,7 +8,7 @@ EAPI=6
CMAKE_MIN_VERSION=3.7.0-r1
PYTHON_COMPAT=( python2_7 )
-inherit cmake-utils git-r3 llvm python-any-r1
+inherit cmake-utils git-r3 llvm multiprocessing python-any-r1
DESCRIPTION="OCaml bindings for LLVM"
HOMEPAGE="https://llvm.org/"
@@ -88,7 +88,7 @@ src_configure() {
)
use test && mycmakeargs+=(
- -DLLVM_LIT_ARGS="-vv"
+ -DLLVM_LIT_ARGS="-vv;-j;${LIT_JOBS:-$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")}"
)
# LLVM_ENABLE_ASSERTIONS=NO does not guarantee this for us, #614844
diff --git a/dev-ml/llvm-ocaml/llvm-ocaml-9999.ebuild b/dev-ml/llvm-ocaml/llvm-ocaml-9999.ebuild
index 6901bd11fb00..6fa322a6fd10 100644
--- a/dev-ml/llvm-ocaml/llvm-ocaml-9999.ebuild
+++ b/dev-ml/llvm-ocaml/llvm-ocaml-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -8,7 +8,7 @@ EAPI=6
CMAKE_MIN_VERSION=3.7.0-r1
PYTHON_COMPAT=( python2_7 )
-inherit cmake-utils git-r3 llvm python-any-r1
+inherit cmake-utils git-r3 llvm multiprocessing python-any-r1
DESCRIPTION="OCaml bindings for LLVM"
HOMEPAGE="https://llvm.org/"
@@ -92,7 +92,7 @@ src_configure() {
)
use test && mycmakeargs+=(
- -DLLVM_LIT_ARGS="-vv"
+ -DLLVM_LIT_ARGS="-vv;-j;${LIT_JOBS:-$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")}"
)
# LLVM_ENABLE_ASSERTIONS=NO does not guarantee this for us, #614844